aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-06 10:37:14 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-06 10:37:14 +0000
commit2df0d56decc96f4d67822824228dee1751b62466 (patch)
tree0a19418f547e53f7b135e4163e0d0beb61c33640 /chinese
parentb2396e23039c1250f878a1e590bb14aaaee51587 (diff)
downloadports-2df0d56decc96f4d67822824228dee1751b62466.tar.gz
ports-2df0d56decc96f4d67822824228dee1751b62466.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/qt4-codecs-tw/Makefile65
-rw-r--r--chinese/qt4-codecs-tw/distinfo3
-rw-r--r--chinese/qt4-codecs-tw/pkg-descr12
-rw-r--r--chinese/qt4-codecs-tw/pkg-plist3
5 files changed, 84 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index b90ed0023d16..6a7e5f492562 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -110,6 +110,7 @@
SUBDIR += pyDict
SUBDIR += qe
SUBDIR += qt4-codecs-cn
+ SUBDIR += qt4-codecs-tw
SUBDIR += qterm
SUBDIR += reciteword
SUBDIR += scim-chewing
diff --git a/chinese/qt4-codecs-tw/Makefile b/chinese/qt4-codecs-tw/Makefile
new file mode 100644
index 000000000000..659ffad30e89
--- /dev/null
+++ b/chinese/qt4-codecs-tw/Makefile
@@ -0,0 +1,65 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= codecs
+PORTVERSION= 4.2.2
+CATEGORIES?= chinese
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+PKGNAMESUFFIX= -tw
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt Big-5 codec plugin
+
+BUILD_DEPENDS= qmake-qt4:${PORTSDIR}/devel/qmake4
+LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -prefix ${PREFIX} \
+ -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
+ -confirm-license
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/network' --exclude '${DISTNAME}/src/xml' \
+ --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
+ --exclude '${DISTNAME}/src/sql' \
+ --exclude '${DISTNAME}/src/tools/moc' --exclude '${DISTNAME}/src/tools/uic' \
+ --exclude '${DISTNAME}/src/tools/rcc' --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/assistant' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}/tw
+CONFIGURE_WRKSRC=${WRKSRC}/../../../..
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins/codecs|g' \
+ ${WRKSRC}/tw.pro
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../../bin/moc
+
+.include <bsd.port.post.mk>
diff --git a/chinese/qt4-codecs-tw/distinfo b/chinese/qt4-codecs-tw/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/chinese/qt4-codecs-tw/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/chinese/qt4-codecs-tw/pkg-descr b/chinese/qt4-codecs-tw/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/chinese/qt4-codecs-tw/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/chinese/qt4-codecs-tw/pkg-plist b/chinese/qt4-codecs-tw/pkg-plist
new file mode 100644
index 000000000000..86cff7bf6e0a
--- /dev/null
+++ b/chinese/qt4-codecs-tw/pkg-plist
@@ -0,0 +1,3 @@
+lib/plugins/codecs/libqtwcodecs.so
+lib/plugins/codecs/libqtwcodecs.so.debug
+@dirrm lib/plugins/codecs