aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-03-01 18:21:59 +0000
committerClive Lin <clive@FreeBSD.org>2001-03-01 18:21:59 +0000
commit30c7bdac13f7f2456929ea053114933fde66f543 (patch)
tree150e03d9157ca6a660edfcd175f5058c8510b66a /chinese
parent0a76f31a598848b8958e58421684a68efb362fd3 (diff)
downloadports-30c7bdac13f7f2456929ea053114933fde66f543.tar.gz
ports-30c7bdac13f7f2456929ea053114933fde66f543.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile3
-rw-r--r--chinese/aterm/Makefile36
-rw-r--r--chinese/aterm/distinfo2
-rw-r--r--chinese/aterm/files/cli_xcin.c146
-rw-r--r--chinese/aterm/files/patch-aa20
-rw-r--r--chinese/aterm/files/patch-ab29
-rw-r--r--chinese/aterm/files/protocol.h13
-rw-r--r--chinese/aterm/files/state.h23
-rw-r--r--chinese/aterm/pkg-comment1
-rw-r--r--chinese/aterm/pkg-descr12
-rw-r--r--chinese/aterm/pkg-plist1
-rw-r--r--chinese/xa+cv/Makefile50
-rw-r--r--chinese/xa+cv/distinfo1
-rw-r--r--chinese/xa+cv/files/patch-aa36
-rw-r--r--chinese/xa+cv/files/patch-ac200
-rw-r--r--chinese/xa+cv/files/patch-ad19
-rw-r--r--chinese/xa+cv/pkg-comment1
-rw-r--r--chinese/xa+cv/pkg-descr9
-rw-r--r--chinese/xa+cv/pkg-plist22
-rw-r--r--chinese/xcin/Makefile30
-rw-r--r--chinese/xcin/distinfo1
-rw-r--r--chinese/xcin/files/patch-aa11
-rw-r--r--chinese/xcin/files/patch-ab34
-rw-r--r--chinese/xcin/files/patch-af27
-rw-r--r--chinese/xcin/files/patch-ag11
-rw-r--r--chinese/xcin/pkg-comment1
-rw-r--r--chinese/xcin/pkg-descr14
-rw-r--r--chinese/xcin/pkg-plist47
28 files changed, 0 insertions, 800 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index f378cb214cff..378890525eb0 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -7,7 +7,6 @@
SUBDIR += acroread-chsfont
SUBDIR += acroread-chtfont
SUBDIR += arphicttf
- SUBDIR += aterm
SUBDIR += auto-tw-l10n
SUBDIR += autoconvert
SUBDIR += bg5ps
@@ -64,8 +63,6 @@
SUBDIR += ve
SUBDIR += vflib
SUBDIR += wangttf
- SUBDIR += xa+cv
- SUBDIR += xcin
SUBDIR += xcin25
SUBDIR += xemacs
SUBDIR += xemacs21
diff --git a/chinese/aterm/Makefile b/chinese/aterm/Makefile
deleted file mode 100644
index 3aee14d4fe22..000000000000
--- a/chinese/aterm/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: zh-aterm
-# Date created: 26 April 1999
-# Whom: Chia-Hsing Yu <davidyu@ken.csie.ntu.edu.tw>
-#
-# $FreeBSD$
-#
-
-PORTNAME= aterm
-PORTVERSION= 0.3.6
-CATEGORIES= chinese
-MASTER_SITES= http://members.xoom.com/sashav/aterm/ \
- http://www.tigr.net/afterstep/as-apps/download/aterm/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= foxfair
-
-MAINTAINER= davidyu@ken.csie.ntu.edu.tw
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.4:${PORTSDIR}/graphics/png
-
-BROKEN= "Non-I18N-aware old-fashioned application no more supported"
-
-USE_X_PREFIX= yes
-USE_XPM= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-transparency --enable-background-image \
- --disable-delete-key --disable-backspace-key \
- --enable-fading --enable-utmp --enable-wtmp --enable-big5
-MAN1= aterm.1
-
-post-patch:
- ${CP} ${FILESDIR}/cli_xcin.c ${WRKSRC}/src/
- ${CP} ${FILESDIR}/state.h ${WRKSRC}/src/
- ${CP} ${FILESDIR}/protocol.h ${WRKSRC}/src/
-
-.include <bsd.port.mk>
diff --git a/chinese/aterm/distinfo b/chinese/aterm/distinfo
deleted file mode 100644
index 50538e88919f..000000000000
--- a/chinese/aterm/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (aterm-0.3.6.tar.gz) = 8adc789412c583fa5ee10ce664e43373
-MD5 (aterm-0.3.6.tar.gz) = dba960c51e40c64a84ad61dda42e75f0
diff --git a/chinese/aterm/files/cli_xcin.c b/chinese/aterm/files/cli_xcin.c
deleted file mode 100644
index 91c14d2fa3d6..000000000000
--- a/chinese/aterm/files/cli_xcin.c
+++ /dev/null
@@ -1,146 +0,0 @@
-/*
- Copyright (C) 1994,1995 Edward Der-Hua Liu, Hsin-Chu, Taiwan
-*/
-
-#include <stdio.h>
-#include <stdarg.h>
-#include <sys/types.h>
-#include <X11/Xlib.h>
-#include <X11/Xatom.h>
-#include "state.h"
-#include "protocol.h"
-
-/*static void p_err(char *fmt,...)
-{
- va_list args;
-
- va_start(args, fmt);
- fprintf(stderr,"%s:", "cli_xcin:");
- vfprintf(stderr, fmt, args);
- va_end(args);
- fprintf(stderr,"\n");
- exit(-1);
-}
-*/
-
-
-static Atom xcin_atom=0;
-static Window xcin_win=None;
-static InmdState inmdstate;
-#define ENDIAN_TEST() (*(int *)"\x11\x22\x33\x44"==0x11223344)
-char my_endian;
-
-static int connect_xcin(Display *display)
-{
-/*Window twin;*/
-xcin_atom=XInternAtom(display, XCIN_ATOM,False);
-my_endian=ENDIAN_TEST(); /* if == 11223344, it is big-endian */
-
-xcin_win=XGetSelectionOwner(display,xcin_atom);
-return xcin_win;
-}
-
-void send_FocusIn(Display *display, Window window)
-{
- XClientMessageEvent event;
- /*XEvent erreve;*/
- char *tmp=event.data.b;
-
- if (connect_xcin(display)==None) return;
-/* Ensure xcin exists, or the process will be hanged */
- event.type=ClientMessage;
- event.window=window;
- event.message_type=xcin_atom;
- event.format=8;
-
- tmp[0]=tmp[1]=tmp[2]=0xff;
- tmp[3]=CLI_FOCUS_IN;
- memcpy(&tmp[4],&inmdstate, sizeof(inmdstate));
- XSendEvent(display, xcin_win, False, 0, (XEvent *)&event);
-}
-
-void send_FocusOut(Display *display, Window window)
-{
- XClientMessageEvent event;
-/* XEvent erreve; */
- char *tmp=event.data.b;
-
- if (connect_xcin(display)==None) return;
-/* Ensure xcin exists, or the process will be hanged */
- event.type=ClientMessage;
- event.window=window;
- event.message_type=xcin_atom;
- event.format=8;
-
- tmp[0]=tmp[1]=tmp[2]=0xff;
- tmp[3]=CLI_FOCUS_OUT;
- memcpy(&tmp[4],&inmdstate, sizeof(inmdstate));
- XSendEvent(display, xcin_win, False, 0, (XEvent *)&event);
-}
-
-static void big_little(char *i)
-{
-char t;
-t=*i; *i=*(i+3); *(i+3)=t;
-t=*(i+1); *(i+1)=*(i+2); *(i+2)=t;
-}
-static int read_keys(Display *display, char *buf)
-{
- Atom actual_type;
- int actual_format/*,i*/;
- u_long nitems,bytes_after;
- char *ttt, *cp;
- XCIN_RES res;
- int ofs;
-
- cp=(char *)&res;
- ofs=0;
- do {
- if (XGetWindowProperty(display,xcin_win,xcin_atom,
- ofs/4,(sizeof(XCIN_RES)+3)/4,
- True, AnyPropertyType, &actual_type,&actual_format,
- &nitems,&bytes_after,(unsigned char **)&ttt) != Success)
- puts("err property");
- memcpy((char *)(&res)+(ofs & ~0x3), ttt, nitems);
- XFree(ttt);
- ofs=(ofs & ~0x3) + nitems;
- } while ((!nitems && !ofs) || bytes_after>0);
- if (my_endian) {
- big_little((char *)&res.len);
- big_little((char *)&res.status);
- }
- memcpy(buf,res.tkey, res.len);
- inmdstate=res.inmdstate;
- buf[res.len]=0;
-
- return res.status;
-}
-
-#include <X11/Xutil.h>
-
-static XComposeStatus compose_status = {NULL, 0};
-
-int send_key(Display *display, Window win, XKeyEvent *eve, char *buf)
-{
-XClientMessageEvent event;
-/*XEvent erreve;*/
-char *tmp=event.data.b;
-u_char tttt[8];
-/*KeySym keysym;*/
-int count;
-
-if (xcin_win==None && connect_xcin(display)==None)
- return K_REJECT;
-if ((xcin_win=XGetSelectionOwner(display,xcin_atom))==None)
- return K_REJECT;
-
-event.type=ClientMessage;
-event.window=win;
-event.message_type=xcin_atom;
-event.format=32;
-count = XLookupString (eve, tttt, sizeof(tmp), (KeySym *)tmp, &compose_status);
-memcpy(&tmp[4],&eve->state,4);
-XSendEvent(display, xcin_win, False, 0, (XEvent *)&event);
-XSync(display,False);
-return (read_keys(display, buf));
-}
diff --git a/chinese/aterm/files/patch-aa b/chinese/aterm/files/patch-aa
deleted file mode 100644
index 422f546abdc9..000000000000
--- a/chinese/aterm/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Makefile.in.orig Fri May 14 05:30:49 1999
-+++ src/Makefile.in Fri May 14 05:31:10 1999
-@@ -19,13 +19,14 @@
-
- SRCS = command.c graphics.c grkelot.c main.c menubar.c misc.c \
- netdisp.c rmemset.c screen.c @SBARFILE@.c utmp.c xdefaults.c \
-- pixmap.c ximage_utils.c
-+ pixmap.c ximage_utils.c cli_xcin.c
-
- OBJS = command.o graphics.o grkelot.o main.o menubar.o misc.o \
- netdisp.o rmemset.o screen.o @SBARFILE@.o utmp.o xdefaults.o \
-- pixmap.o ximage_utils.o
-+ pixmap.o ximage_utils.o cli_xcin.o
-
--HDRS = feature.h protos.h grkelot.h rxvt.h rxvtgrx.h screen.h version.h
-+HDRS = feature.h protos.h grkelot.h rxvt.h rxvtgrx.h screen.h version.h \
-+ state.h protocol.h
-
- PROS = command.pro graphics.pro grkelot.pro main.pro menubar.pro misc.pro \
- netdisp.pro rmemset.pro screen.pro @SBARFILE@.pro utmp.pro xdefaults.pro \
diff --git a/chinese/aterm/files/patch-ab b/chinese/aterm/files/patch-ab
deleted file mode 100644
index 4abeec0e9949..000000000000
--- a/chinese/aterm/files/patch-ab
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/command.c.orig Fri May 14 05:31:24 1999
-+++ src/command.c Fri May 14 05:34:35 1999
-@@ -2128,11 +2128,17 @@
- static int bypass_keystate = 0;
- int reportmode;
- static int csrO = 0; /* Hops - csr offset in thumb/slider */
-+ int k_status;
-+ char kbuf[256];
-
- /* to give proper Scroll behaviour */
- switch (ev->type) {
- case KeyPress:
-- lookup_key(ev);
-+ k_status = send_key(Xdisplay, TermWin.parent, &ev->xkey, kbuf);
-+ if(!k_status)
-+ lookup_key(ev);
-+ else if(kbuf[0])
-+ tt_write(kbuf, strlen(kbuf));
- break;
-
- case ClientMessage:
-@@ -2197,6 +2203,7 @@
-
- case FocusIn:
- if (!TermWin.focus) {
-+ send_FocusIn(Xdisplay, TermWin.parent);
- TermWin.focus = 1;
- #ifdef OFF_FOCUS_FADING
- if( rs_fade != NULL )
diff --git a/chinese/aterm/files/protocol.h b/chinese/aterm/files/protocol.h
deleted file mode 100644
index bc19abfb5d12..000000000000
--- a/chinese/aterm/files/protocol.h
+++ /dev/null
@@ -1,13 +0,0 @@
-/*
- Copyright (C) 1994 Edward Der-Hua Liu, Hsin-Chu, Taiwan
-*/
-
-#define K_REJECT (0)
-#define K_ACCEPT (1)
-
-#define CLI_FOCUS_IN (1)
-#define CLI_FOCUS_OUT (3)
-
-#define LOAD_KEYWORD (2)
-
-#define XCIN_ATOM "XCIN_A"
diff --git a/chinese/aterm/files/state.h b/chinese/aterm/files/state.h
deleted file mode 100644
index e663df9fb986..000000000000
--- a/chinese/aterm/files/state.h
+++ /dev/null
@@ -1,23 +0,0 @@
-/*
- Copyright (C) 1994 Edward Der-Hua Liu, Hsin-Chu, Taiwan
-*/
-
-typedef struct {
- char kb_state;
- char _CurInMethod;
-} InmdState;
-
-#define EngChiMask (1)
-#define HalfFullMask (2)
-
-typedef struct {
- int len;
- int status;
- InmdState inmdstate;
- char tkey[512];
-} XCIN_RES;
-
-#define EngChi ((inmdstate.kb_state & EngChiMask) ? 1:0)
-#define HalfFull ((inmdstate.kb_state & HalfFullMask) ? 1:0)
-#define CurInMethod (inmdstate._CurInMethod)
-/* extern InmdState inmdstate; */
diff --git a/chinese/aterm/pkg-comment b/chinese/aterm/pkg-comment
deleted file mode 100644
index 51dd2923467d..000000000000
--- a/chinese/aterm/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A color vt102 terminal emulator with transparency support
diff --git a/chinese/aterm/pkg-descr b/chinese/aterm/pkg-descr
deleted file mode 100644
index c49a5903ec09..000000000000
--- a/chinese/aterm/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-aterm is a color vt102 terminal emulator, based on rxvt 2.4.8 with
-additions for fast transparency.
-
-It was created with AfterStep users in mind, but is not tied to any
-libraries, and can be used anywhere.
-
-- Jim <jim@phrantic.phear.net>
-
-
-This port supports XCIN.
-
-- David Yu <davidyu@ken.csie.ntu.edu.tw>
diff --git a/chinese/aterm/pkg-plist b/chinese/aterm/pkg-plist
deleted file mode 100644
index 6a4f1420cad3..000000000000
--- a/chinese/aterm/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/aterm
diff --git a/chinese/xa+cv/Makefile b/chinese/xa+cv/Makefile
deleted file mode 100644
index 91e03eeff51d..000000000000
--- a/chinese/xa+cv/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# New ports collection makefile for: xa+cv
-# Date created: 29 March 1999
-# Whom: Clive Lin <clive@CirX.ORG>
-#
-# $FreeBSD: /tmp/pcvs/ports/chinese/xa+cv/Attic/Makefile,v 1.5 2001-02-27 09:48:26 clive Exp $
-#
-
-PORTNAME= xa+cv
-PORTVERSION= 0.6
-CATEGORIES= chinese
-MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/clive/
-
-MAINTAINER= clive@FreeBSD.org
-
-RUN_DEPENDS= ${X11BASE}/bin/xcin:${PORTSDIR}/chinese/xcin \
- ${X11BASE}/lib/X11/fonts/TrueType/moe_sung.ttf:${PORTSDIR}/chinese/moettf
-
-BROKEN= "Non-I18N-aware old-fashioned application no more supported"
-
-USE_GMAKE= yes
-
-DOC1= FAQ NEW README.XA README.+CV README.XA+CV-0.5 USE.Big5 USE.GB
-EX1= README cnetscape cxcoral cxemacs cxterm dot.fvwm2rc95 et24 \
- et24r ns
-
-post-install:
- @${ECHO} "========================================================="
- @${ECHO} "-=> Install examples to invoke XA+CV"
- @${ECHO} " into ${PREFIX}/share/examples/xa+cv"
- @${ECHO} " "
- @${MKDIR} ${PREFIX}/share/examples/xa+cv
-.for i in ${EX1}
- @${INSTALL_DATA} ${WRKSRC}/example/${i} ${PREFIX}/share/examples/xa+cv/${i}
-.endfor
-.if !defined(NOPORTDOCS)
- @${ECHO} "-=> Install documents into ${PREFIX}/share/doc/xa+cv"
- @${ECHO} " "
- @${MKDIR} ${PREFIX}/share/doc/xa+cv
-.for i in ${DOC1}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/xa+cv/${i}
-.endfor
-.endif
- @${ECHO} "-=> Done."
- @${ECHO} " "
- @${ECHO} "If you are inpatient, simply set environment varible
- @${ECHO} "LD_PRELOAD = ${PREFIX}/lib/wrap.so to make it work."
- @${ECHO} " "
- @${ECHO} "========================================================="
-
-.include <bsd.port.mk>
diff --git a/chinese/xa+cv/distinfo b/chinese/xa+cv/distinfo
deleted file mode 100644
index c15e2f9d80d4..000000000000
--- a/chinese/xa+cv/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (xa+cv-0.6.tar.gz) = 489c976d5fba7cd52ceb706d484143ce
diff --git a/chinese/xa+cv/files/patch-aa b/chinese/xa+cv/files/patch-aa
deleted file mode 100644
index 1c7451a5b2da..000000000000
--- a/chinese/xa+cv/files/patch-aa
+++ /dev/null
@@ -1,36 +0,0 @@
---- Makefile.orig Thu May 13 01:28:07 1999
-+++ Makefile Wed Aug 11 03:27:24 1999
-@@ -8,12 +8,12 @@
-
- CC = gcc
- CFLAGS = -fPIC -O2
--SHAREFLAGES = -shared
--SHARELIBS = -ldl
-+SHAREFLAGES = -shared -export-dynamic
-+SHARELIBS =
- INSTALL = /usr/bin/install -c
-
--DESTDIR = /usr/locale/lib
--CONGDIR = /etc/chinese/xa+cv
-+DESTDIR = /usr/local/lib
-+CONGDIR = /usr/local/etc/chinese/xa+cv
- INCLUDEDIR = -I/usr/include -I/usr/X11R6/include
-
- all: wrap.so
-@@ -22,7 +22,7 @@
- $(CC) -c $(CFLAGS) $(INCLUDEDIR) $< -o $@
-
- wrap.so: cli_xcin.o wrap.o select_mode.o config.h
-- $(CC) $(SHAREFLAGES) $(SHARELIBS) -o wrap.so cli_xcin.o \
-+ ld $(SHAREFLAGES) $(SHARELIBS) -o wrap.so cli_xcin.o \
- wrap.o select_mode.o
- strip wrap.so
-
-@@ -38,6 +38,6 @@
-
- install: all
- $(INSTALL) -m 755 wrap.so $(DESTDIR)
-- mkdir -p /etc/chinese/xa+cv && \
-+ mkdir -p $(CONGDIR) && \
- $(INSTALL) -m 644 xa+cv.config $(CONGDIR)/config
-
diff --git a/chinese/xa+cv/files/patch-ac b/chinese/xa+cv/files/patch-ac
deleted file mode 100644
index 9f425c05e1d8..000000000000
--- a/chinese/xa+cv/files/patch-ac
+++ /dev/null
@@ -1,200 +0,0 @@
---- wrap.c.orig Wed Jul 28 15:19:02 1999
-+++ wrap.c Wed Sep 8 17:00:52 1999
-@@ -272,168 +272,168 @@
-
- int load_all_syms(void *handle)
- {
-- char *error;
--
-+ char const *error;
-+ FILE * nullfp = fopen("/dev/null", "w") ;
- real_XOpenDisplay=dlsym(handle,"XOpenDisplay");
- p_log(-1, " XOpenDisplay loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XCloseDisplay=dlsym(handle,"XCloseDisplay");
- p_log(-1, " XCloseDisplay loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XGetFontProperty=dlsym(handle,"XGetFontProperty");
- p_log(-1, " XGetFontProperty loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XFreeFont=dlsym(handle,"XFreeFont");
- p_log(-1, " XFreeFont loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XFreeFontInfo=dlsym(handle,"XFreeFontInfo");
- p_log(-1, " XFreeFontInfo loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XQueryFont=dlsym(handle,"XQueryFont");
- p_log(-1, " XQueryFont loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XLoadQueryFont=dlsym(handle,"XLoadQueryFont");
- p_log(-1, " XLoadQueryFont loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XTextWidth=dlsym(handle,"XTextWidth");
- p_log(-1, " XTextWidth loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XTextWidth16=dlsym(handle,"XTextWidth16");
- p_log(-1, " XTextWidth16 loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XTextExtents=dlsym(handle,"XTextExtents");
- p_log(-1, " XTextExtents loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XTextExtents16=dlsym(handle,"XTextExtents16");
- p_log(-1, " XTextExtents16 loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XQueryTextExtents=dlsym(handle,"XQueryTextExtents");
- p_log(-1, " XQueryTextExtents loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XQueryTextExtents16=dlsym(handle,"XQueryTextExtents16");
- p_log(-1, " XQueryTextExtents16 loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XDrawString=dlsym(handle,"XDrawString");
- p_log(-1, " XDrawString loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XDrawString16=dlsym(handle,"XDrawString16");
- p_log(-1, " XDrawString16 loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XDrawImageString=dlsym(handle,"XDrawImageString");
- p_log(-1, " XDrawImageString loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XDrawImageString16=dlsym(handle,"XDrawImageString16");
- p_log(-1, " XDrawImageString16 loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XChangeGC=dlsym(handle,"XChangeGC");
- p_log(-1, " XChangeGC loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XGetGCValues=dlsym(handle,"XGetGCValues");
- p_log(-1, " XGetGCValues loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XChangeProperty=dlsym(handle,"XChangeProperty");
- p_log(-1, " XChangeProperty loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XNextEvent=dlsym(handle,"XNextEvent");
- p_log(-1, " XNextEvent loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XPeekEvent=dlsym(handle,"XPeekEvent");
- p_log(-1, " XPeekEvent loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XPutBackEvent=dlsym(handle,"XPutBackEvent");
- p_log(-1, " XPutBackEvent loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XLookupString=dlsym(handle,"XLookupString");
- p_log(-1, " XLookupString loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XSetSelectionOwner=dlsym(handle,"XSetSelectionOwner");
- p_log(-1, " XSetSelectionOwner loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XGetSelectionOwner=dlsym(handle,"XGetSelectionOwner");
- p_log(-1, " XGetSelectionOwner loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
- real_XInternAtom=dlsym(handle,"XInternAtom");
- p_log(-1, " XInternAtom loaded...\n");
- if ((error = dlerror()) != NULL) {
-- fputs(error, stderr);
-+ fputs(error, nullfp);
- exit(1);
- }
-
diff --git a/chinese/xa+cv/files/patch-ad b/chinese/xa+cv/files/patch-ad
deleted file mode 100644
index 3307e23d5403..000000000000
--- a/chinese/xa+cv/files/patch-ad
+++ /dev/null
@@ -1,19 +0,0 @@
---- config.h.orig Wed May 26 10:06:40 1999
-+++ config.h Wed Aug 11 02:35:00 1999
-@@ -14,14 +14,14 @@
- #define XA_LIBX11 "/usr/X11R6/lib/libX11.so.6"
- #endif
-
--#define XA_SMART_DADABASE "/etc/chinese/xa+cv/config"
-+#define XA_SMART_DADABASE "/usr/local/etc/chinese/xa+cv/config"
-
- #define DEFAULT_FACE "*"
- #define DEFAULT_FAMILY "*"
- #define BIG5_FONT_ENCODING "big5-0"
- #define GB_FONT_ENCODING "gb2312.1980-0"
- #define DEFAULT_BASE_FONT_NAME "-%s-%s-*-r-*-*-%d-*-*-*-*-%d-%s"
--#define DEFAULT_SMALL_BIG5_FONT "taipei16"
-+#define DEFAULT_SMALL_BIG5_FONT "sung"
- #define DEFAULT_SMALL_GB_FONT "hanzigb16fs"
- #define MIN_SMALL_FONT_PIXELS 16
- #define CFNTMAX 10
diff --git a/chinese/xa+cv/pkg-comment b/chinese/xa+cv/pkg-comment
deleted file mode 100644
index 705b50be1b35..000000000000
--- a/chinese/xa+cv/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A loadable library to show Chinese words in most applications
diff --git a/chinese/xa+cv/pkg-descr b/chinese/xa+cv/pkg-descr
deleted file mode 100644
index 79b556b51926..000000000000
--- a/chinese/xa+cv/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-XA+CV is a work around library lets most X applications to show Chinese words
-properly. Use LD_PRELOAD to make it work.
-
-NOTE: for ELF world after 3.0-RELEASE, ONLY compitable with Linux Netscape.
- you HAVE to enable Linux emulation and install Linux version Netscape.
-
-Other information please refer to /usr/local/share/doc/xa+cv/.
-
-- Clive Lin <clive@CirX.ORG>
diff --git a/chinese/xa+cv/pkg-plist b/chinese/xa+cv/pkg-plist
deleted file mode 100644
index 4dd8bfe4f15e..000000000000
--- a/chinese/xa+cv/pkg-plist
+++ /dev/null
@@ -1,22 +0,0 @@
-lib/wrap.so
-etc/chinese/xa+cv/config
-share/doc/xa+cv/FAQ
-share/doc/xa+cv/NEW
-share/doc/xa+cv/README.+CV
-share/doc/xa+cv/README.XA
-share/doc/xa+cv/README.XA+CV-0.5
-share/doc/xa+cv/USE.Big5
-share/doc/xa+cv/USE.GB
-share/examples/xa+cv/README
-share/examples/xa+cv/cnetscape
-share/examples/xa+cv/cxcoral
-share/examples/xa+cv/cxemacs
-share/examples/xa+cv/cxterm
-share/examples/xa+cv/dot.fvwm2rc95
-share/examples/xa+cv/et24
-share/examples/xa+cv/et24r
-share/examples/xa+cv/ns
-@dirrm etc/chinese/xa+cv
-@dirrm etc/chinese
-@dirrm share/doc/xa+cv
-@dirrm share/examples/xa+cv
diff --git a/chinese/xcin/Makefile b/chinese/xcin/Makefile
deleted file mode 100644
index 5d94d2f2a60a..000000000000
--- a/chinese/xcin/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: xcin
-# Date created: Nov 28 ,1997
-# Whom: Yen-Shuo Su <yssu@CCCA.NCTU.edu.tw>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xcin
-PORTVERSION= 2.3.04.3
-CATEGORIES= chinese
-MASTER_SITES= ftp://xcin.linux.org.tw/pub/xcin/xcin/old/ \
- ftp://ftp.ncu.edu.tw/OS/Linux/Chinese/xcin/xcin/ \
- ftp://linux.cis.nctu.edu.tw/packages/chinese/X/xcin/xcin/
-DISTNAME= xcin-2.3.04-3
-
-MAINTAINER= yssu@CCCA.NCTU.edu.tw
-
-RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/local/kc15f.pcf.gz:${PORTSDIR}/chinese/kcfonts
-
-BROKEN= "Non-I18N-aware old-fashioned application no more supported"
-
-NO_LATEST_LINK= yes
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix="${X11BASE}" --os=FreeBSD --no-menu
-
-MAN1= xcin.1 cin2tab.1
-
-.include <bsd.port.mk>
diff --git a/chinese/xcin/distinfo b/chinese/xcin/distinfo
deleted file mode 100644
index 002461bb8b20..000000000000
--- a/chinese/xcin/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (xcin-2.3.04-3.tar.gz) = 737a6ea93237b12903c3088a06730c63
diff --git a/chinese/xcin/files/patch-aa b/chinese/xcin/files/patch-aa
deleted file mode 100644
index 7881d25d574f..000000000000
--- a/chinese/xcin/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- script/configure.menu.orig Fri Dec 11 09:49:43 1998
-+++ script/configure.menu Sat Oct 9 17:36:25 1999
-@@ -266,7 +266,7 @@
- {
- PATH_XCIN_PREFIX=$1
- PATH_XCIN_BIN=$PATH_XCIN_PREFIX/bin
-- PATH_XCIN_DIR=$PATH_XCIN_PREFIX/lib/xcin
-+ PATH_XCIN_DIR=$PATH_XCIN_PREFIX/lib/X11/xcin
- PATH_XCIN_MAN=$PATH_XCIN_PREFIX/man
- }
-
diff --git a/chinese/xcin/files/patch-ab b/chinese/xcin/files/patch-ab
deleted file mode 100644
index d43a3c001c5f..000000000000
--- a/chinese/xcin/files/patch-ab
+++ /dev/null
@@ -1,34 +0,0 @@
---- script/Makefile.in.orig Sun Apr 2 10:53:27 2000
-+++ script/Makefile.in Sun Apr 2 10:53:50 2000
-@@ -16,16 +16,16 @@
-
-
- make_xcin:
-- (cd src; make all)
-+ (cd src; gmake all)
-
- make_inptab:
-- (cd input_tab; make all)
-+ (cd input_tab; gmake all)
-
- install_xcin: make_xcin
-- (cd src; make install)
-+ (cd src; gmake install)
-
- install_inptab: make_inptab
-- (cd input_tab; make install)
-+ (cd input_tab; gmake install)
-
- install_doc:
- (cd doc; make install)
---- input_tab/Makefile.in.orig Sun Apr 2 10:53:57 2000
-+++ input_tab/Makefile.in Sun Apr 2 10:54:05 2000
-@@ -12,7 +12,7 @@
-
-
- cin2tab:
-- (cd ../src; make cin2tab)
-+ (cd ../src; gmake cin2tab)
- ln -s ../src/cin2tab .
-
- %.tab: %.cin cin2tab
diff --git a/chinese/xcin/files/patch-af b/chinese/xcin/files/patch-af
deleted file mode 100644
index 8791e8ec265b..000000000000
--- a/chinese/xcin/files/patch-af
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/Makefile.in.org Fri Sep 10 19:54:58 1999
-+++ src/Makefile.in Fri Sep 10 19:55:52 1999
-@@ -149,7 +149,7 @@
-
- install_xcin: xcin $(KBMS) $(INPUT0) tsintab
- if [ ! -d $(PATH_XCIN_BIN) ]; then $(INSTALL_DIR) $(PATH_XCIN_BIN); fi
-- $(INSTALL) xcin $(PATH_XCIN_BIN)
-+ $(INSTALL_PROGRAM) xcin $(PATH_XCIN_BIN)
- echo $(PATH_XCIN_BIN)/xcin >> filelist
-
- if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
-@@ -159,13 +159,13 @@
-
- install_cin2tab: cin2tab
- if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
-- $(INSTALL) cin2tab $(PATH_XCIN_DIR)
-+ $(INSTALL_PROGRAM) cin2tab $(PATH_XCIN_DIR)
- echo $(PATH_XCIN_DIR)/cin2tab >> filelist
-
- install_tsintools: tsintools
- if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
- for f in $(TSINTOOLS); do\
-- $(INSTALL) $$f $(PATH_XCIN_DIR); echo $(PATH_XCIN_DIR)/$$f >> filelist;\
-+ $(INSTALL_PROGRAM) $$f $(PATH_XCIN_DIR); echo $(PATH_XCIN_DIR)/$$f >> filelist;\
- done
-
- install_tsintabsrc:
diff --git a/chinese/xcin/files/patch-ag b/chinese/xcin/files/patch-ag
deleted file mode 100644
index 6aefebdcf1d3..000000000000
--- a/chinese/xcin/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- script/config.status.orig Sat Sep 16 10:38:05 2000
-+++ script/config.status Sat Sep 16 10:38:21 2000
-@@ -14,7 +14,7 @@
- PATH_XCIN_DIR=/usr/local/lib/xcin
- PATH_XCIN_MAN=/usr/local/man
-
--OPT_XCIN_CFONT=-twmoe-kai-medium-r-normal--24-240-75-75-c-240-big5-1
-+OPT_XCIN_CFONT=-twmoe-kai-medium-r-normal--24-240-75-75-c-240-big5-0
- OPT_XCIN_EFONT=12x24
- OPT_UTIL_CIN2TAB=yes
- OPT_UTIL_TSINTOOLS=yes
diff --git a/chinese/xcin/pkg-comment b/chinese/xcin/pkg-comment
deleted file mode 100644
index e10f0f1209eb..000000000000
--- a/chinese/xcin/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A chinese input utility in X
diff --git a/chinese/xcin/pkg-descr b/chinese/xcin/pkg-descr
deleted file mode 100644
index bcb29198e732..000000000000
--- a/chinese/xcin/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-Thanks to Mr. Edward Der-Hua Liu and others who developed the xcin
-system. With the wonderful program, we can do a lot of operations with
-Chinese under the X Window System in the UN*X world. As time goes on,
-more and more people use it, and more and more comments appear. The
-package hs been upgraded with time but it seems that the install process
-is not convenient and self-consistent. These confuse a lot of people,
-especially for new users in the UN*X world. We often see the `Big FAQs'
-about xcin such as `how can I install the Chinese fonts' or `the cj2cin
-command not found' or `the crxvt terminal is too big!!' or something
-appears in the newsgroup again and again. In fact, such problems are
-easy to remedy. Because I really like this program and feel that I may
-do something to improve this package, I try my best to re-write the
-Makefiles and auto-configuration programs of this package to try to
-solve these troubles. This comes the `xcin-2.3' project.
diff --git a/chinese/xcin/pkg-plist b/chinese/xcin/pkg-plist
deleted file mode 100644
index 449e0880462c..000000000000
--- a/chinese/xcin/pkg-plist
+++ /dev/null
@@ -1,47 +0,0 @@
-bin/xcin
-lib/X11/xcin/array30.cin
-lib/X11/xcin/array30.tab
-lib/X11/xcin/array30.tab.phr
-lib/X11/xcin/array30.tab.quick
-lib/X11/xcin/array30.tab.rev
-lib/X11/xcin/cin2tab
-lib/X11/xcin/cj.cin
-lib/X11/xcin/cj.tab
-lib/X11/xcin/cj.tab.rev
-lib/X11/xcin/et.kbm
-lib/X11/xcin/et26.kbm
-lib/X11/xcin/hsu.kbm
-lib/X11/xcin/lphrase
-lib/X11/xcin/pho.sel1st
-lib/X11/xcin/pho.tab
-lib/X11/xcin/phone.cin
-lib/X11/xcin/phone.tab
-lib/X11/xcin/phone.tab.rev
-lib/X11/xcin/phs_out
-lib/X11/xcin/pin2tsin
-lib/X11/xcin/pinyin.cin
-lib/X11/xcin/pinyin.tab
-lib/X11/xcin/pinyin.tab.rev
-lib/X11/xcin/sample.phs.out
-lib/X11/xcin/tsa2d
-lib/X11/xcin/tsa2rel
-lib/X11/xcin/tsd2a
-lib/X11/xcin/tsin
-lib/X11/xcin/tsin.idx
-lib/X11/xcin/tsin.rel
-lib/X11/xcin/tsin.rel.src
-lib/X11/xcin/tsin.src
-lib/X11/xcin/tsin_pin.map
-lib/X11/xcin/voca.box
-lib/X11/xcin/zmdbosh.cin
-lib/X11/xcin/zmdbosh.tab
-lib/X11/xcin/zmdbosh.tab.rev
-lib/X11/xcin/zo.kbm
-lib/X11/xcin/docs/Boshiamy.HOWTO
-lib/X11/xcin/docs/README.xcin
-lib/X11/xcin/docs/XCIN.client.doc
-lib/X11/xcin/docs/Xfonts.HOWTO
-lib/X11/xcin/docs/cin2tab.HOWTO
-lib/X11/xcin/docs/xcin.HOWTO
-@dirrm lib/X11/xcin/docs
-@dirrm lib/X11/xcin