aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorJing-Tang Keith Jang <keith@FreeBSD.org>2001-03-02 17:43:02 +0000
committerJing-Tang Keith Jang <keith@FreeBSD.org>2001-03-02 17:43:02 +0000
commitd6c6d63fd105f89855b619fd7bc9c2ebfa70240d (patch)
tree0053722cdadb4da47462a24ab842db4156c1c30a /chinese
parentddfc9c62a8c26f290d4c0a4bcaa5f93aef6e96fd (diff)
downloadports-d6c6d63fd105f89855b619fd7bc9c2ebfa70240d.tar.gz
ports-d6c6d63fd105f89855b619fd7bc9c2ebfa70240d.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/XFree86-aoutlibs/Makefile8
-rw-r--r--chinese/XFree86-aoutlibs/files/INSTALL.in17
-rw-r--r--chinese/XFree86-aoutlibs/pkg-deinstall17
-rw-r--r--chinese/XFree86-aoutlibs/pkg-install16
4 files changed, 37 insertions, 21 deletions
diff --git a/chinese/XFree86-aoutlibs/Makefile b/chinese/XFree86-aoutlibs/Makefile
index 0f668576bb4d..23422e22450d 100644
--- a/chinese/XFree86-aoutlibs/Makefile
+++ b/chinese/XFree86-aoutlibs/Makefile
@@ -2,7 +2,7 @@
# Date created: 31 Oct 2000
# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
#
-# $FreeBSD: /tmp/pcvs/ports/chinese/XFree86-aoutlibs/Attic/Makefile,v 1.3 2001-02-05 14:29:33 olgeni Exp $
+# $FreeBSD: /tmp/pcvs/ports/chinese/XFree86-aoutlibs/Attic/Makefile,v 1.4 2001-03-02 17:43:02 keith Exp $
#
# The file is identical to
@@ -18,6 +18,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= keith@FreeBSD.org
+RUN_DEPENDS= ${X11BASE}/lib/aout/libX11.so.6.1:${PORTSDIR}/x11/XFree86-aoutlibs
+
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/lib
@@ -25,14 +27,12 @@ NO_BUILD= yes
PORTOBJFORMAT= aout
USE_X_PREFIX= yes
-PKGINSTALL= ${WRKDIR}/pkg-install
pre-configure:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
- @${SED} -e "s;@PREFIX@;${PREFIX};g" ${FILESDIR}/INSTALL.in > ${WRKDIR}/pkg-install
pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
@${MKDIR} ${PREFIX}/lib/aout
diff --git a/chinese/XFree86-aoutlibs/files/INSTALL.in b/chinese/XFree86-aoutlibs/files/INSTALL.in
deleted file mode 100644
index 9af384c65b2f..000000000000
--- a/chinese/XFree86-aoutlibs/files/INSTALL.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-# an installation script for zh-XFree86-aoutlibs
-
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-
-if [ ! -f @PREFIX@/lib/aout/zh-XFree86-aoutlibs-3.3.6 ] && \
- [ -f @PREFIX@/lib/aout/libX11.so.6.1 ]; then
- echo ----------------------------------------------------
- echo You have XFree86-aoutlibs installed!
- echo Please remove it before install zh-XFree86-aoutlibs.
- echo ----------------------------------------------------
- exit 1
-fi
-
-exit 0
diff --git a/chinese/XFree86-aoutlibs/pkg-deinstall b/chinese/XFree86-aoutlibs/pkg-deinstall
new file mode 100644
index 000000000000..6e8d9f297d47
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/pkg-deinstall
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ exit 0
+fi
+
+AOUTLIBSDIR=${PKG_PREFIX}/lib/aout
+
+for old in libX11.so.6.1 liboldX.so.6.0 libICE.so.6.3 libSM.so.6.0 \
+ libXext.so.6.3 libXt.so.6.0 libXmu.so.6.0 libXaw.so.6.1 \
+ libXIE.so.6.0 libXi.so.6.0 libXtst.so.6.1 libPEX5.so.6.0 \
+ libXp.so.6.2; do
+ mv -f ${AOUTLIBSDIR}/X333/${old} ${AOUTLIBSDIR}
+done
+
+rmdir ${PKG_PREFIX}/lib/aout/X333 2>/dev/null || true
+/usr/bin/env OBJFORMAT=aout /sbin/ldconfig -R
diff --git a/chinese/XFree86-aoutlibs/pkg-install b/chinese/XFree86-aoutlibs/pkg-install
new file mode 100644
index 000000000000..238c5d522701
--- /dev/null
+++ b/chinese/XFree86-aoutlibs/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" ]; then
+ exit 0
+fi
+
+AOUTLIBSDIR=${PKG_PREFIX}/lib/aout
+
+mkdir -p ${AOUTLIBSDIR}/X333
+
+for old in libX11.so.6.1 liboldX.so.6.0 libICE.so.6.3 libSM.so.6.0 \
+ libXext.so.6.3 libXt.so.6.0 libXmu.so.6.0 libXaw.so.6.1 \
+ libXIE.so.6.0 libXi.so.6.0 libXtst.so.6.1 libPEX5.so.6.0 \
+ libXp.so.6.2; do
+ mv -f ${AOUTLIBSDIR}/${old} ${AOUTLIBSDIR}/X333
+done