aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-19 08:33:28 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-19 08:33:28 +0000
commit11a8ef61f606997571179a992030d7d2a487fba9 (patch)
treefa525cf86cf83666fe1dea6762436d7c0ef971b0 /chinese
parent0e40d5d60695f38cd07d2e81b7bb530fee106d09 (diff)
downloadports-11a8ef61f606997571179a992030d7d2a487fba9.tar.gz
ports-11a8ef61f606997571179a992030d7d2a487fba9.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/linux-netscape47-communicator/Makefile8
-rw-r--r--chinese/linux-netscape47-navigator/Makefile2
-rw-r--r--chinese/netscape47-communicator/Makefile10
-rw-r--r--chinese/netscape47-navigator/Makefile4
4 files changed, 12 insertions, 12 deletions
diff --git a/chinese/linux-netscape47-communicator/Makefile b/chinese/linux-netscape47-communicator/Makefile
index bbcfd2667a5b..780dee3a3fb1 100644
--- a/chinese/linux-netscape47-communicator/Makefile
+++ b/chinese/linux-netscape47-communicator/Makefile
@@ -17,17 +17,17 @@ MAINTAINER= keith@FreeBSD.org
# We need Arphic because there's no font with all sizes to deal with Java.
RUN_DEPENDS?= \
/compat/linux/CLE-0.9p1:${PORTSDIR}/chinese/cle_base \
- ${LOCALBASE}/bin/${BROWSER_ARC}-${BROWSER_VERSION}:${PORTSDIR}/www/linux-netscape47-${BROWSER} \
+ ${LOCALBASE}/bin/${BROWSER_ARC}-${BROWSER_VERSION}:${PORTSDIR}/www/linux-netscape47-${BROWSER_NAME} \
${X11BASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf
# These variables can be defined in ports that include this Makefile.
PKGNAMEPREFIX?= zh_TW-
LOCALE?= zh_TW.Big5
REGION?= tw
-BROWSER?= communicator
+BROWSER_NAME?= communicator
BROWSER_VER?= 47
BROWSER_VERSION?= 4.77
-BROWSER_ARC?= ${BROWSER}-linux
+BROWSER_ARC?= ${BROWSER_NAME}-linux
BROWSER_BIN?= ${BROWSER_ARC}-${BROWSER_VERSION}.bin
BROWSER_CMD?= ${REGION}-${BROWSER_ARC}-${BROWSER_VER}
NSUBDIR?= lib/netscape-linux
@@ -56,7 +56,7 @@ post-extract:
${MAKESCRIPT} ${FILESDIR}/INSTALL.in > ${WRKDIR}/pkg-install
${MAKESCRIPT} ${FILESDIR}/MESSAGE.in > ${WRKDIR}/pkg-message
${MAKESCRIPT} ${FILESDIR}/DEINSTALL.in > ${WRKDIR}/pkg-deinstall
-.if (${BROWSER} == navigator)
+.if (${BROWSER_NAME} == navigator)
${SED} "s/Communicator/Navigator/g" ${NSKITDIR}/Netscape.ad \
> ${NSKITDIR}/Netscape
.else
diff --git a/chinese/linux-netscape47-navigator/Makefile b/chinese/linux-netscape47-navigator/Makefile
index 38e56945c662..6ca7c17a3fce 100644
--- a/chinese/linux-netscape47-navigator/Makefile
+++ b/chinese/linux-netscape47-navigator/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-BROWSER= navigator
+BROWSER_NAME= navigator
MASTERDIR= ${.CURDIR}/../linux-netscape47-communicator
.include "${.CURDIR}/../linux-netscape47-communicator/Makefile"
diff --git a/chinese/netscape47-communicator/Makefile b/chinese/netscape47-communicator/Makefile
index 046eb2669f9c..3f25c18abeab 100644
--- a/chinese/netscape47-communicator/Makefile
+++ b/chinese/netscape47-communicator/Makefile
@@ -2,7 +2,7 @@
# Date created: 11 Mar 2000
# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
#
-# $FreeBSD: /tmp/pcvs/ports/chinese/netscape47-communicator/Attic/Makefile,v 1.5 2001-06-22 13:05:50 keith Exp $
+# $FreeBSD: /tmp/pcvs/ports/chinese/netscape47-communicator/Attic/Makefile,v 1.6 2001-08-19 08:33:22 knu Exp $
#
PORTNAME= netscape-${BROWSER_ARC}
@@ -16,7 +16,7 @@ MAINTAINER= keith@FreeBSD.org
# ?= is for ports that include this Makefile.
# We need Arphic because there's no font with all sizes to deal with Java.
RUN_DEPENDS?= \
- ${LOCALBASE}/bin/${BROWSER_ARC}-${BROWSER_VERSION}:${PORTSDIR}/www/netscape${BROWSER_VER}-${BROWSER} \
+ ${LOCALBASE}/bin/${BROWSER_ARC}-${BROWSER_VERSION}:${PORTSDIR}/www/netscape${BROWSER_VER}-${BROWSER_NAME} \
${LOCALBASE}/lib/aout/libxpg4-ns.so.2.0:${PORTSDIR}/www/libxpg4-ns \
${X11BASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf
@@ -24,10 +24,10 @@ RUN_DEPENDS?= \
PKGNAMEPREFIX?= zh_TW-
LOCALE?= zh_TW.Big5
REGION?= tw
-BROWSER?= communicator
+BROWSER_NAME?= communicator
BROWSER_VER?= 47
BROWSER_VERSION?= 4.76
-BROWSER_ARC?= ${BROWSER}
+BROWSER_ARC?= ${BROWSER_NAME}
BROWSER_BIN?= ${BROWSER_ARC}-${BROWSER_VERSION}.bin
BROWSER_CMD?= ${REGION}-${BROWSER_ARC}-${BROWSER_VER}
NSUBDIR?= lib/netscape
@@ -55,7 +55,7 @@ do-configure:
${MAKESCRIPT} ${FILESDIR}/INSTALL.in > ${WRKDIR}/pkg-install
${MAKESCRIPT} ${FILESDIR}/MESSAGE.in > ${WRKDIR}/pkg-message
${MAKESCRIPT} ${FILESDIR}/DEINSTALL.in > ${WRKDIR}/pkg-deinstall
-.if (${BROWSER} == navigator)
+.if (${BROWSER_NAME} == navigator)
${SED} "s/Communicator/Navigator/g" ${WRKSRC}/Netscape.ad \
> ${WRKSRC}/Netscape
.else
diff --git a/chinese/netscape47-navigator/Makefile b/chinese/netscape47-navigator/Makefile
index e858a3665a47..a11fb6a6dc02 100644
--- a/chinese/netscape47-navigator/Makefile
+++ b/chinese/netscape47-navigator/Makefile
@@ -2,10 +2,10 @@
# Date created: 23 Oct 2000
# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
#
-# $FreeBSD: /tmp/pcvs/ports/chinese/netscape47-navigator/Attic/Makefile,v 1.2 2000-11-06 18:14:56 keith Exp $
+# $FreeBSD: /tmp/pcvs/ports/chinese/netscape47-navigator/Attic/Makefile,v 1.3 2001-08-19 08:33:23 knu Exp $
#
-BROWSER= navigator
+BROWSER_NAME= navigator
MASTERDIR= ${.CURDIR}/../netscape47-communicator
.include "${.CURDIR}/../netscape47-communicator/Makefile"