aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-24 06:31:11 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-24 06:31:11 +0000
commit2f7b871e6afaeba06e2a1b6e51540a749f5d7a88 (patch)
treebfc5e2ce9024783776aa3ab6397c14d68b5f74e3 /chinese
parent44b3983a8b7710d501ca623b3f74f11cf400474a (diff)
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/BBMan/Makefile31
-rw-r--r--chinese/BBMan/distinfo2
-rw-r--r--chinese/BBMan/pkg-descr3
-rw-r--r--chinese/BBMan/pkg-plist1
-rw-r--r--chinese/Makefile1
5 files changed, 38 insertions, 0 deletions
diff --git a/chinese/BBMan/Makefile b/chinese/BBMan/Makefile
new file mode 100644
index 000000000000..b32995746bd7
--- /dev/null
+++ b/chinese/BBMan/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: zh-BBMan
+# Date created: 24 July 2004
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BBMan
+PORTVERSION= 1.7.7.5
+CATEGORIES= chinese net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bbman
+DISTNAME= BBMan-src-v1-7-7-5
+EXTRACT_SUFX= .zip
+
+MAINTAINER= ports@freebsd.org
+COMMENT= BBMan is a BBS client for X Window System
+
+LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/BBMan
+USE_X_PREFIX= yes
+
+do-build:
+ cd ${WRKSRC} && g++ main.cpp `wxgtk2-2.4-config --libs --cxxflags` -I${LOCALBASE}/include -O2 -o BBMan
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/BBMan ${PREFIX}/bin/BBMan
+
+.include <bsd.port.mk>
diff --git a/chinese/BBMan/distinfo b/chinese/BBMan/distinfo
new file mode 100644
index 000000000000..607e2f81a8ea
--- /dev/null
+++ b/chinese/BBMan/distinfo
@@ -0,0 +1,2 @@
+MD5 (BBMan-src-v1-7-7-5.zip) = dd5834d1aec91a4e00a788a546f16bab
+SIZE (BBMan-src-v1-7-7-5.zip) = 171904
diff --git a/chinese/BBMan/pkg-descr b/chinese/BBMan/pkg-descr
new file mode 100644
index 000000000000..2d1c96a7fd4e
--- /dev/null
+++ b/chinese/BBMan/pkg-descr
@@ -0,0 +1,3 @@
+BBMam is a BBS client for X Window System.
+
+WWW: http://nccu.edu.tw/92753008/BBMan/
diff --git a/chinese/BBMan/pkg-plist b/chinese/BBMan/pkg-plist
new file mode 100644
index 000000000000..9ecef875e240
--- /dev/null
+++ b/chinese/BBMan/pkg-plist
@@ -0,0 +1 @@
+bin/BBMan
diff --git a/chinese/Makefile b/chinese/Makefile
index 2d44a09c7be9..a79e2b9d3d02 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -3,6 +3,7 @@
COMMENT = Chinese support
+ SUBDIR += BBMan
SUBDIR += CJK
SUBDIR += FreeWnn-lib
SUBDIR += FreeWnn-server