aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-12 07:14:44 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-12 07:14:44 +0000
commitdbd08195c748c878161571e1b9e3d09b96bd15b3 (patch)
treee81704df25542482f32e87c0c4b59172d22fcc2e /chinese
parentf3a4d01c12dcb2d993a4b41ca52ef8f5265845ab (diff)
downloadports-dbd08195c748c878161571e1b9e3d09b96bd15b3.tar.gz
ports-dbd08195c748c878161571e1b9e3d09b96bd15b3.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/scim-chinese/Makefile26
-rw-r--r--chinese/scim-pinyin/Makefile26
-rw-r--r--chinese/scim-tables/Makefile12
3 files changed, 50 insertions, 14 deletions
diff --git a/chinese/scim-chinese/Makefile b/chinese/scim-chinese/Makefile
index c01ef604dd1a..485d540a0ae6 100644
--- a/chinese/scim-chinese/Makefile
+++ b/chinese/scim-chinese/Makefile
@@ -7,9 +7,11 @@
PORTNAME= scim-chinese
PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese
-MASTER_SITES= http://freedesktop.org/~suzhe/scim-chinese/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freedesktop.org/~suzhe/scim-chinese/
+MASTER_SITE_SUBDIR=scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= SCIM Chinese Smart Pinyin input method
@@ -22,15 +24,27 @@ USE_X_PREFIX= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
@${ECHO} To display this message again, type \`make post-install\'
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index c01ef604dd1a..485d540a0ae6 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -7,9 +7,11 @@
PORTNAME= scim-chinese
PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese
-MASTER_SITES= http://freedesktop.org/~suzhe/scim-chinese/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freedesktop.org/~suzhe/scim-chinese/
+MASTER_SITE_SUBDIR=scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= SCIM Chinese Smart Pinyin input method
@@ -22,15 +24,27 @@ USE_X_PREFIX= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
@${ECHO} To display this message again, type \`make post-install\'
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/chinese/scim-tables/Makefile b/chinese/scim-tables/Makefile
index 66e60d50c266..360e660b8c8e 100644
--- a/chinese/scim-tables/Makefile
+++ b/chinese/scim-tables/Makefile
@@ -8,7 +8,9 @@
PORTNAME= scim-tables
PORTVERSION= 0.4.0
CATEGORIES= chinese
-MASTER_SITES= http://freedesktop.org/~suzhe/sources/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freedesktop.org/~suzhe/sources/
+MASTER_SITE_SUBDIR=scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= SCIM table based Chinese input methods
@@ -20,10 +22,16 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BROKEN= scim-make-table is not available for 4.x
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
@${ECHO} To display this message again, type \`make post-install\'
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>