aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-28 15:15:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-28 15:15:25 +0000
commit337f9e9d28c7473c7d655c00ca6acbf1bba81ed0 (patch)
treeb859c13dd833c8841943888bfe1831a7a2a3143c /chinese
parent37694a56b108159b4b39c522e24da0e455d56d48 (diff)
downloadports-337f9e9d28c7473c7d655c00ca6acbf1bba81ed0.tar.gz
ports-337f9e9d28c7473c7d655c00ca6acbf1bba81ed0.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/unrar/Makefile2
-rw-r--r--chinese/unrar/files/patch-arcread.cpp26
2 files changed, 14 insertions, 14 deletions
diff --git a/chinese/unrar/Makefile b/chinese/unrar/Makefile
index c2ea423af0ac..7212c8fbd864 100644
--- a/chinese/unrar/Makefile
+++ b/chinese/unrar/Makefile
@@ -10,6 +10,6 @@ MASTERDIR= ${.CURDIR}/../../archivers/unrar
EXTRA_PATCHES= ${.CURDIR}/files/patch-arcread.cpp \
${.CURDIR}/files/patch-unicode.cpp
-CONFLICTS= unrar-[0-9]* unrar-iconv-[0-9]*
+CONFLICTS_INSTALL= unrar-[0-9]* unrar-iconv-[0-9]*
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/unrar/files/patch-arcread.cpp b/chinese/unrar/files/patch-arcread.cpp
index f5e7c65d9c63..10e37242702d 100644
--- a/chinese/unrar/files/patch-arcread.cpp
+++ b/chinese/unrar/files/patch-arcread.cpp
@@ -1,16 +1,16 @@
---- arcread.cpp.orig 2011-01-04 20:28:47.000000000 +0800
-+++ arcread.cpp 2011-01-21 22:59:22.000000000 +0800
-@@ -629,6 +629,7 @@
+--- arcread.cpp.orig 2013-12-01 16:10:14.000000000 +0800
++++ arcread.cpp 2014-02-04 09:23:21.669710373 +0800
+@@ -1272,6 +1272,7 @@
- void Archive::ConvertUnknownHeader()
+ void Archive::ConvertFileHeader(FileHeader *hd)
{
+ int big5=0;
- if (NewLhd.UnpVer<20 && (NewLhd.FileAttr & 0x10))
- NewLhd.Flags|=LHD_DIRECTORY;
- if (NewLhd.HostOS>=HOST_MAX)
-@@ -640,6 +641,16 @@
- }
- for (char *s=NewLhd.FileName;*s!=0;s=charnext(s))
+ if (Format==RARFMT15 && hd->UnpVer<20 && (hd->FileAttr & 0x10))
+ hd->Dir=true;
+ if (hd->HSType==HSYS_UNKNOWN)
+@@ -1282,6 +1283,16 @@
+
+ for (wchar *s=hd->FileName;*s!=0;s++)
{
+ if (big5==1) /* skip Big5 second byte */
+ {
@@ -22,6 +22,6 @@
+ big5=1;
+ continue;
+ }
- if (*s=='/' || *s=='\\')
- *s=CPATHDIVIDER;
- #if defined(_APPLE) && !defined(UNICODE_SUPPORTED)
+ #ifdef _UNIX
+ // Backslash is the invalid character for Windows file headers,
+ // but it can present in Unix file names extracted in Unix.