aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-12 02:25:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-12 02:25:07 +0000
commit7bfae932f73e6929fd4fc0afd04e81199c58df00 (patch)
treeae010486371dd984317b78c829a6c1566d322249 /chinese
parent43c9b0c5bc539452cc0f4da23f4ff1e08646554f (diff)
downloadports-7bfae932f73e6929fd4fc0afd04e81199c58df00.tar.gz
ports-7bfae932f73e6929fd4fc0afd04e81199c58df00.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". For people already testing powerpc on clang, it is possible that they already have both compilers in base. Thus, the assumption that "gcc is in base" (e.g. libstdc++.so exists) always means "force use of GCC" is already broken. It will be for everyone on -CURRENT once the switch is made. While here, standardize on compiler:c++11-lang instead of -lib (they are equivalent these days), pet portlint, and do some other cleanup. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=506432
Diffstat (limited to 'chinese')
-rw-r--r--chinese/pyzy/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/chinese/pyzy/Makefile b/chinese/pyzy/Makefile
index 88f1bc9a27fe..1eef448041c3 100644
--- a/chinese/pyzy/Makefile
+++ b/chinese/pyzy/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3
USE_GITHUB= yes
GH_TAGNAME= 6d9c3cd
-USES= compiler:c++11-lib gmake libtool pkgconfig python:2.7,build shebangfix autoreconf gettext-runtime pathfix
+USES= compiler:c++11-lang gmake libtool pkgconfig python:2.7,build shebangfix autoreconf gettext-runtime pathfix
SHEBANG_FILES= data/db/android/create_db.py
USE_GNOME= glib20
USE_LDCONFIG= yes
@@ -36,11 +36,13 @@ OPENCC_DESC= Use opencc for simplified and traditional Chinese conversion
OPENCC_CONFIGURE_ENABLE= opencc
OPENCC_LIB_DEPENDS= libopencc.so:chinese/opencc
-.if exists(/usr/lib/libstdc++.so)
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
CXXFLAGS+= -Wno-error=narrowing
.endif
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}-1.0.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>