aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-13 22:36:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-13 22:36:16 +0000
commitc10bf75884f436f1eba0a86fb602a6d669c81612 (patch)
tree172deaa3aca6cd6a3e95aa6511ab244fb496639e /chinese
parentd7da8381ae5c62527dc28fb8dd54874c757b69e2 (diff)
downloadports-c10bf75884f436f1eba0a86fb602a6d669c81612.tar.gz
ports-c10bf75884f436f1eba0a86fb602a6d669c81612.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/iiimf-le-chewing/Makefile34
-rw-r--r--chinese/iiimf-le-chewing/distinfo2
-rw-r--r--chinese/iiimf-le-chewing/files/patch-chewing.c19
-rw-r--r--chinese/iiimf-le-chewing/pkg-descr9
-rw-r--r--chinese/iiimf-le-chewing/pkg-plist2
6 files changed, 67 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 69fa863637f4..68d776e9e0c9 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -52,6 +52,7 @@
SUBDIR += hanzim
SUBDIR += hc
SUBDIR += hztty
+ SUBDIR += iiimf-le-chewing
SUBDIR += iiimf-le-newpy
SUBDIR += irssi
SUBDIR += jis2gb
diff --git a/chinese/iiimf-le-chewing/Makefile b/chinese/iiimf-le-chewing/Makefile
new file mode 100644
index 000000000000..75175d00f5d2
--- /dev/null
+++ b/chinese/iiimf-le-chewing/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: iiimf-le-chewing
+# Date created: 8 Sep 2004
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiimf-le-chewing
+PORTVERSION= 0.01
+CATEGORIES= chinese textproc
+MASTER_SITES= http://wagner.elixus.org/~clkao/
+DISTFILES= iiimf-chewing.tgz
+
+MAINTAINER= kcwu@csie.org
+COMMENT= IIIMF Chewing engine, an intelligent Chinese phonetic input method
+
+LIB_DEPENDS= chewing.1:${PORTSDIR}/chinese/libchewing
+BUILD_DEPENDS= ${LOCALBASE}/include/iiimf/iml/SunIM.h:${PORTSDIR}/textproc/iiimf-headers
+RUN_DEPENDS= ${LOCALBASE}/lib/im/htt:${PORTSDIR}/textproc/iiimf-server
+
+WRKSRC= ${WRKDIR}/trunk
+USE_ICONV= yes
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -o chewing.so -shared -fPIC -DARCH=\"${MACHINE_ARCH}\" \
+ -I${LOCALBASE}/include -I${LOCALBASE}/include/iiimf -I${LOCALBASE}/include/iiimf/iml -I${LOCALBASE}/include/chewing \
+ chewing.c -L${LOCALBASE}/lib -lchewing -liconv
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/im/leif
+ ${INSTALL_DATA} ${WRKSRC}/chewing.so ${PREFIX}/lib/im/leif
+
+.include <bsd.port.mk>
diff --git a/chinese/iiimf-le-chewing/distinfo b/chinese/iiimf-le-chewing/distinfo
new file mode 100644
index 000000000000..ff3ef958267b
--- /dev/null
+++ b/chinese/iiimf-le-chewing/distinfo
@@ -0,0 +1,2 @@
+MD5 (iiimf-chewing.tgz) = 349828bd3ff62621b9e924d696395edc
+SIZE (iiimf-chewing.tgz) = 5256
diff --git a/chinese/iiimf-le-chewing/files/patch-chewing.c b/chinese/iiimf-le-chewing/files/patch-chewing.c
new file mode 100644
index 000000000000..97ca0512729a
--- /dev/null
+++ b/chinese/iiimf-le-chewing/files/patch-chewing.c
@@ -0,0 +1,19 @@
+--- chewing.c.orig Sat Jan 31 14:41:35 2004
++++ chewing.c Wed Sep 8 04:33:13 2004
+@@ -40,7 +40,6 @@
+
+ #include "chewingio.h"
+ #include "hash.h"
+-#include "console_chewing.h"
+ #include "dict.h"
+ #include "zuin.h"
+
+@@ -647,7 +646,7 @@
+ case IM_VK_PAGE_DOWN:
+ break;
+
+- case KEY_TAB:
++ case '\t':
+ OnKeyTab(pgdata, op);
+ break;
+
diff --git a/chinese/iiimf-le-chewing/pkg-descr b/chinese/iiimf-le-chewing/pkg-descr
new file mode 100644
index 000000000000..a01f6b9bab59
--- /dev/null
+++ b/chinese/iiimf-le-chewing/pkg-descr
@@ -0,0 +1,9 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework
+
+Chewing - An Intelligent Chinese Phonetic Input Method for UNIX
+
+WWW: http://chewing.good-man.org/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/chinese/iiimf-le-chewing/pkg-plist b/chinese/iiimf-le-chewing/pkg-plist
new file mode 100644
index 000000000000..c3d15ffdbce2
--- /dev/null
+++ b/chinese/iiimf-le-chewing/pkg-plist
@@ -0,0 +1,2 @@
+lib/im/leif/chewing.so
+@unexec rmdir %D/lib/im/leif 2>/dev/null || true