aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-10-30 01:35:21 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-10-30 01:35:21 +0000
commitca5f083e1f70b982ecaef2161a9a02bc5f18ccfc (patch)
tree691ebc47adb0020eb41952d759a76abcf62c94f0 /chinese
parent7468059a5d21a855fa074cc0afd7a28fcf2a7c36 (diff)
downloadports-ca5f083e1f70b982ecaef2161a9a02bc5f18ccfc.tar.gz
ports-ca5f083e1f70b982ecaef2161a9a02bc5f18ccfc.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/pine4/Makefile7
-rw-r--r--chinese/pine4/files/patch-bz20
-rw-r--r--chinese/pine4/pkg-install9
3 files changed, 34 insertions, 2 deletions
diff --git a/chinese/pine4/Makefile b/chinese/pine4/Makefile
index 9307f3ee1959..6e6017e95f33 100644
--- a/chinese/pine4/Makefile
+++ b/chinese/pine4/Makefile
@@ -13,12 +13,15 @@ DISTNAME= pine${PORTVERSION}
MAINTAINER= avatar@www.mmlab.cse.yzu.edu.tw
-FORBIDDEN= "Remotely exploitable buffer overflows."
-
NO_LATEST_LINK= yes
MAN1= pine.1 pico.1 pilot.1
+pre-fetch:
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+ ${SH} pkg-install
+.endif
+
post-patch:
for i in ${WRKSRC}/doc/pine.1 \
${WRKSRC}/pine/init.c \
diff --git a/chinese/pine4/files/patch-bz b/chinese/pine4/files/patch-bz
new file mode 100644
index 000000000000..84b342953976
--- /dev/null
+++ b/chinese/pine4/files/patch-bz
@@ -0,0 +1,20 @@
+*** pine/newmail.c.orig Mon Sep 25 15:07:01 2000
+--- pine/newmail.c Tue Sep 26 15:34:24 2000
+***************
+*** 342,348 ****
+ e->from->personal, NULL),
+ ps_global->ttyo->screen_cols);
+ else
+! sprintf(from + ((number > 1L) ? 18 : 6), "%s%s%s",
+ e->from->mailbox,
+ e->from->host ? "@" : "",
+ e->from->host ? e->from->host : "");
+--- 342,349 ----
+ e->from->personal, NULL),
+ ps_global->ttyo->screen_cols);
+ else
+! snprintf(from + ((number > 1L) ? 18 : 6), sizeof(from) - strlen(from),
+! "%s%s%s",
+ e->from->mailbox,
+ e->from->host ? "@" : "",
+ e->from->host ? e->from->host : "");
diff --git a/chinese/pine4/pkg-install b/chinese/pine4/pkg-install
new file mode 100644
index 000000000000..b8e5db1ea6ee
--- /dev/null
+++ b/chinese/pine4/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+/usr/bin/dialog --yesno "SECURITY NOTE: The pine software has had several remote vulnerabilities discovered in the past, which allowed remote attackers to execute arbitrary code as you on your local system, by the action of sending a specially-prepared email. All such KNOWN problems have been fixed, but the pine code is written in a very insecure style and the FreeBSD Security Officer believes there are likely to be other undiscovered vulnerabilities. Do you wish to proceed with the installation of pine anyway?" 12 70 || /usr/bin/false
+
+