aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-05-20 06:24:00 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-05-20 06:24:00 +0000
commitf3543f44594eb15d5242aed9282d7cd8b39d74ab (patch)
tree68cd163904c6de4aee6b9193829247d2c8ac1ba3 /chinese
parent7ce7a0efa8aa0ec3de128ff5389c2a3fe63b3992 (diff)
downloadports-f3543f44594eb15d5242aed9282d7cd8b39d74ab.tar.gz
ports-f3543f44594eb15d5242aed9282d7cd8b39d74ab.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/libtabe/Makefile19
-rw-r--r--chinese/libtabe/files/patch-src__supports__bims__Makefile.in14
2 files changed, 25 insertions, 8 deletions
diff --git a/chinese/libtabe/Makefile b/chinese/libtabe/Makefile
index af22759d615b..e6489aee0425 100644
--- a/chinese/libtabe/Makefile
+++ b/chinese/libtabe/Makefile
@@ -3,16 +3,16 @@
PORTNAME= libtabe
PORTVERSION= 0.2.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= chinese
MASTER_SITES= ftp://cle.linux.org.tw/pub/xcin/cvs/
MAINTAINER= clsung@FreeBSD.org
COMMENT= Unified library for Chinese text processing
+USES= gmake
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USES= gmake
USE_BDB= yes
OBSOLETE_BDB_VAR= USE_DB2
DATADIR= ${PREFIX}/share/tabe
@@ -26,13 +26,16 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--enable-shared
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFAULT= DOCS
+
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
PLIST_SUB+= X11=""
.else
-CONFIGURE_ARGS+=--without-x
+CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "
.endif
@@ -49,7 +52,7 @@ pre-everything::
post-patch:
${REINPLACE_CMD} -e '/objformat/s/echo aout/echo elf/' ${WRKSRC}/configure
-.if defined(WITHOUT_X11)
+.if !${PORT_OPTIONS:MX11}
${REINPLACE_CMD} -e '/all:/s/ bims//; /bims/d' ${WRKSRC}/src/Makefile.in
.endif
@@ -57,7 +60,7 @@ post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/tsi-src/README ${STAGEDIR}${DOCSDIR}/README.tsi
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
${INSTALL_DATA} ${WRKSRC}/src/supports/bims/README ${STAGEDIR}${DOCSDIR}/README.bims
.endif
.for DOC in BoPoMoFo.shtml Changes Changes.pre-0.1 TODO ZuYinCode.txt \
@@ -66,4 +69,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/libtabe/files/patch-src__supports__bims__Makefile.in b/chinese/libtabe/files/patch-src__supports__bims__Makefile.in
new file mode 100644
index 000000000000..2c23fc2a84a2
--- /dev/null
+++ b/chinese/libtabe/files/patch-src__supports__bims__Makefile.in
@@ -0,0 +1,14 @@
+--- ./src/supports/bims/Makefile.in.orig 2014-05-19 15:27:54.010122398 +0800
++++ ./src/supports/bims/Makefile.in 2014-05-19 15:28:23.998115848 +0800
+@@ -59,7 +59,7 @@
+ $(RM) Makefile
+
+ install: all
+- if [ ! -d $(libdir) ]; then $(INSTALL) -d $(libdir); fi
+- if [ ! -d $(includedir) ]; then $(INSTALL) -d $(includedir); fi
+- $(LIBTOOL) --mode=install $(INSTALL_DATA) $(LIBNAME) $(libdir)
+- $(INSTALL_DATA) $(INCLUDES) $(includedir)
++ if [ ! -d $(DESTDIR)$(libdir) ]; then $(INSTALL) -d $(DESTDIR)$(libdir); fi
++ if [ ! -d $(DESTDIR)$(includedir) ]; then $(INSTALL) -d $(DESTDIR)$(includedir); fi
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(LIBNAME) $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) $(INCLUDES) $(DESTDIR)$(includedir)