aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-15 06:16:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-15 06:16:33 +0000
commit8e4e10f423c28f24a83a2d64c69cf3eb57e6b5b8 (patch)
tree7bbefed6337f7da37827f353360b725216901eef /chinese
parent555de78a8bca085e7164065ae68c4b56f5bd0a3c (diff)
downloadports-8e4e10f423c28f24a83a2d64c69cf3eb57e6b5b8.tar.gz
ports-8e4e10f423c28f24a83a2d64c69cf3eb57e6b5b8.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/autoconvert/Makefile8
-rw-r--r--chinese/autoconvert/files/patch-aa18
2 files changed, 17 insertions, 9 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index 52673313d663..5318bc8ce632 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -13,10 +13,18 @@ MASTER_SITES= http://people.debian.org/~ygh/
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= Intelligent Chinese encoding converter
+USE_REINPLACE= yes
USE_GETOPT_LONG= yes
+CFLAGS+= "${CPPFLAGS}"
+MAKE_ENV= CFLAG="${CPPFLAGS}" LIBS="${LDFLAGS}"
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
+post-patch:
+.for dir in hzconvert contrib/xchat-plugins
+ @${REINPLACE_CMD} -e "s|^CFLAGS|#CLFAGS|" ${WRKSRC}/${dir}/Makefile
+.endfor
+
pre-install:
@${MKDIR} ${DATADIR}
.for i in ChangeLog LICENSE Readme TODO Thanks Version hz.txt procmailrc.example shed.big5 shed.gb shed.uni shed.utf7 shed.utf8
diff --git a/chinese/autoconvert/files/patch-aa b/chinese/autoconvert/files/patch-aa
index 89511447ecb7..acb87a179abb 100644
--- a/chinese/autoconvert/files/patch-aa
+++ b/chinese/autoconvert/files/patch-aa
@@ -1,12 +1,12 @@
--- Makefile.orig Sat Apr 28 09:45:46 2001
-+++ Makefile Thu Aug 9 23:31:09 2001
++++ Makefile Thu May 15 13:52:33 2003
@@ -1,7 +1,7 @@
CC=gcc
-CFLAG=-O2 -g -Wall -Iinclude
-LIBS= -Llib -lhz
-+CFLAG+=-Iinclude -I/usr/local/include
-+LIBS+=-Llib -lhz -L/usr/local/lib -lgnugetopt
++CFLAG+=-Iinclude
++LIBS+=-Llib -lhz
.PHONY: all hzlib clean install-home install
@@ -23,11 +23,11 @@
- install -m 755 contrib/xchat-plugins/xchat-autob5.so $(DESTDIR)/usr/share/zh-autoconvert
- install -m 644 include/*.h $(DESTDIR)/usr/include
- ln -s autogb $(DESTDIR)/usr/bin/autob5
-+ install -m 755 autogb $(PREFIX)/bin
-+ install -m 755 lib/libhz.so.0.0 $(PREFIX)/lib/libhz.so.0
++ ${BSD_INSTALL_PROGRAM} autogb $(PREFIX)/bin
++ ${BSD_INSTALL_PROGRAM} lib/libhz.so.0.0 $(PREFIX)/lib/libhz.so.0
+ cd $(PREFIX)/lib;ln -s libhz.so.0 libhz.so
-+ install -m 755 lib/libhz.a $(PREFIX)/lib
-+ install -m 755 contrib/xchat-plugins/xchat-autogb.so $(PREFIX)/share/zh-autoconvert
-+ install -m 755 contrib/xchat-plugins/xchat-autob5.so $(PREFIX)/share/zh-autoconvert
-+ install -m 644 include/*.h $(PREFIX)/include
++ ${BSD_INSTALL_PROGRAM} lib/libhz.a $(PREFIX)/lib
++ ${BSD_INSTALL_PROGRAM} contrib/xchat-plugins/xchat-autogb.so $(PREFIX)/share/zh-autoconvert
++ ${BSD_INSTALL_PROGRAM} contrib/xchat-plugins/xchat-autob5.so $(PREFIX)/share/zh-autoconvert
++ ${BSD_INSTALL_DATA} include/*.h $(PREFIX)/include
+ ln -s autogb $(PREFIX)/bin/autob5