aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-09 01:55:52 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-09 01:55:52 +0000
commitc11a12d0f6dbbaf4892fda3486f39044ac237f25 (patch)
tree0d4cb50362a79fc35ac9b40022e80a366245c2c1 /chinese
parent9b3f9ce1c223f6354586790bb52a62c05be43bdf (diff)
downloadports-c11a12d0f6dbbaf4892fda3486f39044ac237f25.tar.gz
ports-c11a12d0f6dbbaf4892fda3486f39044ac237f25.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/oxim/Makefile24
-rw-r--r--chinese/oxim/files/patch-Makefile.in4
-rw-r--r--chinese/oxim/files/patch-configure15
-rw-r--r--chinese/oxim/files/patch-src__util__oxim-setup__Makefile.in13
-rw-r--r--chinese/oxim/pkg-plist1
5 files changed, 52 insertions, 5 deletions
diff --git a/chinese/oxim/Makefile b/chinese/oxim/Makefile
index 335d396c0a61..dbc35247784f 100644
--- a/chinese/oxim/Makefile
+++ b/chinese/oxim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= oxim
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= chinese textproc
MASTER_SITES= ftp://ftp.opendesktop.org.tw/odp/OXIM/Source/ \
ftp://apt.nc.hcc.edu.tw/pub/mirror/opendesktop.org.tw/OXIM/Source/ \
@@ -22,7 +23,8 @@ RUN_DEPENDS= zh-fireflyttf>=0:${PORTSDIR}/chinese/fireflyttf
OPTIONS= GTK2 "Enable GTK2 input method module" On \
CHEWING "Enable Chewing input module" On \
- UNICODE "Enable Unicode input module" On
+ UNICODE "Enable Unicode input module" On \
+ SETUP "Enable GUI Setup Tool" On
USE_GCC= 3.2+
USE_ICONV= yes
@@ -39,8 +41,7 @@ CONFIGURE_ARGS+=--disable-bimsphone-module \
--disable-static \
--with-conf-dir=${TARGETDIR}/etc/${PORTNAME}
# oxim requires qinputcontextplugin.h which only exists in Debian package
-CONFIGURE_ARGS+=--disable-qt-immodule \
- --disable-setup-tool
+CONFIGURE_ARGS+=--disable-qt-immodule
.include <bsd.port.pre.mk>
@@ -74,6 +75,23 @@ CONFIGURE_ARGS+= --disable-unicode-module
PLIST_SUB+= UNICODE="@comment "
.endif
+.if !defined(WITHOUT_SETUP)
+BUILD_DEPENDS+= qmake:${PORTSDIR}/devel/qmake
+
+CONFIGURE_ARGS+= --enable-setup-tool
+PLIST_SUB+= SETUP=""
+
+USE_QT_VER= 3
+.include "${PORTSDIR}/Mk/bsd.kde.mk"
+
+QMAKESPEC?= freebsd-g++
+CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}" QTDIR="${QT_PREFIX}"
+MAKE_ARGS+= LOCALBASE="${LOCALBASE}" MAKE="${MAKE}" QMAKESPEC="${QMAKESPEC}"
+.else
+CONFIGURE_ARGS+= --disable-setup-tool
+PLIST_SUB+= SETUP="@comment "
+.endif
+
# TODO WITHOUT_NLS knob
#.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/chinese/oxim/files/patch-Makefile.in b/chinese/oxim/files/patch-Makefile.in
index a2ae28c47d01..94090972a4f6 100644
--- a/chinese/oxim/files/patch-Makefile.in
+++ b/chinese/oxim/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Fri Sep 8 05:15:45 2006
-+++ Makefile.in Fri Sep 8 05:16:05 2006
+--- ./Makefile.in.orig Fri Sep 22 17:20:10 2006
++++ ./Makefile.in Mon Oct 9 09:38:36 2006
@@ -672,8 +672,6 @@
diff --git a/chinese/oxim/files/patch-configure b/chinese/oxim/files/patch-configure
new file mode 100644
index 000000000000..96ee881818dc
--- /dev/null
+++ b/chinese/oxim/files/patch-configure
@@ -0,0 +1,15 @@
+--- ./configure.orig Fri Sep 22 17:19:58 2006
++++ ./configure Mon Oct 9 09:38:36 2006
+@@ -29055,9 +29055,9 @@
+
+ echo "$as_me:$LINENO: checking for qmake" >&5
+ echo $ECHO_N "checking for qmake... $ECHO_C" >&6
+- if test -f ${qt_dir}/bin/qmake ; then
+- echo "$as_me:$LINENO: result: ${qt_dir}/bin/qmake" >&5
+-echo "${ECHO_T}${qt_dir}/bin/qmake" >&6
++ if test -f ${LOCALBASE}/bin/qmake ; then
++ echo "$as_me:$LINENO: result: ${LOCALBASE}/bin/qmake" >&5
++echo "${ECHO_T}${LOCALBASE}/bin/qmake" >&6
+ have_qmake="yes"
+ else
+ echo "$as_me:$LINENO: result: not found!" >&5
diff --git a/chinese/oxim/files/patch-src__util__oxim-setup__Makefile.in b/chinese/oxim/files/patch-src__util__oxim-setup__Makefile.in
new file mode 100644
index 000000000000..a4613597a9e3
--- /dev/null
+++ b/chinese/oxim/files/patch-src__util__oxim-setup__Makefile.in
@@ -0,0 +1,13 @@
+--- ./src/util/oxim-setup/Makefile.in.orig Fri Sep 22 17:20:09 2006
++++ ./src/util/oxim-setup/Makefile.in Mon Oct 9 09:39:52 2006
+@@ -474,8 +474,8 @@
+ @ENABLE_SETUP_TOOL_TRUE@ main.cpp
+
+ @ENABLE_SETUP_TOOL_TRUE@oxim-setup: oxim-setup.pro
+-@ENABLE_SETUP_TOOL_TRUE@ $(QTDIR)/bin/qmake oxim-setup.pro -o Makefile.qt
+-@ENABLE_SETUP_TOOL_TRUE@ QTDIR=$(QTDIR) make -f Makefile.qt
++@ENABLE_SETUP_TOOL_TRUE@ QMAKESPEC=$(QMAKESPEC) $(LOCALBASE)/bin/qmake oxim-setup.pro -o Makefile.qt
++@ENABLE_SETUP_TOOL_TRUE@ QTDIR=$(QTDIR) $(MAKE) -f Makefile.qt
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/chinese/oxim/pkg-plist b/chinese/oxim/pkg-plist
index 5c994b4193f5..a9c86ec278bf 100644
--- a/chinese/oxim/pkg-plist
+++ b/chinese/oxim/pkg-plist
@@ -1,5 +1,6 @@
bin/oxim
bin/oxim-conv
+%%SETUP%%bin/oxim-setup
bin/oxim2tab
etc/oxim/locale.list
etc/oxim/oxim.conf