aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-20 11:45:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-20 11:45:22 +0000
commit401791425b840262429e64fa659430f20fb2b04d (patch)
tree7ac85be775a88b9f67dd7691e0d4a009a51c0295 /chinese
parentddef71acca8a8a26294a063c3abf1c6321b6881e (diff)
downloadports-401791425b840262429e64fa659430f20fb2b04d.tar.gz
ports-401791425b840262429e64fa659430f20fb2b04d.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/pcmanx/Makefile6
-rw-r--r--chinese/pcmanx/distinfo4
-rw-r--r--chinese/pcmanx/files/patch-src-stringutil.cpp10
-rw-r--r--chinese/pcmanx/files/patch-src-telnetcon.h10
-rw-r--r--chinese/pcmanx/files/patch-src-telnetview.cpp11
-rw-r--r--chinese/pcmanx/files/patch-src-termview.cpp11
6 files changed, 46 insertions, 6 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index 9a84974ab468..e0fd2e8eb2cc 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pcmanx
-PORTVERSION= 0.1.7
+PORTVERSION= 0.1.8
CATEGORIES= chinese net
MASTER_SITES= http://pcmanx.csie.net/release/ \
http://bbs.ilc.edu.tw/~chinsan/pcmanx/
@@ -32,9 +32,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|--tag=CXX||g' ${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/pcmanx/distinfo b/chinese/pcmanx/distinfo
index 312cf31db9be..b468fb52ad4c 100644
--- a/chinese/pcmanx/distinfo
+++ b/chinese/pcmanx/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcmanx-pure-gtk2-0.1.7.tar.gz) = b39d8254598a665b49e743200763fd96
-SIZE (pcmanx-pure-gtk2-0.1.7.tar.gz) = 502471
+MD5 (pcmanx-pure-gtk2-0.1.8.tar.gz) = 8b101c9bc3c8b761e6503dafcf8fab0f
+SIZE (pcmanx-pure-gtk2-0.1.8.tar.gz) = 503749
diff --git a/chinese/pcmanx/files/patch-src-stringutil.cpp b/chinese/pcmanx/files/patch-src-stringutil.cpp
new file mode 100644
index 000000000000..dc6f6f01903b
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-stringutil.cpp
@@ -0,0 +1,10 @@
+--- src/stringutil.cpp.orig Thu Jul 7 14:08:01 2005
++++ src/stringutil.cpp Wed Jul 20 13:32:46 2005
+@@ -11,6 +11,7 @@
+
+ #include "stringutil.h"
+ #include <ctype.h>
++#include <stdio.h>
+
+ int strncmpi(const char* str1, const char* str2, size_t len)
+ {
diff --git a/chinese/pcmanx/files/patch-src-telnetcon.h b/chinese/pcmanx/files/patch-src-telnetcon.h
new file mode 100644
index 000000000000..6d193f4f2958
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-telnetcon.h
@@ -0,0 +1,10 @@
+--- src/telnetcon.h.orig Tue Jul 19 21:30:01 2005
++++ src/telnetcon.h Wed Jul 20 13:36:06 2005
+@@ -25,6 +25,7 @@
+ #include <string>
+ #include <vector>
+
++#include <sys/types.h>
+ #include <netinet/in.h>
+
+ using namespace std;
diff --git a/chinese/pcmanx/files/patch-src-telnetview.cpp b/chinese/pcmanx/files/patch-src-telnetview.cpp
new file mode 100644
index 000000000000..229e8450ef12
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-telnetview.cpp
@@ -0,0 +1,11 @@
+--- src/telnetview.cpp.orig Wed Jul 20 07:07:54 2005
++++ src/telnetview.cpp Wed Jul 20 13:39:22 2005
+@@ -178,7 +178,7 @@
+ "utf-8", m_pTermData->m_Encoding.c_str(), "?", NULL, &wl, NULL);
+ if(purl)
+ {
+- m_s_ANSIColorStr.clear();
++ m_s_ANSIColorStr = "";
+ GtkClipboard* clipboard = gtk_clipboard_get( GDK_NONE );
+ gtk_clipboard_set_text(clipboard, purl, wl );
+ clipboard = gtk_clipboard_get( GDK_SELECTION_PRIMARY);
diff --git a/chinese/pcmanx/files/patch-src-termview.cpp b/chinese/pcmanx/files/patch-src-termview.cpp
new file mode 100644
index 000000000000..f9cdc6443e2f
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-termview.cpp
@@ -0,0 +1,11 @@
+--- src/termview.cpp.orig Tue Jul 19 19:37:38 2005
++++ src/termview.cpp Wed Jul 20 13:27:05 2005
+@@ -728,7 +728,7 @@
+ m_s_ANSIColorStr = m_pTermData->GetSelectedTextWithColor(trim);
+ else
+ {
+- m_s_ANSIColorStr.clear();
++ m_s_ANSIColorStr = "";
+ string text = m_pTermData->GetSelectedText(trim);
+
+ gsize wl = 0;