aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-05-16 16:06:29 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-05-16 16:06:29 +0000
commite9b46b36232dc852105a3d17da80b0d8c9edcb39 (patch)
tree6e3b0f97ed75e1b247da10a2ca92cf75001e1215 /chinese
parent563f62c5c7af7c46cbec3a4c5f9c91a40624dd8f (diff)
downloadports-e9b46b36232dc852105a3d17da80b0d8c9edcb39.tar.gz
ports-e9b46b36232dc852105a3d17da80b0d8c9edcb39.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/big5con/Makefile1
-rw-r--r--chinese/big5con/files/patch-src-fnld.c11
-rw-r--r--chinese/big5con/files/patch-src-vc.c42
3 files changed, 54 insertions, 0 deletions
diff --git a/chinese/big5con/Makefile b/chinese/big5con/Makefile
index c7f905af0e5d..a9b9e2834649 100644
--- a/chinese/big5con/Makefile
+++ b/chinese/big5con/Makefile
@@ -7,6 +7,7 @@
PORTNAME= big5con
PORTVERSION= 0.92h
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/chinese/big5con/files/patch-src-fnld.c b/chinese/big5con/files/patch-src-fnld.c
new file mode 100644
index 000000000000..3c48163855b9
--- /dev/null
+++ b/chinese/big5con/files/patch-src-fnld.c
@@ -0,0 +1,11 @@
+--- src/fnld.c.orig Mon May 16 14:04:51 2005
++++ src/fnld.c Mon May 16 14:04:51 2005
+@@ -21,7 +21,7 @@
+
+ struct fontRegs *dbFReg, *sbFReg;
+
+-u_char *GetShmem();
++u_char *GetShmem(char);
+
+ void
+ FontDetach(bool down)
diff --git a/chinese/big5con/files/patch-src-vc.c b/chinese/big5con/files/patch-src-vc.c
new file mode 100644
index 000000000000..a9c54d724aab
--- /dev/null
+++ b/chinese/big5con/files/patch-src-vc.c
@@ -0,0 +1,42 @@
+--- src/vc.c.orig Mon May 16 13:33:11 2005
++++ src/vc.c Mon May 16 13:33:11 2005
+@@ -60,28 +60,23 @@
+ inline void
+ blatch(void *head, int n)
+ {
+-
+- __asm__ volatile ("\t clc\n"
+- "1:\n"
+- "\t andb %%bl, (%%eax)\n"
+- "\t incl %%eax\n"
+- "\t loop 1b\n"
+- : "=bl" (head), "=c"(n)
+- : "eax"((long)head), "0"(0x7F), "1"(n));
++ char *tmp = (char *)head;
++ do {
++ *tmp &= 0x7f;
++ tmp++;
++ } while( --n );
+ }
+
+ static
+ inline void
+ llatch(void *head, int n)
+ {
+-
+- __asm__ volatile ("\t clc\n"
+- "1:\n"
+- "\t andl %%ebx, (%%eax)\n"
+- "\t addl $4, %%eax\n"
+- "\t loop 1b\n"
+- : "=ebx" (head), "=c"(n)
+- : "eax"((long)head), "0"(0x7F7F7F7F), "1"(n >> 2));
++ int *tmp = (int *)head;
++ n /= 4;
++ do {
++ *tmp &= 0x7f7f7f7f;
++ tmp++;
++ } while( --n );
+ }
+
+ static inline u_int