aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-12-11 16:48:54 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-12-11 16:48:54 +0000
commitc7bd299595181cae9f77afee727ff2884b3c5276 (patch)
tree74a6f3b7daafa1bacd37bf685501c5b6653767d9 /chinese
parent16059f88ac82545001337ff6a2157667e4feef4f (diff)
downloadports-c7bd299595181cae9f77afee727ff2884b3c5276.tar.gz
ports-c7bd299595181cae9f77afee727ff2884b3c5276.zip
Fix packaging with python3
Notes
Notes: svn path=/head/; revision=456048
Diffstat (limited to 'chinese')
-rw-r--r--chinese/ibus-libpinyin/Makefile1
-rw-r--r--chinese/ibus-pinyin/Makefile3
2 files changed, 3 insertions, 1 deletions
diff --git a/chinese/ibus-libpinyin/Makefile b/chinese/ibus-libpinyin/Makefile
index d1bae508ca83..2137785d4524 100644
--- a/chinese/ibus-libpinyin/Makefile
+++ b/chinese/ibus-libpinyin/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
USES= compiler:c++11-lib gmake python pkgconfig gettext
USE_GNOME= glib20
+USE_PYTHON= py3kplist
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
index c43b2c7450ab..75252fe4d9f3 100644
--- a/chinese/ibus-pinyin/Makefile
+++ b/chinese/ibus-pinyin/Makefile
@@ -11,7 +11,7 @@ COMMENT= PinYin engine for IBus
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR} \
${LOCALBASE}/share/gir-1.0/IBus-1.0.gir:textproc/ibus
LIB_DEPENDS= libpyzy-1.0.so:chinese/pyzy \
libibus-1.0.so:textproc/ibus \
@@ -19,6 +19,7 @@ LIB_DEPENDS= libpyzy-1.0.so:chinese/pyzy \
USES= compiler:c++11-lib gmake pkgconfig python autoreconf libtool
USE_GNOME= glib20
+USE_PYTHON= py3kplist
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking --disable-lua-extension