aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-05-28 05:55:34 +0000
committerXin LI <delphij@FreeBSD.org>2007-05-28 05:55:34 +0000
commit9bf54d60d70e220705a72ade978aa32ce1034b73 (patch)
tree9a2c89acaaffaf14d5521a4f1d5077a207a9006a /chinese
parent2f96037a4c8683f5316754ceecde9e2124fd0e8c (diff)
downloadports-9bf54d60d70e220705a72ade978aa32ce1034b73.tar.gz
ports-9bf54d60d70e220705a72ade978aa32ce1034b73.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/wordpress/Makefile62
-rw-r--r--chinese/wordpress/distinfo3
-rw-r--r--chinese/wordpress/pkg-descr7
-rw-r--r--chinese/wordpress/pkg-message10
5 files changed, 83 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 7da58dac2d02..444f3620d904 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -131,6 +131,7 @@
SUBDIR += vflib
SUBDIR += wangttf
SUBDIR += wenju
+ SUBDIR += wordpress
SUBDIR += xemacs
SUBDIR += xemacs21
SUBDIR += xmms
diff --git a/chinese/wordpress/Makefile b/chinese/wordpress/Makefile
new file mode 100644
index 000000000000..b6d3dbdd4ddb
--- /dev/null
+++ b/chinese/wordpress/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: wordpress
+# Date created: 2007-05-11
+# Whom: Yinghong.Liu <liu_yinghong@yahoo.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordpress
+PORTVERSION= 2.2
+CATEGORIES= chinese www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}-zh
+PKGNAMEPREFIX= zh-
+DISTNAME= ${PORTNAME}_${PORTVERSION}_zh_CN
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= A state-of-the-art semantic personal publishing platform
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_ZIP= YES
+USE_PHP= mysql pcre xml
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+WORDPRESS?= www/wordpress
+PLIST_SUB+= WORDPRESS=${WORDPRESS}
+PLIST= ${WRKDIR}/pkg-plist
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PORTDOCS= license.txt readme.html
+
+pre-everything::
+ @${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
+ @${ECHO_CMD} ""
+ @sleep 1
+
+pre-install:
+ @${ECHO_CMD} "@unexec if cmp -s %D/www/wordpress/wp-config.php %D/www/wordpress/wp-config-sample.php; then ${RM} -f %D/www/wordpress/wp-config.php; fi" > ${PLIST}
+ @cd ${WRKSRC} && ${FIND} -s * -type f | \
+ ${SED} -e 's|^|${WORDPRESS}/|' >> ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${WORDPRESS}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrmtry ${WORDPRESS} >> ${PLIST}
+ @if [ ! -f ${WRKSRC}/wp-config.php ]; then ${CP} \
+ ${WRKSRC}/wp-config-sample.php ${WRKSRC}/wp-config.php; fi
+
+do-install:
+ @${MKDIR} ${PREFIX}/${WORDPRESS}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${WORDPRESS}
+ @${CHMOD} 755 ${PREFIX}/${WORDPRESS}
+ ${CP} -R ${WRKSRC}/ ${PREFIX}/${WORDPRESS}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+.endif
+ @${SED} "s|%%WORDPRESSDIR%%|${PREFIX}/${WORDPRESS}|g" \
+ ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/chinese/wordpress/distinfo b/chinese/wordpress/distinfo
new file mode 100644
index 000000000000..4e69a0b01495
--- /dev/null
+++ b/chinese/wordpress/distinfo
@@ -0,0 +1,3 @@
+MD5 (wordpress_2.2_zh_CN.zip) = ffe88453c983509d3e7119b16ea42119
+SHA256 (wordpress_2.2_zh_CN.zip) = 7877aea89dc64e9bd67c94fe9b44fd5990315f3e56d5d7202f57e594c7ce76d3
+SIZE (wordpress_2.2_zh_CN.zip) = 1118486
diff --git a/chinese/wordpress/pkg-descr b/chinese/wordpress/pkg-descr
new file mode 100644
index 000000000000..e87a805838d3
--- /dev/null
+++ b/chinese/wordpress/pkg-descr
@@ -0,0 +1,7 @@
+WordPress is a state-of-the-art semantic personal publishing platform
+with a focus on aesthetics, web standards, and usability.
+
+More simply, Wordpress is what you use when you want to work
+with your blogging software, not fight it.
+
+WWW: http://sourceforge.net/projects/wordpress-zh/
diff --git a/chinese/wordpress/pkg-message b/chinese/wordpress/pkg-message
new file mode 100644
index 000000000000..bd186d22d8e0
--- /dev/null
+++ b/chinese/wordpress/pkg-message
@@ -0,0 +1,10 @@
+
+ ********************************** NOTE **********************************
+
+ Before the first use of WordPress, modify %%WORDPRESSDIR%%/wp-config.php
+ to fit your MySQL. Maybe you need 'mysqladmin create wordpress' first
+
+ If you are upgrading from 1.x or 2.x to 2.2, please run
+ http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 2.2
+
+ **************************************************************************