aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-16 07:14:57 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-16 07:14:57 +0000
commit47b5d29bc5fd0e6b88110f9c288a5b80d1cb4a74 (patch)
treefbd7e70ca89a6ad87aca56078c7bf333a7e3f340 /chinese
parentcaeb2c7540d019548e577d2799649e23b2d4ca52 (diff)
downloadports-47b5d29bc5fd0e6b88110f9c288a5b80d1cb4a74.tar.gz
ports-47b5d29bc5fd0e6b88110f9c288a5b80d1cb4a74.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/wordpress-zh_CN/Makefile67
-rw-r--r--chinese/wordpress-zh_CN/distinfo3
-rw-r--r--chinese/wordpress-zh_CN/files/pkg-message.in15
-rw-r--r--chinese/wordpress-zh_CN/pkg-descr7
5 files changed, 93 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 3e8ccebd194a..58e9839aa490 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -137,6 +137,7 @@
SUBDIR += vflib
SUBDIR += wangttf
SUBDIR += wenju
+ SUBDIR += wordpress-zh_CN
SUBDIR += xemacs21
SUBDIR += xmms
SUBDIR += xpdf
diff --git a/chinese/wordpress-zh_CN/Makefile b/chinese/wordpress-zh_CN/Makefile
new file mode 100644
index 000000000000..052201d50338
--- /dev/null
+++ b/chinese/wordpress-zh_CN/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: wordpress-zh_CN
+# Date created: 2010-03-01
+# Whom: Joe Horn <joehorn@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordpress
+PORTVERSION= 2.9.2
+CATEGORIES= chinese www
+MASTER_SITES= http://cn.wordpress.org/
+PKGNAMESUFFIX= -zh_CN
+DISTNAME= wordpress-${PORTVERSION}-zh_CN
+
+MAINTAINER= joehorn@gmail.com
+COMMENT= A state-of-the-art semantic personal publishing platform
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PHP= mysql pcre xml gd tokenizer
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+
+WORDPRESS= www/wordpress-zh_CN
+WWWDIR= ${PREFIX}/${WORDPRESS}
+
+PLIST_SUB+= WORDPRESS=${WORDPRESS}
+PLIST= ${WRKDIR}/pkg-plist
+
+PORTDOCS= license.txt readme.html
+
+SUB_FILES+= pkg-message
+SUB_LISTS+= WWWDIR=${WWWDIR}
+
+pre-everything::
+ @${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
+ @${ECHO_CMD} ""
+ @sleep 1
+
+pre-install:
+ cd ${WRKSRC} && ${FIND} -s * -type f | \
+ ${SED} -e 's|^|${WORDPRESS}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${WORDPRESS}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${WORDPRESS} >> ${PLIST}
+ if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
+ ${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' \
+ >> ${TMPPLIST}
+ @${CHMOD} -R 755 ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${WWWDIR}' >> ${TMPPLIST}
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/chinese/wordpress-zh_CN/distinfo b/chinese/wordpress-zh_CN/distinfo
new file mode 100644
index 000000000000..340f39eb7673
--- /dev/null
+++ b/chinese/wordpress-zh_CN/distinfo
@@ -0,0 +1,3 @@
+MD5 (wordpress-2.9.2-zh_CN.tar.gz) = 7c2069bcdf92f3a4a287e6699a063b1c
+SHA256 (wordpress-2.9.2-zh_CN.tar.gz) = 6a33f9117178faa63d43ed558c4a475ab2cdb10881bde54466565353d965030a
+SIZE (wordpress-2.9.2-zh_CN.tar.gz) = 2475651
diff --git a/chinese/wordpress-zh_CN/files/pkg-message.in b/chinese/wordpress-zh_CN/files/pkg-message.in
new file mode 100644
index 000000000000..e40a28ebbe04
--- /dev/null
+++ b/chinese/wordpress-zh_CN/files/pkg-message.in
@@ -0,0 +1,15 @@
+*************************************************************************************
+Please read following note for installation steps before the first use of WordPress.
+
+1. Copy wp-config-sample.php to wp-config.php
+ in %%WWWDIR%% .
+
+2. Modify it to fit your MySQL.
+
+3. Modify your web server configuration.
+
+
+If you are upgrading from prior version, please browse this URL :
+
+ http://[WORDPRESS_URL]/wp-admin/upgrade.php
+
diff --git a/chinese/wordpress-zh_CN/pkg-descr b/chinese/wordpress-zh_CN/pkg-descr
new file mode 100644
index 000000000000..656bfdcdc8a1
--- /dev/null
+++ b/chinese/wordpress-zh_CN/pkg-descr
@@ -0,0 +1,7 @@
+WordPress is a state-of-the-art semantic personal publishing platform
+with a focus on aesthetics, web standards, and usability.
+
+More simply, Wordpress is what you use when you want to work
+with your blogging software, not fight it.
+
+WWW: http://cn.wordpress.org/