aboutsummaryrefslogtreecommitdiff
path: root/comms/acfax/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-08 04:53:25 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-08 04:53:25 +0000
commitd882b3b791bfc7edfb14ea67464bf08393121fd5 (patch)
tree92a2f00dc8b50573fbf869096f4f19d563aaa686 /comms/acfax/Makefile
parent1f79d984a399caf6081868650fa919cb88d12ee4 (diff)
downloadports-d882b3b791bfc7edfb14ea67464bf08393121fd5.tar.gz
ports-d882b3b791bfc7edfb14ea67464bf08393121fd5.zip
Notes
Diffstat (limited to 'comms/acfax/Makefile')
-rw-r--r--comms/acfax/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/comms/acfax/Makefile b/comms/acfax/Makefile
new file mode 100644
index 000000000000..758f5e2e2bd6
--- /dev/null
+++ b/comms/acfax/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: acfax
+# Date created: 20 February 2002
+# Whom: Darren <igla@batterybackups.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acfax
+PORTVERSION= 0.981011
+CATEGORIES= comms
+MASTER_SITES= ftp://ftp.funet.fi/pub/ham/unix/Linux/misc/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
+
+MAINTAINER= igla@batterybackups.net
+
+BUILD_DEPENDS= ${X11BASE}/lib/libXaw3d.a:${PORTSDIR}/x11-toolkits/Xaw3d
+RUN_DEPENDS= ${X11BASE}/lib/libXaw3d.a:${PORTSDIR}/x11-toolkits/Xaw3d
+
+WRKSRC= ${WRKDIR}/acfax
+USE_IMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e 's|setup_fax\(120, 288|setup_fax(120, 576|' \
+ ${WRKSRC}/acfax.c
+ @${PERL} -pi -e 's|ixoc = 288|ixoc = 576|' ${WRKSRC}/fax_funcs.c
+ @${PERL} -pi -e 's|regex.h|gnuregex.h|' ${WRKSRC}/RegExp.h
+ @${PERL} -pi -e 's|-lm|-lm -lgnuregex|' ${WRKSRC}/Imakefile
+
+post-configure:
+ ${TOUCH} ${WRKSRC}/acfax.man
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/acfax ${X11BASE}/bin
+
+.include <bsd.port.mk>