aboutsummaryrefslogtreecommitdiff
path: root/comms/aldo
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-29 21:29:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-29 21:29:34 +0000
commit8a12e04ed82f88dfd1fca0270db728dd01fefe74 (patch)
treec9bf7b11054e9c1c71c6f06b9a16e36469f6afbc /comms/aldo
parent7b53eea81cce6aa9006e1354749bad5e08e1e857 (diff)
downloadports-8a12e04ed82f88dfd1fca0270db728dd01fefe74.tar.gz
ports-8a12e04ed82f88dfd1fca0270db728dd01fefe74.zip
Notes
Diffstat (limited to 'comms/aldo')
-rw-r--r--comms/aldo/Makefile29
-rw-r--r--comms/aldo/distinfo2
-rw-r--r--comms/aldo/files/patch-Makefile21
-rw-r--r--comms/aldo/pkg-descr5
4 files changed, 57 insertions, 0 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
new file mode 100644
index 000000000000..7563b5544f2f
--- /dev/null
+++ b/comms/aldo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: aldo
+# Date created: 16 March 2004
+# Whom: lambert@lambertfam.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= aldo
+PORTVERSION= 0.6.3
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lambert@lambertfam.org
+COMMENT= Morse code training program
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/aldo
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+MAKE_ENV+= CXX="${CXX}"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/aldo/distinfo b/comms/aldo/distinfo
new file mode 100644
index 000000000000..7041ccd70fca
--- /dev/null
+++ b/comms/aldo/distinfo
@@ -0,0 +1,2 @@
+MD5 (aldo-0.6.3.tar.bz2) = 7548bed9282f4581858648236a9ac5e0
+SIZE (aldo-0.6.3.tar.bz2) = 18748
diff --git a/comms/aldo/files/patch-Makefile b/comms/aldo/files/patch-Makefile
new file mode 100644
index 000000000000..06ec482e7138
--- /dev/null
+++ b/comms/aldo/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.old Tue Mar 16 21:13:21 2004
++++ Makefile Tue Mar 16 21:14:20 2004
+@@ -3,6 +3,8 @@
+ includedir = $(CURDIR)/include
+ CXXFLAGS+= -I$(includedir)
+
++PREFIX ?= /usr
++
+ export MARCH CXXFLAGS
+
+ VPATH = src $(SUBDIRS)
+@@ -65,7 +67,7 @@
+
+ install: libs aldo uninstall
+ @strip aldo
+- @install -m555 -oroot aldo /usr/bin/
++ @install -m555 -oroot aldo $(PREFIX)/bin/
+
+ uninstall:
+- @$(RM) /usr/bin/aldo
++ @$(RM) $(PREFIX)/bin/aldo
diff --git a/comms/aldo/pkg-descr b/comms/aldo/pkg-descr
new file mode 100644
index 000000000000..ddc6573e726a
--- /dev/null
+++ b/comms/aldo/pkg-descr
@@ -0,0 +1,5 @@
+Aldo is a Morse code tutor. At the moment it has four kinds of
+exercises: Classic exercise, the Koch method, Callsign exercise, and
+exercises read from files.
+
+WWW: http://sourceforge.net/projects/aldo