aboutsummaryrefslogtreecommitdiff
path: root/comms/bforce-kst
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-30 10:31:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-30 10:31:21 +0000
commita76fdec1c55b9e031d49330b882dd1ac2822f23d (patch)
tree949827e3fc2086e8e71b626190fc80219d181144 /comms/bforce-kst
parent2010fa94716719c16496cfabb562a45ec9464eec (diff)
downloadports-a76fdec1c55b9e031d49330b882dd1ac2822f23d.tar.gz
ports-a76fdec1c55b9e031d49330b882dd1ac2822f23d.zip
Notes
Diffstat (limited to 'comms/bforce-kst')
-rw-r--r--comms/bforce-kst/Makefile31
-rw-r--r--comms/bforce-kst/distinfo4
-rw-r--r--comms/bforce-kst/files/patch-bforce.c26
-rw-r--r--comms/bforce-kst/files/patch-config.h.in33
-rw-r--r--comms/bforce-kst/files/patch-expression.y29
-rw-r--r--comms/bforce-kst/files/patch-sess_call.c26
6 files changed, 144 insertions, 5 deletions
diff --git a/comms/bforce-kst/Makefile b/comms/bforce-kst/Makefile
index 8b24e7e1ab05..4a583d6476a4 100644
--- a/comms/bforce-kst/Makefile
+++ b/comms/bforce-kst/Makefile
@@ -6,22 +6,47 @@
#
PORTNAME= bforce
-PORTVERSION= 0.22.7.5
-PORTREVISION= 1
+PORTVERSION= 0.22.8.7
CATEGORIES= comms
MASTER_SITES= http://kst.spb.ru/bforce/
PKGNAMESUFFIX= -kst
-DISTNAME= bforce-0.22.7.kst5
+DISTNAME= ${PORTNAME}-0.22.8.kst7
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple ifcico like Fidonet technology mailer
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CONFIGDIR= /etc/fido/bforce
+
+FIXME= include/bforce.h include/util.h include/logger.h \
+ bforce/bforce.c bforce/conf_proc.c bforce/conf_read.c bforce/daemon.c \
+ bforce/daemon_branch.c bforce/daemon_call.c bforce/daemon_lines.c \
+ bforce/expression.y bforce/freq_proc.c bforce/freq_wazoo.c bforce/io_modem.c \
+ bforce/io_tcpip.c bforce/io_unix_lock.c bforce/io_unix_modem.c \
+ bforce/io_unix_tio.c bforce/io_unix_tty.c bforce/logger.c bforce/nodelist.c \
+ bforce/os_unix.c bforce/outb_sysqueue.c bforce/prot_common.c bforce/prot_binkp.c \
+ bforce/prot_binkp_misc.c bforce/prot_hydra.c bforce/prot_zmmisc.c \
+ bforce/prot_zmrecv.c bforce/prot_zmsend.c bforce/prot_yoohoo.c \
+ bforce/prot_yoohoo_api.c bforce/prot_emsi.c bforce/prot_emsi_misc.c \
+ bforce/prot_emsi_api.c bforce/sess_call.c bforce/sess_answ.c bforce/sess_init.c \
+ bforce/sess_main.c bforce/u_misc.c bforce/u_time.c bforce/u_recode.c \
+ bforce/u_plock.c bfutil/bfindex.c
+
WRKSRC= ${WRKDIR}/${DISTNAME}/source
+pre-configure:
+ ${MKDIR} ${WRKSRC}/bin
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/bforce,${CONFIGDIR},g' ${WRKSRC}/Makefile.in
+.for i in ${FIXME}
+ @${REINPLACE_CMD} -e 's,log(,bf_log(,g' ${WRKSRC}/${i}
+.endfor
+
do-install:
${MKDIR} ${PREFIX}/etc/bforce
${INSTALL_DATA} ${WRKSRC}/../examples/bforce.conf ${PREFIX}/etc/bforce/bforce.conf.sample
diff --git a/comms/bforce-kst/distinfo b/comms/bforce-kst/distinfo
index b0d09946b9ad..9f613572e024 100644
--- a/comms/bforce-kst/distinfo
+++ b/comms/bforce-kst/distinfo
@@ -1,2 +1,2 @@
-MD5 (bforce-0.22.7.kst5.tar.bz2) = 6a5b9b0be70d23e9720787e4aa6c8f4e
-SIZE (bforce-0.22.7.kst5.tar.bz2) = 217436
+MD5 (bforce-0.22.8.kst7.tar.bz2) = 2c6f0f8581fec231c6a7d3a3dcfe06a2
+SIZE (bforce-0.22.8.kst7.tar.bz2) = 217675
diff --git a/comms/bforce-kst/files/patch-bforce.c b/comms/bforce-kst/files/patch-bforce.c
new file mode 100644
index 000000000000..ae21fd6828ae
--- /dev/null
+++ b/comms/bforce-kst/files/patch-bforce.c
@@ -0,0 +1,26 @@
+--- bforce/bforce.c Thu Nov 21 23:22:55 2002
++++ bforce/bforce.c Sat Apr 3 21:47:04 2004
+@@ -414,12 +419,12 @@
+ }
+ }
+
+- if( (rc = log_open(log_getfilename(LOG_FILE_SESSION), NULL, NULL)) )
++/* if( (rc = log_open(log_getfilename(LOG_FILE_SESSION), NULL, NULL)) )
+ {
+ log("can't continue without logging");
+ gotoexit(BFERR_FATALERROR);
+ }
+-
++*/
+ /* Process primary config file */
+ if( opts.confname && *opts.confname )
+ rc = conf_readconf(opts.confname, 0);
+@@ -433,7 +438,7 @@
+ (void)conf_readconf(opts.incname, 1);
+
+ /* Reopen log file if it was defined in config */
+- if( log_reopen(log_getfilename(LOG_FILE_SESSION), NULL, NULL) )
++ if( log_open(log_getfilename(LOG_FILE_SESSION), NULL, NULL) )
+ {
+ log("can't continue without logging");
+ gotoexit(BFERR_FATALERROR);
diff --git a/comms/bforce-kst/files/patch-config.h.in b/comms/bforce-kst/files/patch-config.h.in
new file mode 100644
index 000000000000..c476a20f06a0
--- /dev/null
+++ b/comms/bforce-kst/files/patch-config.h.in
@@ -0,0 +1,33 @@
+--- include/config.h.in Thu Aug 30 16:33:52 2001
++++ include/config.h.in Wed Sep 10 15:36:53 2003
+@@ -84,7 +84,7 @@
+ #undef HAVE_STATFS
+
+ /* Define if you have the statvfs function. */
+-#undef HAVE_STATVFS
++// #undef HAVE_STATVFS
+
+ /* Define if you have the strcasecmp function. */
+ #undef HAVE_STRCASECMP
+@@ -123,10 +123,10 @@
+ #undef HAVE_SYS_SELECT_H
+
+ /* Define if you have the <sys/statfs.h> header file. */
+-#undef HAVE_SYS_STATFS_H
++// #undef HAVE_SYS_STATFS_H
+
+ /* Define if you have the <sys/statvfs.h> header file. */
+-#undef HAVE_SYS_STATVFS_H
++// #undef HAVE_SYS_STATVFS_H
+
+ /* Define if you have the <sys/termiox.h> header file. */
+ #undef HAVE_SYS_TERMIOX_H
+@@ -135,7 +135,7 @@
+ #undef HAVE_SYS_TIME_H
+
+ /* Define if you have the <sys/vfs.h> header file. */
+-#undef HAVE_SYS_VFS_H
++// #undef HAVE_SYS_VFS_H
+
+ /* Define if you have the <termios.h> header file. */
+ #undef HAVE_TERMIOS_H
diff --git a/comms/bforce-kst/files/patch-expression.y b/comms/bforce-kst/files/patch-expression.y
new file mode 100644
index 000000000000..417fe959d541
--- /dev/null
+++ b/comms/bforce-kst/files/patch-expression.y
@@ -0,0 +1,29 @@
+--- bforce/expression.y.old Thu Aug 30 16:33:48 2001
++++ bforce/expression.y Thu Feb 6 23:38:32 2003
+@@ -52,6 +52,7 @@
+ #include "logger.h"
+ #include "session.h"
+ #include "nodelist.h"
++#include "io.h"
+
+ static struct tm *now = NULL;
+ static int expr_result = 0;
+@@ -205,6 +206,7 @@
+ {
+ $$ = expr_check_logic($1, OR, $3);
+ }
++ ;
+ %%
+
+ #include "expression_lex.c"
+@@ -329,6 +331,10 @@
+ else if( state.modemport && state.modemport->name )
+ {
+ return strstr(state.modemport->name, str) ? 1 : 0;
++ }
++ else if( isatty(0) )
++ {
++ return strstr(ttyname(0), str) ? 1 : 0;
+ }
+
+ return -1;
diff --git a/comms/bforce-kst/files/patch-sess_call.c b/comms/bforce-kst/files/patch-sess_call.c
new file mode 100644
index 000000000000..bef2ffbe6ca5
--- /dev/null
+++ b/comms/bforce-kst/files/patch-sess_call.c
@@ -0,0 +1,26 @@
+--- bforce/sess_call.c.orig Thu Nov 21 23:22:56 2002
++++ bforce/sess_call.c Sat May 29 22:37:30 2004
+@@ -609,10 +609,20 @@
+
+ if( !opts->hiddline )
+ {
+- if( timevec_isdefined(&state.override.worktime) )
+- goodtime = timevec_isnow(&state.override.worktime, now);
++ if( state.override.sFlags && !nodelist_checkflag(state.override.sFlags, "CM") )
++ goodtime = TRUE;
+ else
+- goodtime = timevec_isnow(&state.node.worktime, now);
++ {
++ if( timevec_isdefined(&state.override.worktime) )
++ goodtime = timevec_isnow(&state.override.worktime, now);
++ else
++ {
++ if( !nodelist_checkflag(state.node.flags, "CM") )
++ goodtime = TRUE;
++ else
++ goodtime = timevec_isnow(&state.node.worktime, now);
++ }
++ }
+ }
+ else
+ goodtime = timevec_isnow(&state.override.worktime, now);