aboutsummaryrefslogtreecommitdiff
path: root/comms/bforce-kst
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-07 06:59:53 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-07 06:59:53 +0000
commitbbc1787d3dcc16278efe26af444758780e97c118 (patch)
tree839dc27645dcb00e8c097c5dd88521f40260ecbb /comms/bforce-kst
parent631deef91135ae92207e0c98a609fa0304625580 (diff)
downloadports-bbc1787d3dcc16278efe26af444758780e97c118.tar.gz
ports-bbc1787d3dcc16278efe26af444758780e97c118.zip
Notes
Diffstat (limited to 'comms/bforce-kst')
-rw-r--r--comms/bforce-kst/Makefile2
-rw-r--r--comms/bforce-kst/files/patch-bfstat.c10
-rw-r--r--comms/bforce-kst/files/patch-sess_stat.c20
3 files changed, 31 insertions, 1 deletions
diff --git a/comms/bforce-kst/Makefile b/comms/bforce-kst/Makefile
index 1a5c701e8c5d..b6cac989f86b 100644
--- a/comms/bforce-kst/Makefile
+++ b/comms/bforce-kst/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bforce
PORTVERSION= 0.22.8.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms
MASTER_SITES= http://kst.spb.ru/bforce/
PKGNAMESUFFIX= -kst
diff --git a/comms/bforce-kst/files/patch-bfstat.c b/comms/bforce-kst/files/patch-bfstat.c
new file mode 100644
index 000000000000..51cff17e27ee
--- /dev/null
+++ b/comms/bforce-kst/files/patch-bfstat.c
@@ -0,0 +1,10 @@
+--- bfutil/bfstat.c.orig Thu Nov 21 23:23:00 2002
++++ bfutil/bfstat.c Sat Aug 7 02:20:35 2004
+@@ -17,6 +17,7 @@
+ #include "logger.h"
+ #include "util.h"
+ #include "outbound.h"
++#include "session.h"
+
+ /*
+ * Command line options storage structure
diff --git a/comms/bforce-kst/files/patch-sess_stat.c b/comms/bforce-kst/files/patch-sess_stat.c
new file mode 100644
index 000000000000..f6938012bbfa
--- /dev/null
+++ b/comms/bforce-kst/files/patch-sess_stat.c
@@ -0,0 +1,20 @@
+--- bforce/sess_stat.c.old Sat Aug 7 02:06:26 2004
++++ bforce/sess_stat.c Sat Aug 7 02:11:29 2004
+@@ -75,7 +75,7 @@
+
+ memset(stat, '\0', sizeof(s_sess_stat));
+
+- fscanf(fp, "%u %u %u %u %u %lu %lu %lu %lu",
++ fscanf(fp, "%u %u %u %u %u %u %lu %lu %lu %lu",
+ (unsigned int *) &stat->tries,
+ (unsigned int *) &stat->tries_noconn,
+ (unsigned int *) &stat->tries_noansw,
+@@ -98,7 +98,7 @@
+ if( fseek(fp, 0, SEEK_SET) == -1 )
+ return -1;
+
+- fprintf(fp, "%u %u %u %u %u %lu %lu %lu %lu",
++ fprintf(fp, "%u %u %u %u %u %u %lu %lu %lu %lu",
+ (unsigned int) stat->tries,
+ (unsigned int) stat->tries_noconn,
+ (unsigned int) stat->tries_noansw,