aboutsummaryrefslogtreecommitdiff
path: root/comms/chirp/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-12-27 21:10:53 +0000
committerDiane Bruce <db@FreeBSD.org>2013-12-27 21:10:53 +0000
commit2a5af251fff7f33a7642ba8ce5a1777382bc6dd3 (patch)
tree60047adb77d63fde78923730ab927ec4682a27e4 /comms/chirp/Makefile
parent18efa609ed2046439f11bf7bce4b38a0f1ecc464 (diff)
Notes
Diffstat (limited to 'comms/chirp/Makefile')
-rw-r--r--comms/chirp/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/comms/chirp/Makefile b/comms/chirp/Makefile
index ad991dcbc84e..8bf7ca5b7a88 100644
--- a/comms/chirp/Makefile
+++ b/comms/chirp/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= chirp
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= comms hamradio
MASTER_SITES= http://chirp.danplanet.com/download/${PORTVERSION}/ \
${MASTER_SITE_LOCAL}
@@ -10,24 +10,21 @@ MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Chirp is a free, open-source tool for programming your amateur radio
+LICENSE= GPLv3
+
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/serial:${PORTSDIR}/comms/py-serial \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
USE_PYTHON= YES
USE_PYDISTUTILS= YES
-MAN1= chirpw.1
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-configure:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/chirpui/mainapp.py
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>