aboutsummaryrefslogtreecommitdiff
path: root/comms/conserver
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-07-24 20:20:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-07-24 20:20:53 +0000
commitc61254ec743c38e45f0cc863446b91d46116a9ad (patch)
tree86c8dca860aed97b0623afaafba04010b2254d06 /comms/conserver
parent88f332edbc6093ae718ee140f3098cf91c329d2e (diff)
downloadports-c61254ec743c38e45f0cc863446b91d46116a9ad.tar.gz
ports-c61254ec743c38e45f0cc863446b91d46116a9ad.zip
Notes
Diffstat (limited to 'comms/conserver')
-rw-r--r--comms/conserver/Makefile2
-rw-r--r--comms/conserver/files/patch-sgtty63
2 files changed, 64 insertions, 1 deletions
diff --git a/comms/conserver/Makefile b/comms/conserver/Makefile
index a94e55427b9f..abccf88bda5b 100644
--- a/comms/conserver/Makefile
+++ b/comms/conserver/Makefile
@@ -8,7 +8,7 @@
PORTNAME= conserver
PORTVERSION= 8.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms
MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
http://www.komquats.com/distfiles/ \
diff --git a/comms/conserver/files/patch-sgtty b/comms/conserver/files/patch-sgtty
new file mode 100644
index 000000000000..c6c8e19cf092
--- /dev/null
+++ b/comms/conserver/files/patch-sgtty
@@ -0,0 +1,63 @@
+--- etc/autologin/autologin.c
++++ etc/autologin/autologin.c
+@@ -41,7 +41,6 @@
+
+ #if USE_TERMIOS
+ #include <termios.h>
+-#include <unistd.h>
+
+ #else
+ #if USE_TERMIO
+@@ -443,11 +442,11 @@
+ /* NOTREACHED */
+ }
+ #endif
+- n_tio.c_iflag &= ~(IGNCR|IUCLC);
++ n_tio.c_iflag &= ~(IGNCR);
+ n_tio.c_iflag |= ICRNL|IXON|IXANY;
+- n_tio.c_oflag &= ~(OLCUC|ONOCR|ONLRET|OFILL|NLDLY|CRDLY|TABDLY|BSDLY);
+- n_tio.c_oflag |= OPOST|ONLCR|TAB3;
+- n_tio.c_lflag &= ~(XCASE|NOFLSH|ECHOK|ECHONL);
++ n_tio.c_oflag &= ~(ONOCR|ONLRET);
++ n_tio.c_oflag |= OPOST|ONLCR|OXTABS;
++ n_tio.c_lflag &= ~(NOFLSH|ECHOK|ECHONL);
+ n_tio.c_lflag |= ISIG|ICANON|ECHO;
+ n_tio.c_cc[VEOF] = '\004'; /* ^D */
+ n_tio.c_cc[VEOL] = '\000'; /* EOL */
+--- etc/autologin/machine.h
++++ etc/autologin/machine.h
+@@ -38,7 +38,7 @@
+ #define USE_TERMIO (defined(ETA10)||defined(V386))
+ #endif
+ #if !defined(USE_TERMIOS)
+-#define USE_TERMIOS (defined(HPUX)||defined(SUN5)||defined(PTX)||defined(IRIX5)||defined(LINUX))
++#define USE_TERMIOS (defined(HPUX)||defined(SUN5)||defined(PTX)||defined(IRIX5)||defined(LINUX)||defined(FREEBSD))
+ #endif
+ #if !defined(USE_TCBREAK)
+ #define USE_TCBREAK (defined(SUN4)||defined(PTX))
+@@ -66,7 +66,7 @@
+ #endif
+
+ #if !defined(USE_TC)
+-#define USE_TC (defined(EPIX)||defined(IBMR2)||defined(V386)||defined(S81)||defined(PARAGON))
++#define USE_TC (defined(EPIX)||defined(IBMR2)||defined(V386)||defined(S81)||defined(PARAGON)||defined(FREEBSD))
+ #endif
+
+ #if !defined(HAVE_GETUSERATTR)
+@@ -74,7 +74,7 @@
+ #endif
+
+ #if !defined(USE_IOCTL)
+-#define USE_IOCTL (defined(V386)||defined(S81)||defined(NETBSD)||defined(FREEBSD))
++#define USE_IOCTL (defined(V386)||defined(S81)||defined(NETBSD))
+ #endif
+
+
+@@ -127,7 +127,6 @@
+ #if FREEBSD
+ #include <sys/uio.h>
+ #include <sys/proc.h>
+-#include <sys/ioctl_compat.h>
+ #define setsid() getpid()
+ #else
+