aboutsummaryrefslogtreecommitdiff
path: root/comms/cutecom/files
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-04-28 19:17:53 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-04-28 19:17:53 +0000
commitf4344fa32b908aba456757cae88a79a8f24fd89a (patch)
tree3464f7b6ffc73b8e579d50cdf8a46795c79a1a63 /comms/cutecom/files
parent93e15a2756aff8a814b2082ed6d991a662485dc9 (diff)
downloadports-f4344fa32b908aba456757cae88a79a8f24fd89a.tar.gz
ports-f4344fa32b908aba456757cae88a79a8f24fd89a.zip
Notes
Diffstat (limited to 'comms/cutecom/files')
-rw-r--r--comms/cutecom/files/patch-CMakeLists.txt14
-rw-r--r--comms/cutecom/files/patch-cutecommdlg.ui28
-rw-r--r--comms/cutecom/files/patch-qcppdialogimpl.cpp79
-rw-r--r--comms/cutecom/files/patch-qcppdialogimpl.h24
4 files changed, 67 insertions, 78 deletions
diff --git a/comms/cutecom/files/patch-CMakeLists.txt b/comms/cutecom/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..318b8a27a275
--- /dev/null
+++ b/comms/cutecom/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- ./CMakeLists.txt.orig 2008-03-13 00:09:49.000000000 +0300
++++ ./CMakeLists.txt 2009-04-25 21:48:15.000000000 +0400
+@@ -19,10 +19,4 @@
+
+ install(FILES cutecom.1 DESTINATION man/man1 )
+
+-find_program(KDECONFIG_EXECUTABLE NAMES kde-config )
+-
+-if (KDECONFIG_EXECUTABLE)
+- # then ask kde-config for the kde data dirs
+- exec_program(${KDECONFIG_EXECUTABLE} ARGS --install apps --expandvars OUTPUT_VARIABLE _apps_DIR )
+- install(FILES cutecom.desktop DESTINATION ${_apps_DIR}/Utilities)
+-endif (KDECONFIG_EXECUTABLE)
++install(FILES cutecom.desktop DESTINATION share/applications)
diff --git a/comms/cutecom/files/patch-cutecommdlg.ui b/comms/cutecom/files/patch-cutecommdlg.ui
index 67276a99aebf..5171d4eac0aa 100644
--- a/comms/cutecom/files/patch-cutecommdlg.ui
+++ b/comms/cutecom/files/patch-cutecommdlg.ui
@@ -1,14 +1,14 @@
---- cutecommdlg.ui.orig Thu Jul 15 01:11:45 2004
-+++ cutecommdlg.ui Thu Jul 15 01:12:07 2004
-@@ -248,11 +248,6 @@
- </item>
- <item>
- <property name="text">
-- <string>576000</string>
-- </property>
-- </item>
-- <item>
-- <property name="text">
- <string>921600</string>
- </property>
- </item>
+--- cutecommdlg.ui.orig 2008-03-12 16:09:50.000000000 -0500
++++ cutecommdlg.ui 2009-03-28 12:46:04.000000000 -0500
+@@ -220,11 +220,6 @@
+ </item>
+ <item>
+ <property name="text" >
+- <string>576000</string>
+- </property>
+- </item>
+- <item>
+- <property name="text" >
+ <string>921600</string>
+ </property>
+ </item>
diff --git a/comms/cutecom/files/patch-qcppdialogimpl.cpp b/comms/cutecom/files/patch-qcppdialogimpl.cpp
index 9e970a2c7e39..1f501b0e0341 100644
--- a/comms/cutecom/files/patch-qcppdialogimpl.cpp
+++ b/comms/cutecom/files/patch-qcppdialogimpl.cpp
@@ -1,78 +1,29 @@
---- qcppdialogimpl.cpp.orig 2008-03-10 17:53:45.000000000 -0500
-+++ qcppdialogimpl.cpp 2008-04-15 17:43:27.000000000 -0500
-@@ -49,6 +49,7 @@
- #include <sys/time.h>
- #include <sys/types.h>
- #include <sys/select.h>
-+#include <sys/param.h>
- #include <fcntl.h>
-
- void millisleep(int ms)
-@@ -234,11 +235,27 @@
+--- qcppdialogimpl.cpp.orig 2009-03-28 12:42:56.000000000 -0500
++++ qcppdialogimpl.cpp 2009-03-28 12:44:32.000000000 -0500
+@@ -243,11 +243,10 @@
bool entryFound=false;
QStringList devices=settings.readListEntry("/cutecom/AllDevices", &entryFound);
if (!entryFound)
-+#ifdef __FreeBSD__
-+#if __FreeBSD_version < 600000
-+ devices<<"/dev/cuaa0"<<"/dev/cuaa1"<<"/dev/cuaa2"<<"/dev/cuaa3"<<"/dev/cuaU0"<<"/dev/cuaU1";
-+#else
-+ devices<<"/dev/cuad0"<<"/dev/cuad1"<<"/dev/cuad2"<<"/dev/cuad3"<<"/dev/cuaU0"<<"/dev/cuaU1";
-+#endif
-+#else
- devices<<"/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
-+#endif
+- devices<<"/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
++ devices<<DEVLIST;
m_deviceCb->insertStringList(devices);
-
-+#ifdef __FreeBSD__
-+#if __FreeBSD_version < 600000
-+ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/cuaa0"));
-+#else
-+ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/cuad0"));
-+#endif
-+#else
- m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/ttyS0"));
-+#endif
+-
+- m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/ttyS0"));
++ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", DEFAULT_DEV));
QStringList history=settings.readListEntry("/cutecom/History");
-@@ -350,7 +367,7 @@
- m_sz->addArgument("sh");
- m_sz->addArgument("-c");
- // QString tmp=QString("sx -vv \"")+filename+"\" < "+m_deviceCb->currentText()+" > "+m_deviceCb->currentText();
-- QString tmp=QString("sz ");
-+ QString tmp=QString("lsz ");
- if (m_protoPb->currentText()=="XModem")
- tmp+="--xmodem ";
- else if (m_protoPb->currentText()=="YModem")
-@@ -472,7 +489,7 @@
-
- void QCPPDialogImpl::sendDone()
- {
-- cerr<<"sx exited"<<endl;
-+ cerr<<"lsx exited"<<endl;
- }
-
- bool QCPPDialogImpl::eventFilter(QObject* watched, QEvent *e)
-@@ -915,15 +932,21 @@
- case 230400:
- _baud=B230400;
- break;
-+#if !defined(__FreeBSD__) || (_FreeBSD_version > 500000)
+@@ -932,9 +931,9 @@
case 460800:
_baud=B460800;
break;
-+#endif
-+#ifndef __FreeBSD__
- case 576000:
- _baud=B576000;
- break;
-+#endif
-+#if !defined(__FreeBSD__) || (_FreeBSD_version >= 500000)
+- case 576000:
+- _baud=B576000;
+- break;
++// case 576000:
++// _baud=B576000;
++// break;
case 921600:
_baud=B921600;
break;
-+#endif
- // case 128000:
- // _baud=B128000;
- // break;
diff --git a/comms/cutecom/files/patch-qcppdialogimpl.h b/comms/cutecom/files/patch-qcppdialogimpl.h
new file mode 100644
index 000000000000..3629f490a098
--- /dev/null
+++ b/comms/cutecom/files/patch-qcppdialogimpl.h
@@ -0,0 +1,24 @@
+--- qcppdialogimpl.h.orig 2008-03-12 16:09:50.000000000 -0500
++++ qcppdialogimpl.h 2009-03-28 09:05:42.000000000 -0500
+@@ -103,4 +103,21 @@
+
+ };
+
++#if defined(__FreeBSD__)
++
++#define DEVLIST "/dev/cuaU0"<<"/dev/cuaU1"<<"/dev/cuad0"<<"/dev/cuad1";
++#define DEFAULT_DEV "/dev/cuaU0"
++
++#elif defined(__APPLE__)
++
++#define DEVLIST "/dev/cu.usbserial"<<"/dev/cu.KeySerial1";
++#define DEFAULT_DEV "/dev/cu.usbserial"
++
++#else // Default to Linux devices.
++
++#define DEVLIST "/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
++#define DEFAULT_DEV "/dev/ttyS0"
++
++#endif
++
+ #endif