aboutsummaryrefslogtreecommitdiff
path: root/comms/cutecom
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-07-30 08:24:48 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-07-30 08:24:48 +0000
commit6fed3376b4f0c761cb2aec2459a82f936dabdbb9 (patch)
treeaa98015f0440c44e30783b0ccbcff1ac6a3f0042 /comms/cutecom
parent7821520c40bc05058446723dbcf1af9d05a22c4a (diff)
downloadports-6fed3376b4f0c761cb2aec2459a82f936dabdbb9.tar.gz
ports-6fed3376b4f0c761cb2aec2459a82f936dabdbb9.zip
Notes
Diffstat (limited to 'comms/cutecom')
-rw-r--r--comms/cutecom/Makefile2
-rw-r--r--comms/cutecom/distinfo4
-rw-r--r--comms/cutecom/files/patch-qcppdialogimpl.cpp22
3 files changed, 9 insertions, 19 deletions
diff --git a/comms/cutecom/Makefile b/comms/cutecom/Makefile
index 39924f23e5d4..8ea0ceef0308 100644
--- a/comms/cutecom/Makefile
+++ b/comms/cutecom/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= cutecom
-PORTVERSION= 0.0.5
+PORTVERSION= 0.0.7
CATEGORIES= comms
MASTER_SITES= http://cutecom.sourceforge.net/
diff --git a/comms/cutecom/distinfo b/comms/cutecom/distinfo
index 6b40b4ff1660..c9562dbc0ea1 100644
--- a/comms/cutecom/distinfo
+++ b/comms/cutecom/distinfo
@@ -1,2 +1,2 @@
-MD5 (cutecom-0.0.5.tar.gz) = dea531a2ac9f82312f4888b9a2e7dc28
-SIZE (cutecom-0.0.5.tar.gz) = 16150
+MD5 (cutecom-0.0.7.tar.gz) = ef068d73bb27704c395557a5883179a0
+SIZE (cutecom-0.0.7.tar.gz) = 16682
diff --git a/comms/cutecom/files/patch-qcppdialogimpl.cpp b/comms/cutecom/files/patch-qcppdialogimpl.cpp
index fa5fa98af744..c3add52a2c08 100644
--- a/comms/cutecom/files/patch-qcppdialogimpl.cpp
+++ b/comms/cutecom/files/patch-qcppdialogimpl.cpp
@@ -1,16 +1,6 @@
---- qcppdialogimpl.cpp.orig Tue Jul 13 21:30:51 2004
-+++ qcppdialogimpl.cpp Thu Jul 15 01:45:55 2004
-@@ -44,6 +44,9 @@
- #include <ctype.h>
- #include <sys/ioctl.h>
- #include <sys/termios.h>
-+#ifdef __FreeBSD__
-+#include <sys/time.h>
-+#endif
- #include <fcntl.h>
-
- QCPPDialogImpl::QCPPDialogImpl(QWidget* parent)
-@@ -147,11 +150,19 @@
+--- qcppdialogimpl.cpp.orig Thu Jul 29 22:24:43 2004
++++ qcppdialogimpl.cpp Fri Jul 30 10:22:04 2004
+@@ -167,11 +167,19 @@
bool entryFound=false;
QStringList devices=settings.readListEntry("/cutecom/AllDevices", &entryFound);
if (!entryFound)
@@ -27,10 +17,10 @@
+#else
m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/ttyS0"));
+#endif
- }
- void QCPPDialogImpl::showAboutMsg()
-@@ -610,15 +621,21 @@
+ QStringList history=settings.readListEntry("/cutecom/History");
+ m_oldCmdsLb->insertStringList(history);
+@@ -659,15 +667,21 @@
case 230400:
_baud=B230400;
break;