aboutsummaryrefslogtreecommitdiff
path: root/comms/dcf77pi
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-06-21 22:46:12 +0000
committerRene Ladan <rene@FreeBSD.org>2013-06-21 22:46:12 +0000
commit11fb4232d6b268118951443102d00a81b9550d34 (patch)
tree804226b5020242e2a35d1d6a0653c5baa40209bf /comms/dcf77pi
parent413652f2c0b7c40980290e2b631a63dbf22bca1a (diff)
downloadports-11fb4232d6b268118951443102d00a81b9550d34.tar.gz
ports-11fb4232d6b268118951443102d00a81b9550d34.zip
Notes
Diffstat (limited to 'comms/dcf77pi')
-rw-r--r--comms/dcf77pi/Makefile34
-rw-r--r--comms/dcf77pi/distinfo2
-rw-r--r--comms/dcf77pi/pkg-descr6
-rw-r--r--comms/dcf77pi/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/comms/dcf77pi/Makefile b/comms/dcf77pi/Makefile
new file mode 100644
index 000000000000..e4b48c338528
--- /dev/null
+++ b/comms/dcf77pi/Makefile
@@ -0,0 +1,34 @@
+# Created by: rene@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= dcf77pi
+PORTVERSION= 1.0.1
+CATEGORIES= comms
+
+MAINTAINER= rene@FreeBSD.org
+COMMENT= DCF77 receiver/logger/analyzer for the Raspberry Pi
+
+LICENSE= BSD
+
+USE_GITHUB= yes
+GH_ACCOUNT= rene0
+GH_COMMIT= 135299c
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 900000
+IGNORE= no GPIO support
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}
+.endif
+ @if [ ! ${ETCDIR}/hardware.txt ] ; then \
+ ${CP} -p ${ETCDIR}/hardware.txt.sample ${ETCDIR}/hardware.txt ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/comms/dcf77pi/distinfo b/comms/dcf77pi/distinfo
new file mode 100644
index 000000000000..bd11daa5744a
--- /dev/null
+++ b/comms/dcf77pi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dcf77pi-1.0.1.tar.gz) = ade35ec36bef4e7fb306f5019f483d13fa78915a2c79e4210c53a587d2de91f1
+SIZE (dcf77pi-1.0.1.tar.gz) = 8340
diff --git a/comms/dcf77pi/pkg-descr b/comms/dcf77pi/pkg-descr
new file mode 100644
index 000000000000..03557890634a
--- /dev/null
+++ b/comms/dcf77pi/pkg-descr
@@ -0,0 +1,6 @@
+Yet another DCF77 decoder. This one is intended for the Raspberry Pi
+platform but might work on other devices using GPIO pins too.
+
+The received data can be logged for later playback/analysis.
+
+WWW: https://github.com/rene0/dcf77pi
diff --git a/comms/dcf77pi/pkg-plist b/comms/dcf77pi/pkg-plist
new file mode 100644
index 000000000000..2e3d6ab12ba8
--- /dev/null
+++ b/comms/dcf77pi/pkg-plist
@@ -0,0 +1,8 @@
+bin/dcf77pi
+bin/readpin
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+@unexec if cmp -s %D/etc/dcf77pi/hardware.txt.sample %D/etc/dcf77pi/hardware.txt ; then rm -f %D/etc/dcf77pi/hardware.txt ; fi
+etc/dcf77pi/hardware.txt.sample
+@exec if [ ! -f %D/etc/dcf77pi/hardware.txt ] ; then cp -p %D/%F %B/hardware.txt ; fi
+@dirrmtry %%ETCDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%