aboutsummaryrefslogtreecommitdiff
path: root/comms/ebook2cw/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-07-18 14:57:43 +0000
committerDiane Bruce <db@FreeBSD.org>2008-07-18 14:57:43 +0000
commit5d1097a0db04abd08b696bd55781c12d07fe92f9 (patch)
treecce287ec819f51bf7cc743672beff623e6dc8d04 /comms/ebook2cw/Makefile
parent658f6d2c05a019d32af317a5dbc23592f1815b43 (diff)
downloadports-5d1097a0db04abd08b696bd55781c12d07fe92f9.tar.gz
ports-5d1097a0db04abd08b696bd55781c12d07fe92f9.zip
Notes
Diffstat (limited to 'comms/ebook2cw/Makefile')
-rw-r--r--comms/ebook2cw/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/comms/ebook2cw/Makefile b/comms/ebook2cw/Makefile
new file mode 100644
index 000000000000..fc2841f3de61
--- /dev/null
+++ b/comms/ebook2cw/Makefile
@@ -0,0 +1,39 @@
+# ports collection makefile for: ebook2cw
+# Date created: 17 July 2008
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= ebook2cw
+PORTVERSION= 0.7.0
+CATEGORIES= comms hamradio
+MASTER_SITES= http://fkurz.net/ham/ebook2cw/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Convert textfiles into cw as a mp3 file
+
+LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame
+
+MAN1= ebook2cw.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|'g \
+ ${WRKSRC}/Makefile
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/ebook2cw ${PREFIX}/bin/ebook2cw
+ @${INSTALL_DATA} ${WRKSRC}/ebook2cw.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in ebook2cw.conf isomap.txt utf8map.txt
+ @${INSTALL_DATA} ${WRKSRC}/$f ${EXAMPLESDIR}/$f
+.endfor
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>