aboutsummaryrefslogtreecommitdiff
path: root/comms/ebook2cw
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-07-18 14:57:43 +0000
committerDiane Bruce <db@FreeBSD.org>2008-07-18 14:57:43 +0000
commit5d1097a0db04abd08b696bd55781c12d07fe92f9 (patch)
treecce287ec819f51bf7cc743672beff623e6dc8d04 /comms/ebook2cw
parent658f6d2c05a019d32af317a5dbc23592f1815b43 (diff)
downloadports-5d1097a0db04abd08b696bd55781c12d07fe92f9.tar.gz
ports-5d1097a0db04abd08b696bd55781c12d07fe92f9.zip
Notes
Diffstat (limited to 'comms/ebook2cw')
-rw-r--r--comms/ebook2cw/Makefile39
-rw-r--r--comms/ebook2cw/distinfo3
-rw-r--r--comms/ebook2cw/files/patch-Makefile17
-rw-r--r--comms/ebook2cw/files/patch-ebook2cw.c11
-rw-r--r--comms/ebook2cw/pkg-descr7
-rw-r--r--comms/ebook2cw/pkg-plist7
6 files changed, 84 insertions, 0 deletions
diff --git a/comms/ebook2cw/Makefile b/comms/ebook2cw/Makefile
new file mode 100644
index 000000000000..fc2841f3de61
--- /dev/null
+++ b/comms/ebook2cw/Makefile
@@ -0,0 +1,39 @@
+# ports collection makefile for: ebook2cw
+# Date created: 17 July 2008
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= ebook2cw
+PORTVERSION= 0.7.0
+CATEGORIES= comms hamradio
+MASTER_SITES= http://fkurz.net/ham/ebook2cw/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Convert textfiles into cw as a mp3 file
+
+LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame
+
+MAN1= ebook2cw.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|'g \
+ ${WRKSRC}/Makefile
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/ebook2cw ${PREFIX}/bin/ebook2cw
+ @${INSTALL_DATA} ${WRKSRC}/ebook2cw.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in ebook2cw.conf isomap.txt utf8map.txt
+ @${INSTALL_DATA} ${WRKSRC}/$f ${EXAMPLESDIR}/$f
+.endfor
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/ebook2cw/distinfo b/comms/ebook2cw/distinfo
new file mode 100644
index 000000000000..61de6fcd1689
--- /dev/null
+++ b/comms/ebook2cw/distinfo
@@ -0,0 +1,3 @@
+MD5 (ebook2cw-0.7.0.tar.gz) = 77a2902ef19340ad8528514822d17518
+SHA256 (ebook2cw-0.7.0.tar.gz) = 1f4ce59f78f5519986cfa0a8f4f9ca4e38996ddc1842511a79179a247719a33a
+SIZE (ebook2cw-0.7.0.tar.gz) = 19580
diff --git a/comms/ebook2cw/files/patch-Makefile b/comms/ebook2cw/files/patch-Makefile
new file mode 100644
index 000000000000..bf9c5e8f825b
--- /dev/null
+++ b/comms/ebook2cw/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig 2008-07-03 10:36:58.000000000 -0400
++++ Makefile 2008-07-18 08:34:18.000000000 -0400
+@@ -1,12 +1,12 @@
+ # ebook2cw Makefile -- Fabian Kurz, DJ1YFK -- http://fkurz.net/ham/ebook2cw.html
+
+ VERSION=0.7.0
+-DESTDIR ?= /usr
++DESTDIR ?= %%PREFIX%%
+
+ all: ebook2cw
+
+ ebook2cw: ebook2cw.c codetables.h
+- gcc ebook2cw.c -pedantic -Wall -lm -lmp3lame -D VERSION=\"$(VERSION)\" -o ebook2cw
++ ${CC} -I%%PREFIX%%/include -L%%PREFIX%%/lib ebook2cw.c ${CFLAGS} -lm -lmp3lame -D VERSION=\"$(VERSION)\" -o ebook2cw
+
+ static:
+ gcc -static ebook2cw.c -lmp3lame -lm -D VERSION=\"$(VERSION)\" -o ebook2cw
diff --git a/comms/ebook2cw/files/patch-ebook2cw.c b/comms/ebook2cw/files/patch-ebook2cw.c
new file mode 100644
index 000000000000..87b25d63059a
--- /dev/null
+++ b/comms/ebook2cw/files/patch-ebook2cw.c
@@ -0,0 +1,11 @@
+--- ebook2cw.c.orig 2008-07-17 21:28:33.000000000 -0400
++++ ebook2cw.c 2008-07-17 21:28:45.000000000 -0400
+@@ -20,7 +20,7 @@
+
+ */
+
+-#include "lame/lame.h"
++#include <lame/lame.h>
+ #include <math.h>
+ #include <stdio.h>
+ #include <string.h>
diff --git a/comms/ebook2cw/pkg-descr b/comms/ebook2cw/pkg-descr
new file mode 100644
index 000000000000..d19946b95e05
--- /dev/null
+++ b/comms/ebook2cw/pkg-descr
@@ -0,0 +1,7 @@
+ebook2cw is a command line program (optional GUI available) which converts
+a plain text (ISO 8859-1 or UTF-8) ebook to morse code MP3 files.
+It works on several platforms, including Windows and Linux.
+
+Written by Fabian Kurz, DJ1YFK <mail@fkurz.net>
+
+WWW: http://fkurz.net/ham/ebook2cw.html
diff --git a/comms/ebook2cw/pkg-plist b/comms/ebook2cw/pkg-plist
new file mode 100644
index 000000000000..2f8f04ad0614
--- /dev/null
+++ b/comms/ebook2cw/pkg-plist
@@ -0,0 +1,7 @@
+bin/ebook2cw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ebook2cw.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/isomap.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8map.txt
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%