aboutsummaryrefslogtreecommitdiff
path: root/comms/ebook2cw
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2011-04-16 16:21:33 +0000
committerDiane Bruce <db@FreeBSD.org>2011-04-16 16:21:33 +0000
commita4fea175f003f2ce8e3366841567df127b0612be (patch)
tree339207bea05594126d2d020a627cb1a440740e88 /comms/ebook2cw
parente682063978a2d87229d2e5ce6fe7d50215eccea7 (diff)
downloadports-a4fea175f003f2ce8e3366841567df127b0612be.tar.gz
ports-a4fea175f003f2ce8e3366841567df127b0612be.zip
Notes
Diffstat (limited to 'comms/ebook2cw')
-rw-r--r--comms/ebook2cw/Makefile2
-rw-r--r--comms/ebook2cw/distinfo4
-rw-r--r--comms/ebook2cw/files/patch-Makefile52
3 files changed, 42 insertions, 16 deletions
diff --git a/comms/ebook2cw/Makefile b/comms/ebook2cw/Makefile
index 23c9c6fc21f3..f2ea3ba5aae9 100644
--- a/comms/ebook2cw/Makefile
+++ b/comms/ebook2cw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ebook2cw
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.1
CATEGORIES= comms hamradio
MASTER_SITES= http://fkurz.net/ham/ebook2cw/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/ebook2cw/distinfo b/comms/ebook2cw/distinfo
index af86668ead83..f6b0c03ed4fa 100644
--- a/comms/ebook2cw/distinfo
+++ b/comms/ebook2cw/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ebook2cw-0.8.0.tar.gz) = 4eea453ec7557ca2739de936343c2b872346bd8224f83f8e3d1d6cf34a713654
-SIZE (ebook2cw-0.8.0.tar.gz) = 25711
+SHA256 (ebook2cw-0.8.1.tar.gz) = 3f97d2e6fbb419f8c985b0cbe3a9d33bfaa8fd746ea3651ecf086e523395c908
+SIZE (ebook2cw-0.8.1.tar.gz) = 26581
diff --git a/comms/ebook2cw/files/patch-Makefile b/comms/ebook2cw/files/patch-Makefile
index e779293b3df0..33abd14b7b31 100644
--- a/comms/ebook2cw/files/patch-Makefile
+++ b/comms/ebook2cw/files/patch-Makefile
@@ -1,28 +1,54 @@
---- Makefile.orig 2011-01-25 16:10:27.000000000 -0500
-+++ Makefile 2011-02-10 19:41:06.000000000 -0500
-@@ -1,19 +1,19 @@
+--- Makefile.orig 2011-04-04 15:57:55.000000000 -0400
++++ Makefile 2011-04-16 11:11:52.000000000 -0400
+@@ -1,34 +1,26 @@
# ebook2cw Makefile -- Fabian Kurz, DJ1YFK -- http://fkurz.net/ham/ebook2cw.html
- VERSION=0.8.0
+ VERSION=0.8.1
-DESTDIR ?= /usr
-+DESTDIR ?= %%PREFIX%%
++DESTDIR ?= /usr/local
+CC ?= gcc
+-# Set to NO to compile without Lame/Ogg-vorbis support
+-USE_LAME?=YES
+-USE_OGG?=YES
+
+ CFLAGS:=$(CFLAGS) -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\"
+
+-ifeq ($(USE_LAME), YES)
+- CFLAGS:=$(CFLAGS) -D LAME
+- LDFLAGS:=$(LDFLAGS) -lmp3lame
+-endif
+-ifeq ($(USE_OGG), YES)
+- CFLAGS:=$(CFLAGS) -D OGGV
+- LDFLAGS:=$(LDFLAGS) -lvorbis -lvorbisenc -logg
+-endif
++CFLAGS+= -I/usr/local/include -D LAME -D OGGV
++LDFLAGS+= -L/usr/local/lib -lmp3lame -lvorbis -lvorbisenc -logg
+
+
-all: ebook2cw
+all: ebook2cw cgi
ebook2cw: ebook2cw.c codetables.h
-- gcc ebook2cw.c -pedantic -Wall -lm -lmp3lame -lvorbis -lvorbisenc -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
-+ ${CC} -I%%PREFIX%%/include -L%%PREFIX%%/lib ebook2cw.c -pedantic -Wall -lm -lmp3lame -lvorbis -lvorbisenc -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
+- gcc ebook2cw.c -pedantic -Wall -lm $(LDFLAGS) $(CFLAGS) -o ebook2cw
++ ${CC} ebook2cw.c -pedantic -Wall -lm $(LDFLAGS) $(CFLAGS) -o ebook2cw
cgi: ebook2cw.c codetables.h
-- gcc -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -D CGI -o cw.cgi
-+ ${CC} -I%%PREFIX%%/include -L%%PREFIX%%/lib -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -D CGI -o cw.cgi
+- gcc -static ebook2cw.c $(LDFLAGS) -lm $(CFLAGS) -D CGI -o cw.cgi
++ ${CC} -static ebook2cw.c $(LDFLAGS) -lm $(CFLAGS) -D CGI -o cw.cgi
static:
-- gcc -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
--
-+ ${CC} -I%%PREFIX%% -L%%PREFIX%% -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
+- gcc -static ebook2cw.c $(LDFLAGS) -lm $(CFLAGS) -o ebook2cw
++ ${CC} -static ebook2cw.c $(LDFLAGS) -lm $(CFLAGS) -o ebook2cw
+
install:
install -d -v $(DESTDIR)/share/man/man1/
- install -d -v $(DESTDIR)/bin/
+@@ -41,7 +33,7 @@
+ install -m 0644 ebook2cw.conf $(DESTDIR)/share/doc/ebook2cw/examples/
+ install -m 0644 isomap.txt $(DESTDIR)/share/doc/ebook2cw/examples/
+ install -m 0644 utf8map.txt $(DESTDIR)/share/doc/ebook2cw/examples/
+-
++
+ uninstall:
+ rm -f $(DESTDIR)/bin/ebook2cw
+ rm -f $(DESTDIR)/share/man/man1/ebook2cw.1