aboutsummaryrefslogtreecommitdiff
path: root/comms/efax-gtk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-27 21:45:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-27 21:45:41 +0000
commitd041795889b90f505e904fa16ce390a4e4523b50 (patch)
tree1b1541da271f9f1cf17daed271a88c3ce3f57490 /comms/efax-gtk
parent964b1fe1d9aecaa1087c175e05698838b5cf4569 (diff)
downloadports-d041795889b90f505e904fa16ce390a4e4523b50.tar.gz
ports-d041795889b90f505e904fa16ce390a4e4523b50.zip
Notes
Diffstat (limited to 'comms/efax-gtk')
-rw-r--r--comms/efax-gtk/Makefile6
-rw-r--r--comms/efax-gtk/distinfo4
-rw-r--r--comms/efax-gtk/files/patch-install11
-rw-r--r--comms/efax-gtk/files/patch-pthread-include66
-rw-r--r--comms/efax-gtk/files/patch-src::config.h.in12
-rw-r--r--comms/efax-gtk/files/patch-src::prog_defs.h11
-rw-r--r--comms/efax-gtk/pkg-plist2
7 files changed, 73 insertions, 39 deletions
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index 731bdcc9e5fb..678b7d5043da 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -8,9 +8,10 @@
#
PORTNAME= efax-gtk
-PORTVERSION= 2.2.5
+PORTVERSION= 2.2.8
CATEGORIES= comms
-MASTER_SITES= http://www.cvine.freeserve.co.uk/efax-gtk/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .src.tgz
MAINTAINER= jb.quenot@caraldi.com
@@ -23,6 +24,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu
USE_X_PREFIX= YES
GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/gnome
MAN1= efax.1 efix.1 efax-gtk.1
.include <bsd.port.pre.mk>
diff --git a/comms/efax-gtk/distinfo b/comms/efax-gtk/distinfo
index 8f718a4f1248..379f0d51c659 100644
--- a/comms/efax-gtk/distinfo
+++ b/comms/efax-gtk/distinfo
@@ -1,2 +1,2 @@
-MD5 (efax-gtk-2.2.5.src.tgz) = 8458a262740d86db11fabbf501e4c3d6
-SIZE (efax-gtk-2.2.5.src.tgz) = 442037
+MD5 (efax-gtk-2.2.8.src.tgz) = a47cf133ccdb0a78c8cb9b6126ed208d
+SIZE (efax-gtk-2.2.8.src.tgz) = 582863
diff --git a/comms/efax-gtk/files/patch-install b/comms/efax-gtk/files/patch-install
deleted file mode 100644
index 86d620b3980b..000000000000
--- a/comms/efax-gtk/files/patch-install
+++ /dev/null
@@ -1,11 +0,0 @@
---- efax-gtk-faxfilter/Makefile.in.orig Thu Feb 5 21:35:06 2004
-+++ efax-gtk-faxfilter/Makefile.in Sun Feb 29 15:48:48 2004
-@@ -441,8 +441,6 @@
-
-
- install-data-hook:
-- chown lp $(spooldir)
-- chgrp lp $(spooldir)
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/comms/efax-gtk/files/patch-pthread-include b/comms/efax-gtk/files/patch-pthread-include
new file mode 100644
index 000000000000..96e44cdd4c0f
--- /dev/null
+++ b/comms/efax-gtk/files/patch-pthread-include
@@ -0,0 +1,66 @@
+--- src/efax_controller.cpp.orig Sun Jun 27 13:22:08 2004
++++ src/efax_controller.cpp Sun Jun 27 13:22:32 2004
+@@ -14,9 +14,6 @@
+ #include <sys/wait.h>
+ #include <fcntl.h>
+ #include <errno.h>
+-#ifdef HAVE_PTHREAD_SIGMASK
+-#include <pthread.h>
+-#endif
+
+ #include <fstream>
+ #include <iomanip>
+@@ -30,6 +27,10 @@
+ #include <glibmm/thread.h>
+
+ #include "efax_controller.h"
++
++#ifdef HAVE_PTHREAD_SIGMASK
++#include <pthread.h>
++#endif
+
+ #ifdef HAVE_STRINGSTREAM
+ #include <sstream>
+--- src/fax_list.cpp.orig Sun Jun 27 13:22:08 2004
++++ src/fax_list.cpp Sun Jun 27 13:22:44 2004
+@@ -24,9 +24,6 @@
+ #include <stdlib.h>
+ #include <signal.h>
+ #include <errno.h>
+-#ifdef HAVE_PTHREAD_SIGMASK
+-#include <pthread.h>
+-#endif
+
+ #include <gdkmm/pixbuf.h>
+ #include <gdk/gdkkeysyms.h> // the key codes are here
+@@ -42,6 +39,10 @@
+ #include "dialogs.h"
+ #include "fax_list_icons.h"
+ #include "pipes.h"
++
++#ifdef HAVE_PTHREAD_SIGMASK
++#include <pthread.h>
++#endif
+
+ #ifdef HAVE_STRINGSTREAM
+ #include <sstream>
+--- src/socket_server.cpp.orig Sun Jun 27 13:22:08 2004
++++ src/socket_server.cpp Sun Jun 27 13:22:54 2004
+@@ -20,14 +20,14 @@
+ #include <unistd.h>
+ #include <netdb.h>
+ #include <errno.h>
+-#ifdef HAVE_PTHREAD_SIGMASK
+-#include <pthread.h>
+-#endif
+
+ #include <glibmm/convert.h>
+
+ #include "socket_server.h"
+
++#ifdef HAVE_PTHREAD_SIGMASK
++#include <pthread.h>
++#endif
+
+ #ifdef ENABLE_NLS
+ #include <libintl.h>
diff --git a/comms/efax-gtk/files/patch-src::config.h.in b/comms/efax-gtk/files/patch-src::config.h.in
deleted file mode 100644
index 3955f3cf6303..000000000000
--- a/comms/efax-gtk/files/patch-src::config.h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/config.h.in.orig Thu Feb 5 21:37:17 2004
-+++ src/config.h.in Mon May 3 11:09:39 2004
-@@ -79,9 +79,3 @@
-
- /* Define to `unsigned' if <sys/types.h> does not define. */
- #undef size_t
--
--/* Define to `unsigned int' if <sys/types.h> does not define. */
--#undef socklen_t
--
--/* Define to `signed int' if <sys/types.h> does not define. */
--#undef ssize_t
diff --git a/comms/efax-gtk/files/patch-src::prog_defs.h b/comms/efax-gtk/files/patch-src::prog_defs.h
deleted file mode 100644
index a7665d118db6..000000000000
--- a/comms/efax-gtk/files/patch-src::prog_defs.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/prog_defs.h.orig Mon May 3 16:44:33 2004
-+++ src/prog_defs.h Mon May 3 16:44:46 2004
-@@ -9,6 +9,8 @@
- #ifndef PROG_DEFS_H
- #define PROG_DEFS_H
-
-+#include <unistd.h>
-+
- #include "config.h"
-
- // deal with any configuration issues arising from config.h
diff --git a/comms/efax-gtk/pkg-plist b/comms/efax-gtk/pkg-plist
index 971391a0d122..298c1c4a7cfb 100644
--- a/comms/efax-gtk/pkg-plist
+++ b/comms/efax-gtk/pkg-plist
@@ -2,4 +2,4 @@ bin/efax-gtk
bin/efax-0.9a
bin/efix-0.9a
etc/efax-gtkrc
-share/gnome/apps/Applications/efax-gtk.desktop
+share/gnome/applications/efax-gtk.desktop