aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-01-31 17:35:39 +0000
committerDiane Bruce <db@FreeBSD.org>2008-01-31 17:35:39 +0000
commit45c354e681e1e4a3fbcd8f2f4692a5227dad142a (patch)
treee2566deca2ec5e42d2ee5ce3b716ef5455401657 /comms/fldigi/Makefile
parent86a019e6d2758cb9dff086a4935f0852c9351e55 (diff)
downloadports-45c354e681e1e4a3fbcd8f2f4692a5227dad142a.tar.gz
ports-45c354e681e1e4a3fbcd8f2f4692a5227dad142a.zip
Notes
Diffstat (limited to 'comms/fldigi/Makefile')
-rw-r--r--comms/fldigi/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index b63a304310a8..a2ed3cdd5f3d 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fldigi
-PORTVERSION= 2.03
+PORTVERSION= 2.08
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/fldigi-2.0.distro/ \
${MASTER_SITE_LOCAL}
@@ -15,33 +15,33 @@ MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Digital decoder for psk, cw, psk31, olivia
+BUILD_DEPENDS= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk-threads \
hamlib:${PORTSDIR}/comms/hamlib \
sndfile:${PORTSDIR}/audio/libsndfile \
boost_wave:${PORTSDIR}/devel/boost
USE_GMAKE= yes
-
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ENV+= CXX="${CXX}"
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Install/fldigi ${PREFIX}/bin/fldigi
- ${MKDIR} ${DATADIR}
-.for f in ${WRKSRC}/icons/fldigi-psk.png \
- ${WRKSRC}/icons/fldigi-rtty.png \
- ${WRKSRC}/icons/fldigi.xpm
- ${INSTALL_DATA} ${WRKSRC}$f ${DATADIR}
-.endfor
- @${ECHO} ""
+.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" && ${OSVERSION} < 700000
+USE_GCC= 4.1
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/src/Makefile
+
+post-install:
.if !defined(NOPORTDOCS)
+ @${ECHO} ""
${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@${ECHO} "fldigi docs installed in ${DOCSDIR}"
-.endif
- @${ECHO} "fldigi icons installed in ${DATADIR}"
@${ECHO} ""
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>