aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-06-18 00:29:13 +0000
committerDiane Bruce <db@FreeBSD.org>2013-06-18 00:29:13 +0000
commit3641759c7d38e7abd40a4d975db75ac1749cd62c (patch)
treebd457127ef841e39606451b7edea23046d8ad11b /comms/fldigi
parenta1b0dbc4aee89bcda1c6fe038d7f61aafe988c6b (diff)
downloadports-3641759c7d38e7abd40a4d975db75ac1749cd62c.tar.gz
ports-3641759c7d38e7abd40a4d975db75ac1749cd62c.zip
Notes
Diffstat (limited to 'comms/fldigi')
-rw-r--r--comms/fldigi/files/patch-doc-Makefile.in6
-rw-r--r--comms/fldigi/files/patch-src_misc_configuration.cxx30
-rw-r--r--comms/fldigi/files/patch-src_throb_throb.cxx20
-rw-r--r--comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp12
4 files changed, 3 insertions, 65 deletions
diff --git a/comms/fldigi/files/patch-doc-Makefile.in b/comms/fldigi/files/patch-doc-Makefile.in
index 034f3f50e0ff..c2bb40fe76be 100644
--- a/comms/fldigi/files/patch-doc-Makefile.in
+++ b/comms/fldigi/files/patch-doc-Makefile.in
@@ -1,6 +1,6 @@
---- doc/Makefile.in.orig 2013-02-08 22:19:36.000000000 -0500
-+++ doc/Makefile.in 2013-03-31 19:16:17.000000000 -0500
-@@ -568,7 +568,7 @@
+--- doc/Makefile.in.orig 2013-05-17 05:57:05.000000000 -0500
++++ doc/Makefile.in 2013-06-17 19:11:13.000000000 -0500
+@@ -565,7 +565,7 @@
# The rest of the Makefile is enabled only if we have asciidoc
diff --git a/comms/fldigi/files/patch-src_misc_configuration.cxx b/comms/fldigi/files/patch-src_misc_configuration.cxx
deleted file mode 100644
index 271ce118303a..000000000000
--- a/comms/fldigi/files/patch-src_misc_configuration.cxx
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/misc/configuration.cxx.orig 2013-02-08 21:00:53.000000000 -0500
-+++ src/misc/configuration.cxx 2013-04-01 08:06:29.000000000 -0500
-@@ -891,8 +891,6 @@
-
- void configuration::testCommPorts()
- {
-- int retval;
--
- inpTTYdev->clear();
- inpRIGdev->clear();
- inpXmlRigDevice->clear();
-@@ -909,6 +907,7 @@
- #endif
-
- #ifdef __linux__
-+ int retval;
- bool ret = false;
- DIR* sys = NULL;
- char cwd[PATH_MAX] = { '.', '\0' };
-@@ -955,9 +954,7 @@
- "/dev/ttyS%u",
- "/dev/ttyUSB%u",
- "/dev/usb/ttyUSB%u"
--#elif defined(__FreeBSD__)
-- "/dev/ttyd%u"
--#elif defined(__OpenBSD__) || defined(__NetBSD__)
-+#elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
- "/dev/tty%2.2u"
- #elif defined(__CYGWIN__)
- "/dev/ttyS%u"
diff --git a/comms/fldigi/files/patch-src_throb_throb.cxx b/comms/fldigi/files/patch-src_throb_throb.cxx
deleted file mode 100644
index ce464d2bd14b..000000000000
--- a/comms/fldigi/files/patch-src_throb_throb.cxx
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/throb/throb.cxx.orig 2013-03-28 13:27:03.683043974 -0400
-+++ src/throb/throb.cxx 2013-03-28 13:27:55.988221471 -0400
-@@ -37,6 +37,8 @@
- #include "fl_digi.h"
- #include "status.h"
-
-+#define MAX_TONES 15 // Highest used I noticed was 11
-+
- #undef CLAMP
- #define CLAMP(x,low,high) (((x)>(high))?(high):(((x)<(low))?(low):(x)))
-
-@@ -410,7 +412,7 @@
-
- void throb::rx(complex in)
- {
-- complex rxword[num_tones];
-+ complex rxword[MAX_TONES];
- int i, tone1, tone2, maxtone;
-
- symbol[symptr] = in;
diff --git a/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp b/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp
deleted file mode 100644
index 7576d3f3988f..000000000000
--- a/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xmlrpcpp/XmlRpcDispatch.cpp.orig 2013-03-28 09:09:49.000000000 -0500
-+++ src/xmlrpcpp/XmlRpcDispatch.cpp 2013-03-28 09:10:13.000000000 -0500
-@@ -10,7 +10,9 @@
-
- #include <errno.h>
- #include <math.h>
-+#ifdef USE_FTIME
- #include <sys/timeb.h>
-+#endif
-
- #if defined(_WINDOWS)
- # include <winsock2.h>