aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-02-03 19:50:52 +0000
committerDiane Bruce <db@FreeBSD.org>2019-02-03 19:50:52 +0000
commit9c3bcb1cc11dcfe8ba9ad7d8700a2434f4f0a35c (patch)
tree4df89b232e31f1faa894cc91808093a260750796 /comms/fldigi
parent036988eb3d1b2e64a97c798f5badf0f3dc7ee40c (diff)
downloadports-9c3bcb1cc11dcfe8ba9ad7d8700a2434f4f0a35c.tar.gz
ports-9c3bcb1cc11dcfe8ba9ad7d8700a2434f4f0a35c.zip
- Correct to actually turn off unused options
- Add missing xrender to USE_ORG Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=492065
Diffstat (limited to 'comms/fldigi')
-rw-r--r--comms/fldigi/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index bdd59da3e9f0..8beae4a99923 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fldigi
PORTVERSION= 4.1.00
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -25,7 +26,7 @@ USES= autoreconf compiler:c++11-lib jpeg gmake perl5 pkgconfig shebangfix
USE_CXXSTD= gnu++0x
GNU_CONFIGURE= yes
-USE_XORG= x11 xft xext xfixes xcursor xinerama
+USE_XORG= x11 xft xext xfixes xcursor xinerama xrender
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
@@ -46,13 +47,13 @@ NATIVE_OPT_CONFIGURE_ON= --enable-optimizations=native
NATIVE_OPT_CONFIGURE_OFF= --enable-optimizations=none
FLARQ_CONFIGURE_ENABLE= flarq
OSS_CONFIGURE_ENABLE= oss
-SNDFILE_CONFIGURE_WITH= sndfile
+SNDFILE_CONFIGURE_ENABLE= sndfile
SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-PORTAUDIO_CONFIGURE_WITH= portaudio
+PORTAUDIO_CONFIGURE_ENABLE= portaudio
PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
-PULSEAUDIO_CONFIGURE_WITH= pulseaudio
+PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-HAMLIB_CONFIGURE_WITH= hamlib
+HAMLIB_CONFIGURE_ENABLE= hamlib
HAMLIB_LIB_DEPENDS= libhamlib.so:comms/hamlib
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext