aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-01-31 02:04:30 +0000
committerDiane Bruce <db@FreeBSD.org>2019-01-31 02:04:30 +0000
commitff35d1f90e35efda29886685aae7041ececbf36b (patch)
tree722035b5d6124eb35813015b1e3aeff15ec053f6 /comms/fldigi
parent9ae7504791b660ecbcecf3ef5a6d357019f25ec4 (diff)
downloadports-ff35d1f90e35efda29886685aae7041ececbf36b.tar.gz
ports-ff35d1f90e35efda29886685aae7041ececbf36b.zip
- Update to fldigi 4.1.00
- Restore OSS and pulseaudio options - Fix OSS bug in upstream code causing OSS to fail. =Version 4.1.0= 2019-01-29 David Freese <w1hkj@bellsouth.net> 39a76e8: po update 79c67d3: WWV doc 04e53b5: Winkeyer FSK b8ca88e: Contests b197c75: arq-override 8572f35: flmsg-dir 02c66eb: contest-docs 9d85169: fldigi_def.xml 20e2c02: socket_mods e1c2d80: Fltk 1.4 mod 5ffd6f5: wefax fb1fd67: nanoIO 7d604b8: CW SOM table 4eec8f2: flrig: macro 99b0a01: Audio adjust docs 146bd7e: feldhell 6b5c93a: C-11 fixes ccbd52f: nano FSK ed6a7db: Mint-19/Mate e9c0f2d: Signal Browser documentation fbb0654: flrig seg fault
Notes
Notes: svn path=/head/; revision=491675
Diffstat (limited to 'comms/fldigi')
-rw-r--r--comms/fldigi/Makefile15
-rw-r--r--comms/fldigi/distinfo6
-rw-r--r--comms/fldigi/files/patch-src_misc_newinstall.cxx4
-rw-r--r--comms/fldigi/files/patch-src_soundcard_sound.cxx44
-rw-r--r--comms/fldigi/files/patch-src_waterfall_raster.cxx4
5 files changed, 62 insertions, 11 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 4e19500cb9f8..bdd59da3e9f0 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fldigi
-PORTVERSION= 4.0.18
-PORTREVISION= 2
+PORTVERSION= 4.1.00
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -23,26 +22,34 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs\
libsamplerate.so:audio/libsamplerate
USES= autoreconf compiler:c++11-lib jpeg gmake perl5 pkgconfig shebangfix
+
USE_CXXSTD= gnu++0x
GNU_CONFIGURE= yes
USE_XORG= x11 xft xext xfixes xcursor xinerama
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
-OPTIONS_DEFINE= NATIVE_OPT FLARQ PULSEAUDIO HAMLIB NLS DOCS
+OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS SNDFILE PORTAUDIO PULSEAUDIO HAMLIB NLS DOCS
NATIVE_OPT_DESC= Enable Native Optimizations
FLARQ_DESC= Compile flarq
+OSS_DESC= Support OSS
+SNDFILE_DESC= Support for libsndfile
+PORTAUDIO_DESC= PortAudio support
PULSEAUDIO_DESC= PulseAudio support
HAMLIB_DESC= Support rig control via hamlib
-OPTIONS_DEFAULT= FLARQ HAMLIB
+OPTIONS_DEFAULT= FLARQ OSS HAMLIB
OPTIONS_SUB= yes
NATIVE_OPT_CONFIGURE_ON= --enable-optimizations=native
NATIVE_OPT_CONFIGURE_OFF= --enable-optimizations=none
FLARQ_CONFIGURE_ENABLE= flarq
OSS_CONFIGURE_ENABLE= oss
+SNDFILE_CONFIGURE_WITH= sndfile
+SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
+PORTAUDIO_CONFIGURE_WITH= portaudio
+PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PULSEAUDIO_CONFIGURE_WITH= pulseaudio
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
HAMLIB_CONFIGURE_WITH= hamlib
diff --git a/comms/fldigi/distinfo b/comms/fldigi/distinfo
index b2de80585026..0374bf0a5fc6 100644
--- a/comms/fldigi/distinfo
+++ b/comms/fldigi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534289571
-SHA256 (fldigi-4.0.18.tar.gz) = e71e317f6b1ed63094193e953a4d096639cc2708244515a77646e997644f7f28
-SIZE (fldigi-4.0.18.tar.gz) = 3757912
+TIMESTAMP = 1548774122
+SHA256 (fldigi-4.1.00.tar.gz) = 1ab857ee163843e9a7c8f9fc81bea9c1ebf7ff70fcbf1f6712a0b53b2eb1a2c2
+SIZE (fldigi-4.1.00.tar.gz) = 3916169
diff --git a/comms/fldigi/files/patch-src_misc_newinstall.cxx b/comms/fldigi/files/patch-src_misc_newinstall.cxx
index 36df2b464f0a..3eafa07bedbd 100644
--- a/comms/fldigi/files/patch-src_misc_newinstall.cxx
+++ b/comms/fldigi/files/patch-src_misc_newinstall.cxx
@@ -1,6 +1,6 @@
---- src/misc/newinstall.cxx.orig 2017-10-28 00:24:34 UTC
+--- src/misc/newinstall.cxx.orig 2018-02-24 13:42:49 UTC
+++ src/misc/newinstall.cxx
-@@ -67,7 +67,7 @@ text[3] = " btu <NAME> <CALL> de <MYCALL
+@@ -67,7 +67,7 @@ text[3] = " btu <NAME> <CALL> de <MYCALL> k\n\
label[4] = "SK @||";
text[4] = "\n\
diff --git a/comms/fldigi/files/patch-src_soundcard_sound.cxx b/comms/fldigi/files/patch-src_soundcard_sound.cxx
new file mode 100644
index 000000000000..3ad51c5922ed
--- /dev/null
+++ b/comms/fldigi/files/patch-src_soundcard_sound.cxx
@@ -0,0 +1,44 @@
+--- src/soundcard/sound.cxx.orig 2018-12-06 14:41:46 UTC
++++ src/soundcard/sound.cxx
+@@ -651,7 +651,27 @@ int SoundOSS::Open(int md, int freq)
+ oflags = oflags | O_CLOEXEC;
+ # endif
+
++#ifdef __FreeBSD__
++/*
++ * In FreeBSD sound devices e.g. /dev/dsp0.0 can only be open once
++ * whereas /dev/dsp0 can be open multiple times. fldigi tries
++ * to open /dev/dsp0.0 multiple times which fails. Also see man 4 sound.
++ * "For specific sound card access, please instead use /dev/dsp or /dev/dsp%d"
++ * This is a hack. XXX - db VA3DB
++ */
++ char *fixed_name;
++ char *p;
++ /* Look for a '.' if found, blow it away */
++ fixed_name = strdup(device.c_str());
++ p = fixed_name;
++ while (*p++)
++ if(*p == '.')
++ *p = '\0';
++ device_fd = fl_open(fixed_name, oflags, 0);
++ free(fixed_name);
++#else
+ device_fd = fl_open(device.c_str(), oflags, 0);
++#endif
+ if (device_fd == -1)
+ throw SndException(errno);
+
+@@ -677,12 +697,11 @@ void SoundOSS::Close(unsigned dir)
+ void SoundOSS::getVersion()
+ {
+ version = 0;
+-#ifndef __FreeBSD__
++
+ if (ioctl(device_fd, OSS_GETVERSION, &version) == -1) {
+ version = -1;
+ throw SndException("OSS Version");
+ }
+-#endif
+ }
+
+ void SoundOSS::getCapabilities()
diff --git a/comms/fldigi/files/patch-src_waterfall_raster.cxx b/comms/fldigi/files/patch-src_waterfall_raster.cxx
index 339188e80e39..b8f4ab15006d 100644
--- a/comms/fldigi/files/patch-src_waterfall_raster.cxx
+++ b/comms/fldigi/files/patch-src_waterfall_raster.cxx
@@ -1,6 +1,6 @@
---- src/waterfall/raster.cxx.orig 2018-08-11 23:26:43 UTC
+--- src/waterfall/raster.cxx.orig 2018-02-24 13:42:49 UTC
+++ src/waterfall/raster.cxx
-@@ -169,6 +169,10 @@ void Raster::resize(int x, int y, int w,
+@@ -169,6 +169,10 @@ void Raster::resize(int x, int y, int w, int h)
while ((Ndest * rhs) < Hdest) Ndest++;
Ndest--;