aboutsummaryrefslogtreecommitdiff
path: root/comms/flrig
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-04-11 23:57:16 +0000
committerDiane Bruce <db@FreeBSD.org>2014-04-11 23:57:16 +0000
commit7c9ae3285c57dae3822b682ae0d784e1cb39b294 (patch)
tree4ad54446f2b7e20bee0b2375b5d47da31c1f7df9 /comms/flrig
parentdc81ed497074d84c1ebeb8d57fb46511a7f5544a (diff)
downloadports-7c9ae3285c57dae3822b682ae0d784e1cb39b294.tar.gz
ports-7c9ae3285c57dae3822b682ae0d784e1cb39b294.zip
Notes
Diffstat (limited to 'comms/flrig')
-rw-r--r--comms/flrig/Makefile35
-rw-r--r--comms/flrig/distinfo2
-rw-r--r--comms/flrig/files/patch-configure11
-rw-r--r--comms/flrig/files/patch-src_debug.cxx30
-rw-r--r--comms/flrig/files/patch-src_xmlrpcpp_base64.h10
-rw-r--r--comms/flrig/pkg-descr6
6 files changed, 94 insertions, 0 deletions
diff --git a/comms/flrig/Makefile b/comms/flrig/Makefile
new file mode 100644
index 000000000000..fc48d83987ed
--- /dev/null
+++ b/comms/flrig/Makefile
@@ -0,0 +1,35 @@
+# Created by: Stephen Hurd <shurd@sasktel.net>
+# $FreeBSD$
+
+PORTNAME= flrig
+PORTVERSION= 1.3.13
+CATEGORIES= comms hamradio
+MASTER_SITES= http://www.w1hkj.com/downloads/flrig/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Ham Radio rig control program, cooperates with fldigi
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
+PLIST_FILES= bin/flrig share/applications/flrig.desktop \
+ share/pixmaps/flrig.xpm
+OPTIONS_DEFINE= NATIVE_OPT
+
+NATIVE_OPT_DESC= Enable Native Optimizations
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MNATIVE_OPT}
+CONFIGURE_ARGS+=--enable-optimizations=native
+.else
+CONFIGURE_ARGS+=--enable-optimizations=none
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/flrig/distinfo b/comms/flrig/distinfo
new file mode 100644
index 000000000000..f800572cedeb
--- /dev/null
+++ b/comms/flrig/distinfo
@@ -0,0 +1,2 @@
+SHA256 (flrig-1.3.13.tar.gz) = c5238bc72dc04a2b2ba741e093672990ec9ceecc7bfc4137b76d9e01a89dfdbb
+SIZE (flrig-1.3.13.tar.gz) = 578415
diff --git a/comms/flrig/files/patch-configure b/comms/flrig/files/patch-configure
new file mode 100644
index 000000000000..9a36431e674d
--- /dev/null
+++ b/comms/flrig/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2014-04-08 22:42:56.000000000 -0700
++++ configure 2014-04-08 22:43:21.000000000 -0700
+@@ -7205,7 +7205,7 @@
+ FLTK_LIBS=`$FLTK_CONFIG --ldflags --use-images`
+ if test "x$target_mingw32" != "xyes"; then
+ if test "x$target_darwin" != "xyes"; then
+- if grep -q "lX11" <<< "$FLTK_LIBS"; then
++ if echo "$FLTK_LIBS" | grep -q "lX11"; then
+ FLTK_LIBS="$FLTK_LIBS";
+ else
+ FLTK_LIBS="$FLTK_LIBS -lm -lX11";
diff --git a/comms/flrig/files/patch-src_debug.cxx b/comms/flrig/files/patch-src_debug.cxx
new file mode 100644
index 000000000000..054659fcd5e4
--- /dev/null
+++ b/comms/flrig/files/patch-src_debug.cxx
@@ -0,0 +1,30 @@
+--- src/debug.cxx.orig 2013-08-29 02:59:21.000000000 -0700
++++ src/debug.cxx 2014-04-11 03:02:01.000000000 -0700
+@@ -126,7 +126,7 @@
+
+ vsnprintf(sztemp, sizeof(sztemp), fmt, args);
+ estr.append(sztemp);
+- vfprintf(wfile, fmt, args);
++ fputs(sztemp, wfile);
+
+ va_end(args);
+
+@@ -149,16 +149,14 @@
+
+ vsnprintf(sztemp, sizeof(sztemp), fmt, args);
+ estr.append(sztemp);
+- vfprintf(wfile, fmt, args);
++ fputs(sztemp, wfile);
+ va_end(args);
+
+ fflush(wfile);
+
+ if (tty) {
+ if (level <= DEBUG_LEVEL && level >= QUIET_LEVEL) {
+- va_start(args, format);
+- vfprintf(stderr, fmt, args);
+- va_end(args);
++ fputs(sztemp, stderr);
+ }
+ }
+
diff --git a/comms/flrig/files/patch-src_xmlrpcpp_base64.h b/comms/flrig/files/patch-src_xmlrpcpp_base64.h
new file mode 100644
index 000000000000..923e15d9ca6a
--- /dev/null
+++ b/comms/flrig/files/patch-src_xmlrpcpp_base64.h
@@ -0,0 +1,10 @@
+--- src/xmlrpcpp/base64.h.orig 2014-04-08 23:01:00.000000000 -0700
++++ src/xmlrpcpp/base64.h 2014-04-08 23:01:12.000000000 -0700
+@@ -10,6 +10,7 @@
+ #define __BASE64_H_INCLUDED__ 1
+
+ #include <iterator>
++#include <ios>
+
+ static
+ int _base64Chars[]= {'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z',
diff --git a/comms/flrig/pkg-descr b/comms/flrig/pkg-descr
new file mode 100644
index 000000000000..1c662d905394
--- /dev/null
+++ b/comms/flrig/pkg-descr
@@ -0,0 +1,6 @@
+Flrig is a transceiver control program designed to be used either stand alone
+or as an adjunct to fldigi. The supported transceivers all have some degree
+of CAT. The flrig user interface changes to accommodate the degree of CAT
+support available for the transceiver in use.
+
+WWW: http://www.w1hkj.com/flrig-help/index.html