aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu-devel
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-08 11:19:54 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-08 11:19:54 +0000
commite6f69f893bd0df4428099fa274d4c129296e0352 (patch)
treefc30e6eec2bf8eeda314aa6d898eeee272f8687a /comms/gammu-devel
parent129f54943ebae582b41066ce0d4a4a2ac86262a3 (diff)
downloadports-e6f69f893bd0df4428099fa274d4c129296e0352.tar.gz
ports-e6f69f893bd0df4428099fa274d4c129296e0352.zip
Notes
Diffstat (limited to 'comms/gammu-devel')
-rw-r--r--comms/gammu-devel/Makefile3
-rw-r--r--comms/gammu-devel/distinfo5
-rw-r--r--comms/gammu-devel/files/patch-bluetooth12
-rw-r--r--comms/gammu-devel/files/patch-cfg-Makefile.glo9
4 files changed, 10 insertions, 19 deletions
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 9cf99e43157a..6acbd7f1798b 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gammu
-PORTVERSION= 1.02.0
-PORTREVISION= 1
+PORTVERSION= 1.03.0
CATEGORIES= comms
MASTER_SITES= http://www.mwiacek.com/zips/gsm/gammu/stable/1_0x/
diff --git a/comms/gammu-devel/distinfo b/comms/gammu-devel/distinfo
index 725701220f18..6420b891eb39 100644
--- a/comms/gammu-devel/distinfo
+++ b/comms/gammu-devel/distinfo
@@ -1,2 +1,3 @@
-MD5 (gammu-1.02.0.tar.gz) = f8d0b2c6cc045891b6d8f0021246a464
-SIZE (gammu-1.02.0.tar.gz) = 906417
+MD5 (gammu-1.03.0.tar.gz) = 1e9175547c27bf883f899ef8f4db1651
+SHA256 (gammu-1.03.0.tar.gz) = 524eba093fef653043081558b94c7ec38b26b9231e37178ca76b55d3bff6754c
+SIZE (gammu-1.03.0.tar.gz) = 915678
diff --git a/comms/gammu-devel/files/patch-bluetooth b/comms/gammu-devel/files/patch-bluetooth
index 1e698a060071..c841c156b5de 100644
--- a/comms/gammu-devel/files/patch-bluetooth
+++ b/comms/gammu-devel/files/patch-bluetooth
@@ -1,6 +1,5 @@
-diff -ru ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c common/device/bluetoth/bluez.c
---- ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c Thu Mar 10 10:35:58 2005
-+++ common/device/bluetoth/bluez.c Sat Jul 9 12:46:07 2005
+--- common/device/bluetoth/bluez.c.orig Wed Sep 14 21:47:08 2005
++++ common/device/bluetoth/bluez.c Wed Nov 23 22:11:16 2005
@@ -23,6 +23,8 @@
#ifdef GSM_ENABLE_BLUETOOTHDEVICE
#ifdef GSM_ENABLE_BLUEZ
@@ -10,7 +9,7 @@ diff -ru ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c common/device/bluet
#include <stdlib.h>
#include <stdio.h>
#include <fcntl.h>
-@@ -31,10 +33,7 @@
+@@ -31,11 +33,7 @@
#include <sys/socket.h>
#include <sys/time.h>
#include <unistd.h>
@@ -18,11 +17,12 @@ diff -ru ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c common/device/bluet
-#include <bluetooth/rfcomm.h>
-#include <bluetooth/sdp.h>
-#include <bluetooth/sdp_lib.h>
+-#include <bluetooth/hci_lib.h>
+#include <bluetooth.h>
#include "../../gsmcomon.h"
#include "../devfunc.h"
-@@ -43,21 +42,21 @@
+@@ -44,21 +42,21 @@
GSM_Error bluetooth_connect(GSM_StateMachine *s, int port, char *device)
{
GSM_Device_BlueToothData *d = &s->Device.Data.BlueTooth;
@@ -49,7 +49,7 @@ diff -ru ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c common/device/bluet
if (bind(fd, (struct sockaddr *)&laddr, sizeof(laddr)) < 0) {
dbgprintf("Can't bind socket\n");
-@@ -66,9 +65,9 @@
+@@ -67,9 +65,9 @@
}
str2ba(device, &bdaddr);
diff --git a/comms/gammu-devel/files/patch-cfg-Makefile.glo b/comms/gammu-devel/files/patch-cfg-Makefile.glo
index 16ef31ad91d2..c2a88cd1ae03 100644
--- a/comms/gammu-devel/files/patch-cfg-Makefile.glo
+++ b/comms/gammu-devel/files/patch-cfg-Makefile.glo
@@ -9,15 +9,6 @@
$(TOPDIR)/gammu/gammu: $(COMMON) $(GAMMU)
@echo Linking gammu
-@@ -136,7 +136,7 @@
-
- $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR): $(COMMON)
- @echo Linking libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR)
-- @$(CC) $(LDLIBS) -shared -Wl,-soname -Wl,libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) -o $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(COMMON)
-+ @$(CC) $(LDLIBS) -shared -Wl,-soname -Wl,libGammu.so.$(SONAME_MAJOR) -o $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(COMMON)
- @$(LN) -s libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR)
- @$(LN) -s libGammu.so.$(SONAME_MAJOR) $(TOPDIR)/common/libGammu.so
-
@@ -225,12 +225,14 @@
@$(INSTALL) -m 0644 $(TOPDIR)/changelog $(DESTDIR)$(INSTALL_DOC_DIR)
@$(INSTALL) -m 0644 $(TOPDIR)/readme.txt $(DESTDIR)$(INSTALL_DOC_DIR)