aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu-devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-20 17:03:59 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-20 17:03:59 +0000
commit7cfd54f2208ed40e0fadf0189a0491e56ec4f13e (patch)
tree747a8b9637eb7e5c6250bbf07d02f3c194031cf8 /comms/gammu-devel
parent45e60cbc9b7134c86958e4861f07b3982467e739 (diff)
downloadports-7cfd54f2208ed40e0fadf0189a0491e56ec4f13e.tar.gz
ports-7cfd54f2208ed40e0fadf0189a0491e56ec4f13e.zip
Notes
Diffstat (limited to 'comms/gammu-devel')
-rw-r--r--comms/gammu-devel/Makefile11
-rw-r--r--comms/gammu-devel/distinfo4
-rw-r--r--comms/gammu-devel/files/patch-cfg-Makefile.glo28
-rw-r--r--comms/gammu-devel/pkg-plist42
4 files changed, 42 insertions, 43 deletions
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 29d000387979..302b405c668d 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gammu
-PORTVERSION= 1.01.0
+PORTVERSION= 1.02.0
CATEGORIES= comms
MASTER_SITES= http://www.mwiacek.com/zips/gsm/gammu/stable/1_0x/
@@ -16,11 +16,20 @@ COMMENT= GNU All Mobile Management Utilities
MAN1= gammu.1
USE_GMAKE= yes
USE_GNOME= pkgconfig
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
WANT_AUTOCONF_VER=259
INSTALLS_SHLIB= yes
+PORTDOCS= *
+
CONFIGURE_ARGS= --disable-bluerfsearch
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fPIC"
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's@ installdocs@@g' \
+ ${WRKSRC}/cfg/Makefile.glo
+.endif
+
.include <bsd.port.mk>
diff --git a/comms/gammu-devel/distinfo b/comms/gammu-devel/distinfo
index 51c6f4098330..725701220f18 100644
--- a/comms/gammu-devel/distinfo
+++ b/comms/gammu-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (gammu-1.01.0.tar.gz) = 1ae9d7d51158c9f0cb5d3b25e7e7e1e1
-SIZE (gammu-1.01.0.tar.gz) = 860546
+MD5 (gammu-1.02.0.tar.gz) = f8d0b2c6cc045891b6d8f0021246a464
+SIZE (gammu-1.02.0.tar.gz) = 906417
diff --git a/comms/gammu-devel/files/patch-cfg-Makefile.glo b/comms/gammu-devel/files/patch-cfg-Makefile.glo
index 80567a309457..16ef31ad91d2 100644
--- a/comms/gammu-devel/files/patch-cfg-Makefile.glo
+++ b/comms/gammu-devel/files/patch-cfg-Makefile.glo
@@ -1,5 +1,5 @@
---- ../gammu-1.01.0.orig/cfg/Makefile.glo Tue Apr 12 15:26:08 2005
-+++ cfg/Makefile.glo Sat Jul 9 22:24:39 2005
+--- cfg/Makefile.glo.orig Tue Apr 12 10:26:08 2005
++++ cfg/Makefile.glo Tue Sep 6 08:38:21 2005
@@ -122,7 +122,7 @@
@echo Making $<
@$(CC) -c $(CFLAGS) -I$(TOPDIR)/common/ $(CPPFLAGS) $*.c -o $*.o
@@ -18,16 +18,32 @@
@$(LN) -s libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR)
@$(LN) -s libGammu.so.$(SONAME_MAJOR) $(TOPDIR)/common/libGammu.so
-@@ -230,7 +230,7 @@
+@@ -225,12 +225,14 @@
+ @$(INSTALL) -m 0644 $(TOPDIR)/changelog $(DESTDIR)$(INSTALL_DOC_DIR)
+ @$(INSTALL) -m 0644 $(TOPDIR)/readme.txt $(DESTDIR)$(INSTALL_DOC_DIR)
+ @$(INSTALL) -m 0644 $(TOPDIR)/copying $(DESTDIR)$(INSTALL_DOC_DIR)
++
++installman:
+ @echo Installing man to $(DESTDIR)$(INSTALL_MAN_DIR)
+ @$(INSTALL) -m 0755 -d $(DESTDIR)$(INSTALL_MAN_DIR)
@$(INSTALL) -m 0644 $(TOPDIR)/docs/docs/english/gammu.1 $(DESTDIR)$(INSTALL_MAN_DIR)
@$(RM) $(DESTDIR)$(INSTALL_DOC_DIR)/docs/english/gammu.1
-install: uninstall all installdocs installlocales installonly
-+install: uninstall all installdocs installlocales installlibonly
++install: uninstall all installdocs installman installlocales installlibonly
installonly: all
@echo Installing binaries to $(DESTDIR)$(INSTALL_BIN_DIR)
-@@ -247,8 +247,7 @@
+@@ -238,7 +240,7 @@
+ @$(INSTALL) -m 0755 $(TOPDIR)/gammu/gammu $(DESTDIR)$(INSTALL_BIN_DIR)
+
+ installshared: installlib
+-installlib: uninstall makelib installdocs installlocales installlibonly
++installlib: uninstall makelib installman installdocs installlocales installlibonly
+
+ installlibonly: shared
+ @echo Installing binaries to $(DESTDIR)$(INSTALL_BIN_DIR)
+@@ -247,8 +249,7 @@
@echo Installing shared library to $(DESTDIR)$(INSTALL_LIB_DIR)
@$(INSTALL) -m 0755 -d $(DESTDIR)$(INSTALL_LIB_DIR)
@@ -37,7 +53,7 @@
@$(LN) -s libGammu.so.$(SONAME_MAJOR) $(DESTDIR)$(INSTALL_LIB_DIR)/libGammu.so
@echo Installing static library to $(DESTDIR)$(INSTALL_LIB_DIR)
-@@ -267,8 +266,8 @@
+@@ -267,8 +268,8 @@
@$(INSTALL) -m 0644 cfg/config.h $(DESTDIR)$(INSTALL_H_DIR)/config.h
@echo Installing pkgconfig file
diff --git a/comms/gammu-devel/pkg-plist b/comms/gammu-devel/pkg-plist
index 7a1c85bffd02..6aada7c58164 100644
--- a/comms/gammu-devel/pkg-plist
+++ b/comms/gammu-devel/pkg-plist
@@ -1,28 +1,11 @@
bin/gammu
-%%DOCSDIR%%/changelog
-%%DOCSDIR%%/copying
-%%DOCSDIR%%/readme.txt
-%%DOCSDIR%%/docs/english/gammu.txt
-%%DOCSDIR%%/docs/english/replace.txt
-%%DOCSDIR%%/docs/italian/gammu.txt
-%%DOCSDIR%%/docs/italian/readme.txt
-%%DOCSDIR%%/docs/gammu.png
-%%DOCSDIR%%/examples/config/gammurc
-%%DOCSDIR%%/examples/config/smsdrc
-%%DOCSDIR%%/examples/config/mysql.sql
-%%DOCSDIR%%/examples/fax/faxreceive
-%%DOCSDIR%%/examples/fax/faxsend
-%%DOCSDIR%%/examples/ppp/data
-%%DOCSDIR%%/examples/ppp/gprs
-%%DOCSDIR%%/examples/ppp/startppp
-%%DOCSDIR%%/examples/ppp/statsppp
-%%DOCSDIR%%/examples/media/aliens.nlm
-%%DOCSDIR%%/examples/media/axelf.txt
-share/gammu/gammu_cs.txt
-share/gammu/gammu_de.txt
-share/gammu/gammu_it.txt
-share/gammu/gammu_pl.txt
-share/gammu/gammu_us.txt
+%%DATADIR%%/gammu_cs.txt
+%%DATADIR%%/gammu_de.txt
+%%DATADIR%%/gammu_es.txt
+%%DATADIR%%/gammu_it.txt
+%%DATADIR%%/gammu_pl.txt
+%%DATADIR%%/gammu_ru.txt
+%%DATADIR%%/gammu_us.txt
libdata/pkgconfig/gammu.pc
lib/libGammu.a
lib/libGammu.so
@@ -122,13 +105,4 @@ include/gammu/service/sms/gsmsms.h
@dirrm include/gammu/device/bluetoth
@dirrm include/gammu/device
@dirrm include/gammu
-@dirrm share/gammu
-@dirrm %%DOCSDIR%%/docs/english
-@dirrm %%DOCSDIR%%/docs/italian
-@dirrm %%DOCSDIR%%/docs
-@dirrm %%DOCSDIR%%/examples/config
-@dirrm %%DOCSDIR%%/examples/media
-@dirrm %%DOCSDIR%%/examples/ppp
-@dirrm %%DOCSDIR%%/examples/fax
-@dirrm %%DOCSDIR%%/examples
-@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%