aboutsummaryrefslogtreecommitdiff
path: root/comms/geoid
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-04 21:26:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-04 21:26:14 +0000
commit2c6b7d562610b15c275fd09eceb45bcd35b96ecd (patch)
treee1d3d261baa654e8bfc48a88515b546abd86d482 /comms/geoid
parenteb96867973c861c811337831fc29c50187562ec1 (diff)
downloadports-2c6b7d562610b15c275fd09eceb45bcd35b96ecd.tar.gz
ports-2c6b7d562610b15c275fd09eceb45bcd35b96ecd.zip
Notes
Diffstat (limited to 'comms/geoid')
-rw-r--r--comms/geoid/Makefile11
-rw-r--r--comms/geoid/files/patch-geoid.cxx9
2 files changed, 16 insertions, 4 deletions
diff --git a/comms/geoid/Makefile b/comms/geoid/Makefile
index 455819affab9..a05eeb3b12d3 100644
--- a/comms/geoid/Makefile
+++ b/comms/geoid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geoid
PORTVERSION= 1.0
DISTVERSIONSUFFIX= .src
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/LinuxApps/
DISTNAME= fl_geoid
@@ -15,14 +15,17 @@ COMMENT= Geodetic computer for amateur radio use
LICENSE= GPLv2+ NONE # only one src file contains license
LICENSE_COMB= multi
-LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libpng16.so:graphics/png
-USES= gmake
+USES= gmake jpeg
+USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
MAKEFILE= makefile
post-patch:
@${REINPLACE_CMD} -e \
- 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/geoid.cxx
+ 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/geoid.cxx
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/geoid ${STAGEDIR}${PREFIX}/bin
diff --git a/comms/geoid/files/patch-geoid.cxx b/comms/geoid/files/patch-geoid.cxx
index 9df3ddece0b7..354221df959b 100644
--- a/comms/geoid/files/patch-geoid.cxx
+++ b/comms/geoid/files/patch-geoid.cxx
@@ -13,3 +13,12 @@
exit(0);
}
}
+@@ -46,7 +44,7 @@ int main(int argc, char **argv) {
+
+ void About()
+ {
+- fl_message("Geodetic computer\nVersion: "VERSION"\nDave Freese\nw1hkj@@w1hkj.com");
++ fl_message("Geodetic computer\nVersion: " VERSION "\nDave Freese\nw1hkj@@w1hkj.com");
+ }
+
+ void cbSaveQTH()