aboutsummaryrefslogtreecommitdiff
path: root/comms/gmfsk/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:18:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:18:48 +0000
commit891114eb1eb2173f6307f466cb9b7e5a3dbb7e5b (patch)
treefab391f8874a974ad6d9498e650056117aeb5b4b /comms/gmfsk/Makefile
parent1f8cd43b7357f32439b1fd1a826951ba69d51798 (diff)
downloadports-891114eb1eb2173f6307f466cb9b7e5a3dbb7e5b.tar.gz
ports-891114eb1eb2173f6307f466cb9b7e5a3dbb7e5b.zip
Notes
Diffstat (limited to 'comms/gmfsk/Makefile')
-rw-r--r--comms/gmfsk/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/comms/gmfsk/Makefile b/comms/gmfsk/Makefile
new file mode 100644
index 000000000000..e0b436e846af
--- /dev/null
+++ b/comms/gmfsk/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gmfsk
+# Date created: 29th May 2003
+# Whom: Carl Makin <carl@stagecraft.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmfsk
+PORTVERSION= 0.5
+CATEGORIES= comms audio
+MASTER_SITES= http://hes.iki.fi/pub/ham/unix/linux/hfmodems/
+
+MAINTAINER= carl@stagecraft.cx
+COMMENT= The Gnome MFSK terminal program
+
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
+
+GNU_CONFIGURE= yes
+# This is pure evil but it looks like autoconf 2.53 has a bug in linking the
+# preprocessor include tests. This is a work around.
+CONFIGURE_ARGS= LDFLAGS="-L${LOCALBASE}/lib"
+# There is a bug in the code that causes the compile to fail if -O is not set.
+CFLAGS+= -O -I${LOCALBASE}/include
+USE_GMAKE= yes
+USE_AUTOCONF_VER= 253
+USE_GNOME= libgnomeui
+
+post-install:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>