aboutsummaryrefslogtreecommitdiff
path: root/comms/gmfsk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:18:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:18:48 +0000
commit891114eb1eb2173f6307f466cb9b7e5a3dbb7e5b (patch)
treefab391f8874a974ad6d9498e650056117aeb5b4b /comms/gmfsk
parent1f8cd43b7357f32439b1fd1a826951ba69d51798 (diff)
downloadports-891114eb1eb2173f6307f466cb9b7e5a3dbb7e5b.tar.gz
ports-891114eb1eb2173f6307f466cb9b7e5a3dbb7e5b.zip
Notes
Diffstat (limited to 'comms/gmfsk')
-rw-r--r--comms/gmfsk/Makefile31
-rw-r--r--comms/gmfsk/distinfo1
-rw-r--r--comms/gmfsk/files/patch-config.h.in11
-rw-r--r--comms/gmfsk/files/patch-snd.c27
-rw-r--r--comms/gmfsk/pkg-descr13
-rw-r--r--comms/gmfsk/pkg-message29
-rw-r--r--comms/gmfsk/pkg-plist8
7 files changed, 120 insertions, 0 deletions
diff --git a/comms/gmfsk/Makefile b/comms/gmfsk/Makefile
new file mode 100644
index 000000000000..e0b436e846af
--- /dev/null
+++ b/comms/gmfsk/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gmfsk
+# Date created: 29th May 2003
+# Whom: Carl Makin <carl@stagecraft.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmfsk
+PORTVERSION= 0.5
+CATEGORIES= comms audio
+MASTER_SITES= http://hes.iki.fi/pub/ham/unix/linux/hfmodems/
+
+MAINTAINER= carl@stagecraft.cx
+COMMENT= The Gnome MFSK terminal program
+
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
+
+GNU_CONFIGURE= yes
+# This is pure evil but it looks like autoconf 2.53 has a bug in linking the
+# preprocessor include tests. This is a work around.
+CONFIGURE_ARGS= LDFLAGS="-L${LOCALBASE}/lib"
+# There is a bug in the code that causes the compile to fail if -O is not set.
+CFLAGS+= -O -I${LOCALBASE}/include
+USE_GMAKE= yes
+USE_AUTOCONF_VER= 253
+USE_GNOME= libgnomeui
+
+post-install:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/comms/gmfsk/distinfo b/comms/gmfsk/distinfo
new file mode 100644
index 000000000000..0cc1be0da9f8
--- /dev/null
+++ b/comms/gmfsk/distinfo
@@ -0,0 +1 @@
+MD5 (gmfsk-0.5.tar.gz) = b27d4debb69b97a6c290b7811bb402f6
diff --git a/comms/gmfsk/files/patch-config.h.in b/comms/gmfsk/files/patch-config.h.in
new file mode 100644
index 000000000000..12ce1651a549
--- /dev/null
+++ b/comms/gmfsk/files/patch-config.h.in
@@ -0,0 +1,11 @@
+--- ./config.h.in.orig Thu May 29 21:48:43 2003
++++ ./config.h.in Thu May 29 21:48:51 2003
+@@ -20,7 +20,7 @@
+ #undef HAVE_DFFTW_H
+
+ /* Define to 1 if you have the <fftw.h> header file. */
+-#undef HAVE_FFTW_H
++#define HAVE_FFTW_H
+
+ /* Define if the GNU gettext() function is already present or preinstalled. */
+ #undef HAVE_GETTEXT
diff --git a/comms/gmfsk/files/patch-snd.c b/comms/gmfsk/files/patch-snd.c
new file mode 100644
index 000000000000..82a04f4fc82c
--- /dev/null
+++ b/comms/gmfsk/files/patch-snd.c
@@ -0,0 +1,27 @@
+--- ./src/snd.c.orig Thu May 29 22:03:20 2003
++++ ./src/snd.c Thu May 29 22:17:00 2003
+@@ -9,7 +9,14 @@
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <endian.h>
++#if HAVE_SYS_BYTEORDER_H
++# include <sys/byteorder.h>
++#elif HAVE_MACHINE_ENDIAN_H
++# include <machine/endian.h>
++#elif HAVE_ENDIAN_H
++# include <endian.h>
++#endif
++
+ #include <sys/soundcard.h>
+ #include <sys/ioctl.h>
+
+@@ -18,6 +25,8 @@
+ #include "misc.h"
+
+ #undef SND_DEBUG
++
++#define AFMT_S16_NE AFMT_S16_LE
+
+ /* ---------------------------------------------------------------------- */
+
diff --git a/comms/gmfsk/pkg-descr b/comms/gmfsk/pkg-descr
new file mode 100644
index 000000000000..be532b0adfe0
--- /dev/null
+++ b/comms/gmfsk/pkg-descr
@@ -0,0 +1,13 @@
+gMFSK v0.5 - The Gnome MFSK terminal program
+============================================
+
+gMFSK is a multi-mode soundcard terminal program for HF amateur
+communications. Originally the program was written for compatibility
+with the IZ8BLY Stream program in MFSK16 mode. Currently the program
+supports the following amateur digital communications modes: MFSK16,
+MFSK8, RTTY, THROB, PSK31, MT63 and FELDHELL.
+
+WWW: http://hes.iki.fi/
+
+- Carl
+carl@stagecraft.cx
diff --git a/comms/gmfsk/pkg-message b/comms/gmfsk/pkg-message
new file mode 100644
index 000000000000..1459e1c9c302
--- /dev/null
+++ b/comms/gmfsk/pkg-message
@@ -0,0 +1,29 @@
+
+********************************************************************
+gMFSK by Tomi Manninen, OH2BNS, is now installed!
+
+Start it using the command "gmfsk". You may need to type "rehash"
+first.
+
+Upon first starting it, go to Settings->Preferences and fill out
+all your details.
+
+Under Settings->Preferences->Devices->Sound set your sound device to
+/dev/dspW0
+This will use the 16bit sound device rather than /dev/dsp0 which is
+the 8bit sound device.
+
+Then use the Gnome-volume-control to set your receive and transmit
+levels. DO NOT OVERDRIVE YOUR RIG. I recommend you head over to
+http://www.w5bbr.com/
+which has links to useful info.
+
+The port currently has a minor bug that means error messages will be
+printed if the LANG environment variable is not set to something in
+/usr/share/locale. You can either set the LANG environment variable
+or ignore the error.
+
+Enjoy!
+Carl, VK1KCM
+carl@stagecraft.cx
+********************************************************************
diff --git a/comms/gmfsk/pkg-plist b/comms/gmfsk/pkg-plist
new file mode 100644
index 000000000000..945c87e0cc69
--- /dev/null
+++ b/comms/gmfsk/pkg-plist
@@ -0,0 +1,8 @@
+bin/gmfsk
+share/pixmaps/gmfsk/mfsk.png
+share/pixmaps/gmfsk/pause.xpm
+share/pixmaps/gmfsk/rx.xpm
+share/pixmaps/gmfsk/tune.xpm
+share/pixmaps/gmfsk/tx.xpm
+@dirrm share/pixmaps/gmfsk
+@dirrm share/pixmaps