aboutsummaryrefslogtreecommitdiff
path: root/comms/gnocky/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-07-16 17:30:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-07-16 17:30:35 +0000
commitde7fe19b51af815a2276c870842d2ab1a675e0a8 (patch)
treec9cb823640f87e423390699ed3adc8e88b0023ef /comms/gnocky/Makefile
parent9833ffe87cd7c1378ace974f7c98a267d89c8b6d (diff)
downloadports-de7fe19b51af815a2276c870842d2ab1a675e0a8.tar.gz
ports-de7fe19b51af815a2276c870842d2ab1a675e0a8.zip
Notes
Diffstat (limited to 'comms/gnocky/Makefile')
-rw-r--r--comms/gnocky/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/comms/gnocky/Makefile b/comms/gnocky/Makefile
new file mode 100644
index 000000000000..d7b3ee22346a
--- /dev/null
+++ b/comms/gnocky/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Gnocky
+# Date created: 16 Jul 2008
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnocky
+PORTVERSION= 0.0.6
+CATEGORIES= comms
+MASTER_SITES= http://www.gnokii.org/download/gnocky/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A graphical (GTK+2) frontend for gnokii
+
+LIB_DEPENDS= gnokii.12:${PORTSDIR}/comms/gnokii \
+ usb-0.1.8:${PORTSDIR}/devel/libusb
+
+USE_GNOME= gtk20 libglade2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= NLS "Build with Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>