aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-05-20 23:52:47 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-05-20 23:52:47 +0000
commit0e3e65c6bcb8c6f2882d6db18526006e35a831f5 (patch)
treea3e5e9911d699de769d8b5fc88483eaa5b80fde7 /comms/gnokii/Makefile
parent182253b72e62410d743157bb138db5b058ec8d28 (diff)
Notes
Diffstat (limited to 'comms/gnokii/Makefile')
-rw-r--r--comms/gnokii/Makefile35
1 files changed, 19 insertions, 16 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index c6653cbd7aa9..b7943be3b205 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.4.3
+PORTVERSION= 0.5.0
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.nuug.no/pub/anders/distfiles/ \
- http://freesoftware.fsf.org/download/gnokii/
-# ftp://ftp.gnokii.org/pub/gnokii/
+ http://freesoftware.fsf.org/download/gnokii/ \
+ ftp://ftp.gnokii.org/pub/gnokii/
MAINTAINER= anders@FreeBSD.org
COMMENT= Tools to talk to Nokia cellular phones
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+USE_REINPLACE= yes
USE_GMAKE= yes
.if !defined(WITHOUT_X11)
USE_XPM= yes
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-libintl=${LOCALBASE} --enable-security \
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE} --enable-security \
--with-xgnokiidir=${PREFIX}/share
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x
@@ -36,9 +37,10 @@ PLIST_SUB+= X11='@comment '
PLIST_SUB+= X11=''
.endif
CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
- XGETTEXT="${LOCALBASE}/bin/xgettext"
+ XGETTEXT="${LOCALBASE}/bin/xgettext" \
+ CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
-NO_PACKAGE= "Group needs to be created"
MAN1= gnokii.1 todologo.1
.if !defined(WITHOUT_X11)
MAN1+= xgnokii.1
@@ -46,30 +48,31 @@ MAN1+= xgnokii.1
MAN8= gnokiid.8 mgnokiidev.8
INSTALL_TARGET= install-suid
+PKGDEINSTALL= ${PKGINSTALL}
FIXPREFIX= Docs/man/gnokiid.8 Docs/DataCalls-QuickStart Docs/README \
common/cfgreader.c po/et.po po/sl.po
post-patch:
.for f in ${FIXPREFIX}
- @${SED} -e "s:/etc/gnokiirc:${PREFIX}/etc/gnokiirc:g" \
- < ${WRKSRC}/${f} > ${WRKSRC}/${f}.post_sed
- @${CP} ${WRKSRC}/${f}.post_sed ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e "s:/etc/gnokiirc:${PREFIX}/etc/gnokiirc:g" \
+ ${WRKSRC}/${f}
+.endfor
+ @${REINPLACE_CMD} -e "s:%%PTHREAD_LIBS%%:${PTHREAD_LIBS}:; \
+ s:%%PTHREAD_CFLAGS%%:${PTHREAD_CFLAGS}:" ${WRKSRC}/configure
+.for f in common/data/virtmodem.c utils/mgnokiidev.c
+ @${REINPLACE_CMD} -E -e "s:^(#ifdef.*)__OpenBSD__:\1__FreeBSD__:" \
+ ${WRKSRC}/${f}
.endfor
- @${SED} -e "s:%%PTHREAD_LIBS%%:${PTHREAD_LIBS}:" \
- -e "s:%%PTHREAD_CFLAGS%%:${PTHREAD_CFLAGS}:" \
- < ${WRKSRC}/configure > ${WRKSRC}/configure.post_sed
- @${CP} ${WRKSRC}/configure.post_sed ${WRKSRC}/configure
pre-install:
- @${SH} ${SCRIPTDIR}/creategroup
+ @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
+ @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@(cd ${WRKSRC} && ${GMAKE} install-docs)
${INSTALL_DATA} ${WRKSRC}/Docs/sample/gnokiirc \
${PREFIX}/etc/gnokiirc.sample
- ${INSTALL_DATA} ${WRKSRC}/common/libgnokii.so ${PREFIX}/lib/
- @(cd ${PREFIX}/lib && ${LN} -s libgnokii.so libgnokii.so.0)
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>