aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii/files
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-05-23 01:02:28 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-05-23 01:02:28 +0000
commit20e5048262b903d5ae0313f7be754314c67f9d71 (patch)
tree6326fafd8cf043f02cd6f1674606ae8c516aa913 /comms/gnokii/files
parenteeede6ebed1eafbe631f7f137a0e8972db277c59 (diff)
Notes
Diffstat (limited to 'comms/gnokii/files')
-rw-r--r--comms/gnokii/files/patch-Docs-Makefile34
-rw-r--r--comms/gnokii/files/patch-Makefile13
-rw-r--r--comms/gnokii/files/patch-Makefile.global.in6
-rw-r--r--comms/gnokii/files/patch-configure21
-rw-r--r--comms/gnokii/files/patch-configure.in10
-rw-r--r--comms/gnokii/files/patch-gnokiid-Makefile15
-rw-r--r--comms/gnokii/files/patch-gnokiirc30
7 files changed, 68 insertions, 61 deletions
diff --git a/comms/gnokii/files/patch-Docs-Makefile b/comms/gnokii/files/patch-Docs-Makefile
index 16daa1b848a8..3f3fc47b8864 100644
--- a/comms/gnokii/files/patch-Docs-Makefile
+++ b/comms/gnokii/files/patch-Docs-Makefile
@@ -1,33 +1,25 @@
---- Docs/Makefile.orig Fri Sep 28 02:07:58 2001
-+++ Docs/Makefile Mon Oct 15 00:42:14 2001
-@@ -24,24 +24,26 @@
- packaging-howto \
- sample.gnokiirc
-
--GNOKII1_MAN = "man/gnokii.1 man/todologo.1"
--GNOKII8_MAN = "man/gnokiid.8 man/mgnokiidev.8"
-+GNOKII1_MAN = man/gnokii.1 man/todologo.1
-+GNOKII8_MAN = man/gnokiid.8 man/mgnokiidev.8
- XGNOKII_MAN = man/xgnokii.1x
-
- all:
+--- Docs/Makefile.orig Fri May 10 00:31:47 2002
++++ Docs/Makefile Wed May 22 03:09:44 2002
+@@ -32,19 +32,20 @@
@echo
install:
+ifndef NOPORTDOCS
- $(INSTALL) -d $(docdir)
+ $(INSTALL) -d $(DESTDIR)/$(docdir)
@for xxx in $(INSTALL_DOCS); do \
if [ -e $$xxx ]; then \
- $(INSTALL) -m 0444 $$xxx $(docdir)/$$xxx; \
+ $(INSTALL) -m 0444 $$xxx $(DESTDIR)/$(docdir)/$$xxx; \
fi; \
done
+endif
- $(INSTALL) $(GNOKII1_MAN) $(man1dir)
- $(INSTALL) $(GNOKII8_MAN) $(man8dir)
-- if [ "x$HAVE_XGNOKII" = xyes ]; then \
-- $(INSTALL) $(XGNOKII_MAN) $(xmandir) \
-+ if [ "x$(HAVE_XGNOKII)" = xyes ]; then \
-+ $(INSTALL) $(XGNOKII_MAN) $(xmandir)/xgnokii.1; \
+ $(INSTALL) -d $(DESTDIR)/$(man1dir)
+ $(INSTALL) -d $(DESTDIR)/$(man8dir)
+ $(INSTALL) $(GNOKII1_MAN) $(DESTDIR)/$(man1dir)
+ $(INSTALL) $(GNOKII8_MAN) $(DESTDIR)/$(man8dir)
+ if [ "x$(HAVE_XGNOKII)" = "xyes" ]; then \
+- $(INSTALL) -d $(DESTDIR)/$(xmandir); \
+- $(INSTALL) $(XGNOKII_MAN) $(DESTDIR)/$(xmandir); \
++ $(INSTALL) $(XGNOKII_MAN) $(DESTDIR)/$(xmandir)/xgnokii.1; \
fi
@echo "done"
diff --git a/comms/gnokii/files/patch-Makefile b/comms/gnokii/files/patch-Makefile
index d80074b3985a..b3dfa64bac67 100644
--- a/comms/gnokii/files/patch-Makefile
+++ b/comms/gnokii/files/patch-Makefile
@@ -1,15 +1,12 @@
---- Makefile.orig Fri Sep 28 02:07:58 2001
-+++ Makefile Mon Oct 15 02:07:01 2001
-@@ -153,8 +153,11 @@
- $(MAKE) -C $$dir install-suid; \
+--- Makefile.orig Wed May 22 02:17:56 2002
++++ Makefile Wed May 22 02:19:41 2002
+@@ -157,6 +157,9 @@
fi; \
done
+
+ @if [ "x$(USE_NLS)" = xyes ]; then \
+ $(MAKE) -C $(PO_DIR) install; \
+ fi
@if [ "$(GTK_LIBS)" ]; then \
-- @for dir in $(GTK_DIRS); do \
-+ for dir in $(GTK_DIRS); do \
+ for dir in $(GTK_DIRS); do \
if [ -e $$dir/Makefile ]; then \
- $(MAKE) -C $$dir install-suid; \
- fi; \
diff --git a/comms/gnokii/files/patch-Makefile.global.in b/comms/gnokii/files/patch-Makefile.global.in
index 7a095315b1bc..9b631e2de08c 100644
--- a/comms/gnokii/files/patch-Makefile.global.in
+++ b/comms/gnokii/files/patch-Makefile.global.in
@@ -1,12 +1,12 @@
---- Makefile.global.in.orig Fri Sep 28 02:07:58 2001
-+++ Makefile.global.in Sun Oct 14 23:57:52 2001
+--- Makefile.global.in.orig Fri May 10 00:31:47 2002
++++ Makefile.global.in Wed May 22 02:22:26 2002
@@ -22,13 +22,13 @@
bindir = @bindir@
sbindir = @sbindir@
-xbindir = ${prefix}/X11R6/bin/
+xbindir = ${prefix}/bin/
- libdir = @libdir@/${PACKAGE}
+ libdir = @libdir@
xgnokii_libdir = @XGNOKIIDIR@/@XPACKAGE@
man1dir = @mandir@/man1/
man8dir = @mandir@/man8/
diff --git a/comms/gnokii/files/patch-configure b/comms/gnokii/files/patch-configure
new file mode 100644
index 000000000000..2df59f844725
--- /dev/null
+++ b/comms/gnokii/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig Fri May 10 00:31:53 2002
++++ configure Wed May 22 02:04:02 2002
+@@ -661,7 +661,6 @@
+
+
+
+-CFLAGS="-O2 -Wall"
+ ALL_LINGUAS="cs de et fi nl sk pl it sl"
+
+ echo $ac_n "checking for include/config.h.in""... $ac_c" 1>&6
+@@ -1970,8 +1969,8 @@
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+
+- PTHREAD_CFLAGS="$PTHREAD_CFLAGS -D_THREAD_SAFE"
+- PTHREAD_LIBS="-pthread"
++ PTHREAD_CFLAGS="$PTHREAD_CFLAGS %%PTHREAD_CFLAGS%%"
++ PTHREAD_LIBS="%%PTHREAD_LIBS%%"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
diff --git a/comms/gnokii/files/patch-configure.in b/comms/gnokii/files/patch-configure.in
deleted file mode 100644
index 7b0186e12b97..000000000000
--- a/comms/gnokii/files/patch-configure.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.in.orig Sun Oct 14 23:38:48 2001
-+++ configure.in Sun Oct 14 23:38:58 2001
-@@ -15,7 +15,6 @@
- AC_PREFIX_DEFAULT("/usr/local")
-
- dnl ======================== Default setting
--CFLAGS="-O2 -Wall"
- ALL_LINGUAS="cs de et fi nl sk pl it sl"
-
- dnl ======================== Checks for programs.
diff --git a/comms/gnokii/files/patch-gnokiid-Makefile b/comms/gnokii/files/patch-gnokiid-Makefile
deleted file mode 100644
index 7d18607fd783..000000000000
--- a/comms/gnokii/files/patch-gnokiid-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- gnokiid/Makefile.orig Fri Sep 28 02:07:58 2001
-+++ gnokiid/Makefile Mon Oct 15 01:48:39 2001
-@@ -37,9 +37,9 @@
- @echo "done"
-
- install-suid: all
-- @if [ -z "/bin/grep -e '^gnokii:' /etc/group" ]; then \
-- /usr/sbin/groupadd gnokii; \
-- fi
-+ @if (/usr/sbin/pw groupshow gnokii >/dev/null 2>&1); \
-+ then echo "Group gnokii exists. Fine.";\
-+ else /usr/sbin/pw groupadd gnokii; fi
- $(INSTALL) -d $(sbindir)
- $(INSTALL) -o root -g gnokii -m 4750 gnokiid $(sbindir)
- @echo "done"
diff --git a/comms/gnokii/files/patch-gnokiirc b/comms/gnokii/files/patch-gnokiirc
index 95967271e571..f11b412b40f3 100644
--- a/comms/gnokii/files/patch-gnokiirc
+++ b/comms/gnokii/files/patch-gnokiirc
@@ -1,6 +1,6 @@
---- Docs/sample/gnokiirc.orig Thu May 3 00:55:27 2001
-+++ Docs/sample/gnokiirc Thu May 3 00:55:36 2001
-@@ -5,7 +5,7 @@
+--- Docs/sample/gnokiirc.orig Fri May 10 00:31:47 2002
++++ Docs/sample/gnokiirc Thu May 23 02:07:50 2002
+@@ -5,10 +5,10 @@
[global]
# Set port to the physical serial port used to connect to your phone
@@ -8,4 +8,26 @@
+port = /dev/cuaa0
# Set model to the model number of your phone
- model = 6110
+-model = 6110
++model = 6210
+
+ # Initlength controls the number of characters sent to the
+ # phone during initialisation. You can either set it to
+@@ -38,7 +38,7 @@
+ # port software (eg. minicom). If you have wrong permissions for the
+ # directory, a warning will be generated. If you don't want a lockfile, set
+ # it to 'no'.
+-use_locking = yes
++use_locking = no
+
+ # Baudrate to use on serial port connections.
+ # Currently used only by models AT and BIP/CIMD. Defaults to 19200.
+@@ -58,7 +58,7 @@
+
+ # If defined (not commented out by '#') it will quit Gnokii anytime
+ # when DCD line will drop.
+-require_dcd = 1
++#require_dcd = 1
+
+ # Run the specified script(s) right after opening and initializing the device
+ # and before any communucation (right before closing for disconnect_script).