aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-06-12 14:45:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-06-12 14:45:25 +0000
commitc8d5860d24f077fb772b225d8dab7e74755161d6 (patch)
tree78b93cf3d34dcdce1d3d7e66a1037b5549bff402 /comms/gnokii
parentfe2720ba7a16650d8c53949a90fc5c1c86461ed8 (diff)
downloadports-c8d5860d24f077fb772b225d8dab7e74755161d6.tar.gz
ports-c8d5860d24f077fb772b225d8dab7e74755161d6.zip
Notes
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile48
-rw-r--r--comms/gnokii/distinfo6
-rw-r--r--comms/gnokii/files/patch-Docs-Makefile23
-rw-r--r--comms/gnokii/files/patch-Docs-man-Makefile.in11
-rw-r--r--comms/gnokii/files/patch-Makefile.global.in20
-rw-r--r--comms/gnokii/files/patch-Makefile.in14
-rw-r--r--comms/gnokii/files/patch-common-Makefile13
-rw-r--r--comms/gnokii/files/patch-common-Makefile.in12
-rw-r--r--comms/gnokii/files/patch-configure18
-rw-r--r--comms/gnokii/files/patch-gnokiid-Makefile.in13
-rw-r--r--comms/gnokii/files/patch-smsd-Makefile25
-rw-r--r--comms/gnokii/files/patch-smsd-Makefile.in13
-rw-r--r--comms/gnokii/files/patch-xgnokii-Makefile.in12
-rw-r--r--comms/gnokii/pkg-plist65
14 files changed, 117 insertions, 176 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index eff56a078fc9..62e1e1aa02d9 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.6.22
-PORTREVISION= 1
+PORTVERSION= 0.6.26
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -29,11 +28,6 @@ CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
LIBS="-L../common -L${LOCALBASE}/lib" \
PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
-MAN1= gnokii.1 sendsms.1
-MAN8= gnokiid.8 mgnokiidev.8
-PORTDOCS= *
-
-INSTALL_TARGET= install-binaries install-docs install-includes
PKGDEINSTALL= ${PKGINSTALL}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -44,6 +38,12 @@ WANT_GNOME= yes
.include <bsd.port.pre.mk>
+.if !defined(NOPORTDOCS)
+MAN1= gnokii.1 sendsms.1
+MAN8= gnokiid.8 mgnokiidev.8
+PORTDOCS= *
+.endif
+
.if exists(${LOCALBASE}/lib/libical.so)
WITH_ICAL= yes
.endif
@@ -84,6 +84,7 @@ CONFIGURE_ARGS+= --disable-libpcsclite
PLIST_SUB+= SMSD='@comment '
PLIST_SUB+= PGM='@comment '
PLIST_SUB+= MSM='@comment '
+CONFIGURE_ARGS+= --disable-smsd
.else
PLIST_SUB+= SMSD=''
MAN8+= smsd.8
@@ -101,11 +102,6 @@ WITH_PGSQL= yes
.else
PLIST_SUB+= PGM='@comment '
.endif
-.if defined(SMSD_WITH_GLIB1)
-USE_GNOME+= glib12
-.else
-USE_GNOME+= glib20
-.endif
.endif
.if defined(WITHOUT_X11)
@@ -113,9 +109,11 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11='@comment '
.else
USE_XORG= xpm
-USE_GNOME+= gtk20 gnomelibs
+USE_GNOME+= gtk20 libgnome
PLIST_SUB+= X11=''
-MAN1+= xgnokii.1
+.if !defined(NOPORTDOCS)
+MAN1+= xgnokii.1
+.endif
.endif
.if !defined(WITHOUT_NLS)
@@ -137,12 +135,6 @@ pre-fetch:
@${ECHO} "always compiled in."
@${ECHO}
.endif
-.if !defined(SMSD_WITH_GLIB1)
- @${ECHO}
- @${ECHO} "smsd defaults to using glib2, if you'd rather link with glib1
- @${ECHO} "define SMSD_WITH_GLIB1=yes"
- @${ECHO}
-.endif
post-patch:
.for f in ${FIXPREFIX}
@@ -155,24 +147,24 @@ post-patch:
@${REINPLACE_CMD} -E -e "s:^(#ifdef.*)__OpenBSD__:\1__FreeBSD__:" \
${WRKSRC}/${f}
.endfor
- @${REINPLACE_CMD} -e '/pkgconfig/d' ${WRKSRC}/xgnokii/Makefile
-.if defined(SMSD_WITH_GLIB1)
- @cd ${WRKSRC} && ${PATCH} -s <${PATCHDIR}/smsd-Makefile-WITH_GLIB.diff
-.endif
# fix test conditions on configure
@${REINPLACE_CMD} -E \
-e 's|([[:space:]]+test[[:space:]]+.+)==([[:space:]]+"yes")|\1=\2|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${MV} ${WRKSRC}/Docs/man/xgnokii.1x ${WRKSRC}/Docs/man/xgnokii.1
post-build:
.if defined(WITH_SMSD)
.if defined(WITH_MYSQL)
- @${REINPLACE_CMD} -e 's/^DB_LIBS := libfile.la$$/DB_LIBS = libfile.la libmysql.la/' ${WRKSRC}/smsd/Makefile
+ @${REINPLACE_CMD} -e 's/^#libsmsd_mysql_la_SOURCES/libsmsd_mysql_la_SOURCES/' ${WRKSRC}/smsd/Makefile.in
+ @${REINPLACE_CMD} -e 's/^#libsmsd_mysql_la_LDFLAGS/libsmsd_mysql_la_LDFLAGS/' ${WRKSRC}/smsd/Makefile.in
+ @${REINPLACE_CMD} -e 's/^#libsmsd_mysql_la_LIBADD/libsmsd_mysql_la_LIBADD/' ${WRKSRC}/smsd/Makefile.in
.endif
.if defined(WITH_PGSQL)
- @${REINPLACE_CMD} -e 's/^DB_LIBS := libfile.la$$/DB_LIBS = libfile.la libpq.la/' -e 's/^DB_LIBS = libfile.la libmysql.la$$/DB_LIBS = libfile.la libpq.la libmysql.la/' ${WRKSRC}/smsd/Makefile
+ @${REINPLACE_CMD} -e 's/^#libsmsd_pq_la_SOURCES/libsmsd_pq_la_SOURCES/' ${WRKSRC}/smsd/Makefile.in
+ @${REINPLACE_CMD} -e 's/^#libsmsd_pq_la_LDFLAGS/libsmsd_pq_la_LDFLAGS/' ${WRKSRC}/smsd/Makefile.in
+ @${REINPLACE_CMD} -e 's/^#libsmsd_pq_la_LIBADD/libsmsd_pq_la_LIBADD/' ${WRKSRC}/smsd/Makefile.in
.endif
- @cd ${WRKSRC}/smsd && ${GMAKE} all
.endif
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
@@ -183,7 +175,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/xgnokii/xgnokii.pc ${PREFIX}/libdata/pkgconfig
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if !defined(NOPORTDOCS)
- @(cd ${WRKSRC} && ${GMAKE} install-docs)
+ @(cd ${WRKSRC}/Docs && ${GMAKE} install)
.endif
${INSTALL_DATA} ${WRKSRC}/Docs/sample/gnokiirc \
${PREFIX}/etc/gnokiirc.sample
diff --git a/comms/gnokii/distinfo b/comms/gnokii/distinfo
index 238600fac133..d5235e7a1efc 100644
--- a/comms/gnokii/distinfo
+++ b/comms/gnokii/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnokii-0.6.22.tar.bz2) = 15d64a4911735ee30c03a7bfa9b60f05
-SHA256 (gnokii-0.6.22.tar.bz2) = 9c72fdb581bc0a3653962931592439489be7d9306cd71e94b48689545aeb7be0
-SIZE (gnokii-0.6.22.tar.bz2) = 1808129
+MD5 (gnokii-0.6.26.tar.bz2) = 60f817d8ce748fea0ec9a05b3537e08d
+SHA256 (gnokii-0.6.26.tar.bz2) = 35242b5545ced25383ac8c771b602c15b5585063c3637a23c9ef0a31d3e591ea
+SIZE (gnokii-0.6.26.tar.bz2) = 1446615
diff --git a/comms/gnokii/files/patch-Docs-Makefile b/comms/gnokii/files/patch-Docs-Makefile
deleted file mode 100644
index bb0fcc36c7e6..000000000000
--- a/comms/gnokii/files/patch-Docs-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- Docs/Makefile.orig Tue Jul 8 23:23:28 2003
-+++ Docs/Makefile Tue Jul 8 23:24:48 2003
-@@ -63,6 +63,7 @@
- @echo
-
- install:
-+ifndef NOPORTDOCS
- $(INSTALL) -d $(DESTDIR)$(docdir)
- $(INSTALL) -d $(DESTDIR)$(docdir)/sample/logo
- $(INSTALL) -d $(DESTDIR)$(docdir)/sample/ringtone
-@@ -79,10 +80,10 @@
- $(INSTALL_DATA) $(GNOKII1_MAN) $(DESTDIR)$(man1dir)
- $(INSTALL_DATA) $(GNOKII8_MAN) $(DESTDIR)$(man8dir)
- if [ "x$(HAVE_XGNOKII)" = "xyes" ]; then \
-- $(INSTALL) -d $(DESTDIR)$(xmandir); \
-- $(INSTALL_DATA) $(XGNOKII_MAN) $(DESTDIR)$(xmandir); \
-+ $(INSTALL) $(XGNOKII_MAN) $(DESTDIR)/$(xmandir)/xgnokii.1; \
- fi
- @echo "done"
-+endif
-
- clean:
- $(RM) *~
diff --git a/comms/gnokii/files/patch-Docs-man-Makefile.in b/comms/gnokii/files/patch-Docs-man-Makefile.in
new file mode 100644
index 000000000000..38413ce17882
--- /dev/null
+++ b/comms/gnokii/files/patch-Docs-man-Makefile.in
@@ -0,0 +1,11 @@
+--- Docs/man/Makefile.in.orig 2008-02-23 17:36:56.000000000 +0100
++++ Docs/man/Makefile.in 2008-02-23 17:52:50.000000000 +0100
+@@ -252,7 +252,7 @@
+ target_vendor = @target_vendor@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-man_MANS = gnokii.1 sendsms.1 gnokiid.8 mgnokiidev.8 xgnokii.1x
++man_MANS = gnokii.1 sendsms.1 gnokiid.8 mgnokiidev.8 xgnokii.1
+ EXTRA_DIST = $(man_MANS)
+ all: all-am
+
diff --git a/comms/gnokii/files/patch-Makefile.global.in b/comms/gnokii/files/patch-Makefile.global.in
deleted file mode 100644
index e92c4c3fad01..000000000000
--- a/comms/gnokii/files/patch-Makefile.global.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.global.in.orig 2007-11-24 12:31:01.000000000 +0100
-+++ Makefile.global.in 2007-12-06 11:58:02.000000000 +0100
-@@ -21,14 +21,14 @@
-
- bindir = @bindir@
- sbindir = @sbindir@
--xbindir = @XGNOKIIDIR@/bin/
-+xbindir = ${prefix}/bin/
- libdir = @libdir@
--xgnokii_libdir = @XGNOKIIDIR@/share/@XPACKAGE@
-+xgnokii_libdir = ${prefix}/share/@XPACKAGE@
- includedir = @includedir@
- mandir = @mandir@
- man1dir = ${mandir}/man1/
- man8dir = ${mandir}/man8/
--xmandir = @XGNOKIIDIR@/man/man1/
-+xmandir = ${mandir}/man1/
- datarootdir = @datarootdir@
- docdir = @docdir@
- datadir = @datadir@
diff --git a/comms/gnokii/files/patch-Makefile.in b/comms/gnokii/files/patch-Makefile.in
new file mode 100644
index 000000000000..bbaa5eb32a77
--- /dev/null
+++ b/comms/gnokii/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig 2008-06-02 15:48:31.000000000 +0200
++++ Makefile.in 2008-06-02 15:48:47.000000000 +0200
+@@ -279,9 +279,9 @@
+ target_vendor = @target_vendor@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = include common gnokii po patches Docs $(am__append_1) \
++SUBDIRS = include common gnokii po patches $(am__append_1) \
+ $(am__append_2) $(am__append_3)
+-DIST_SUBDIRS = include Docs common gnokii gnokiid utils xgnokii po smsd win32 testsuite patches getopt
++DIST_SUBDIRS = include common gnokii gnokiid utils xgnokii po smsd win32 testsuite patches getopt
+ EXTRA_DIST = \
+ ChangeLog \
+ COPYING \
diff --git a/comms/gnokii/files/patch-common-Makefile b/comms/gnokii/files/patch-common-Makefile
deleted file mode 100644
index 1a191332218f..000000000000
--- a/comms/gnokii/files/patch-common-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- common/Makefile.orig 2007-11-24 12:31:01.000000000 +0100
-+++ common/Makefile 2007-12-06 12:02:39.000000000 +0100
-@@ -107,8 +107,8 @@
- @echo "done"
-
- install-devel: install
-- $(INSTALL) -d $(DESTDIR)$(libdir)/pkgconfig
-- $(INSTALL_DATA) gnokii.pc $(DESTDIR)$(libdir)/pkgconfig
-+ $(INSTALL) -d $(DESTDIR)$(prefix)/libdata/pkgconfig
-+ $(INSTALL_DATA) gnokii.pc $(DESTDIR)$(prefix)/libdata/pkgconfig
- @echo "done"
-
- depend dep:
diff --git a/comms/gnokii/files/patch-common-Makefile.in b/comms/gnokii/files/patch-common-Makefile.in
new file mode 100644
index 000000000000..31358b6e36d4
--- /dev/null
+++ b/comms/gnokii/files/patch-common-Makefile.in
@@ -0,0 +1,12 @@
+--- common/Makefile.in.orig 2008-02-23 17:18:24.000000000 +0100
++++ common/Makefile.in 2008-02-23 17:18:53.000000000 +0100
+@@ -318,7 +318,8 @@
+ $(DATA_DIR)
+
+ pkgconfig_DATA = gnokii.pc
+-pkgconfigdir = $(libdir)/pkgconfig
++libdatadir = $(libdir)data
++pkgconfigdir = $(libdatadir)/pkgconfig
+ libgnokii_la_CPPFLAGS = -DLIBDIR="\"$(libdir)\""
+ libgnokii_la_CFLAGS = -I$(top_srcdir)/include
+ libgnokii_la_SOURCES = \
diff --git a/comms/gnokii/files/patch-configure b/comms/gnokii/files/patch-configure
index adc7bc1a87f7..e40a41d025d5 100644
--- a/comms/gnokii/files/patch-configure
+++ b/comms/gnokii/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2007-11-24 12:31:25.000000000 +0100
-+++ configure 2007-12-06 12:08:24.000000000 +0100
-@@ -981,7 +981,7 @@
+--- configure.orig 2008-02-15 10:21:49.000000000 +0100
++++ configure 2008-02-23 11:08:39.000000000 +0100
+@@ -1050,7 +1050,7 @@
psdir='${docdir}'
libdir='${exec_prefix}/lib'
localedir='${datarootdir}/locale'
@@ -9,7 +9,7 @@
ac_prev=
ac_dashdash=
-@@ -26588,13 +26588,15 @@
+@@ -22653,13 +22653,15 @@
# First of all, check if the user has set any of the PTHREAD_LIBS,
# etcetera environment variables, and if threads linking works using
# them:
@@ -30,7 +30,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -26958,7 +26960,7 @@
+@@ -23023,7 +23025,7 @@
echo $ECHO_N "checking if more special flags are required for pthreads... $ECHO_C" >&6; }
flag=no
case "${host_cpu}-${host_os}" in
@@ -39,7 +39,7 @@
*solaris* | *-osf* | *-hpux*) flag="-D_REENTRANT";;
esac
{ echo "$as_me:$LINENO: result: ${flag}" >&5
-@@ -27762,7 +27764,7 @@
+@@ -23840,7 +23842,7 @@
if test "$enable_libical" == "yes"; then
OLD_CFLAGS="$CFLAGS"
@@ -48,12 +48,12 @@
CFLAGS="$CFLAGS $ICAL_CFLAGS"
{ echo "$as_me:$LINENO: checking whether libical is installed" >&5
echo $ECHO_N "checking whether libical is installed... $ECHO_C" >&6; }
-@@ -29577,7 +29579,7 @@
+@@ -25684,7 +25686,7 @@
echo "${ECHO_T}$ac_cv_lib_Xpm_XpmWriteFileFromXpmImage" >&6; }
if test $ac_cv_lib_Xpm_XpmWriteFileFromXpmImage = yes; then
XPM_CFLAGS="$XINCL"
- XPM_LIBS="$XLIBS -lXpm -lX11"
+ XPM_LIBS="$XLIBS -lXpm -lX11 -lroken -lcrypt"
- cat >>confdefs.h <<\_ACEOF
+
+ cat >>confdefs.h <<\_ACEOF
#define XPM 1
- _ACEOF
diff --git a/comms/gnokii/files/patch-gnokiid-Makefile.in b/comms/gnokii/files/patch-gnokiid-Makefile.in
new file mode 100644
index 000000000000..e816577a9e2b
--- /dev/null
+++ b/comms/gnokii/files/patch-gnokiid-Makefile.in
@@ -0,0 +1,13 @@
+--- gnokiid/Makefile.in.orig 2008-05-03 21:21:29.000000000 +0200
++++ gnokiid/Makefile.in 2008-05-29 22:14:16.000000000 +0200
+@@ -322,8 +322,8 @@
+ || test -f $$p1 \
+ ; then \
+ f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
+- echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
+- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
++ echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(sbindir)/$$f'"; \
++ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(sbindir)/$$f" || exit 1; \
+ else :; fi; \
+ done
+
diff --git a/comms/gnokii/files/patch-smsd-Makefile b/comms/gnokii/files/patch-smsd-Makefile
deleted file mode 100644
index 8674bfd42983..000000000000
--- a/comms/gnokii/files/patch-smsd-Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
---- smsd/Makefile.orig Tue Jul 24 22:31:35 2007
-+++ smsd/Makefile Wed Jul 25 23:18:11 2007
-@@ -29,9 +29,9 @@
- LDLIBS += $(PTHREAD_LIBS) \
- $(shell $(GLIBLDLIBS))
-
--LDLIBS += -rdynamic $(TOPDIR)/common/libgnokii.la -ldl
-+# LDLIBS += -rdynamic $(TOPDIR)/common/libgnokii.la -ldl
- # Some systems, eg. FreeBSD don't have libdl. Use this:
--# LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii -pthread -L../getopt -lgetopt
-+LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii -pthread
-
- OBJS = smsd.lo \
- lowlevel.lo
-@@ -39,8 +39,8 @@
-
- # A list of database modules to build.
- # FIXME: detect which ones to build in configure
--DB_LIBS = libfile.la libpq.la libmysql.la
--#DB_LIBS := libfile.la
-+#DB_LIBS = libfile.la libpq.la libmysql.la
-+DB_LIBS := libfile.la
-
- all: smsd
-
diff --git a/comms/gnokii/files/patch-smsd-Makefile.in b/comms/gnokii/files/patch-smsd-Makefile.in
new file mode 100644
index 000000000000..f8d7655d67aa
--- /dev/null
+++ b/comms/gnokii/files/patch-smsd-Makefile.in
@@ -0,0 +1,13 @@
+--- smsd/Makefile.in.orig 2008-05-03 21:21:32.000000000 +0200
++++ smsd/Makefile.in 2008-05-29 22:16:37.000000000 +0200
+@@ -416,8 +416,8 @@
+ || test -f $$p1 \
+ ; then \
+ f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
+- echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
+- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
++ echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(sbindir)/$$f'"; \
++ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(sbindir)/$$f" || exit 1; \
+ else :; fi; \
+ done
+
diff --git a/comms/gnokii/files/patch-xgnokii-Makefile.in b/comms/gnokii/files/patch-xgnokii-Makefile.in
new file mode 100644
index 000000000000..afa95721373d
--- /dev/null
+++ b/comms/gnokii/files/patch-xgnokii-Makefile.in
@@ -0,0 +1,12 @@
+--- xgnokii/Makefile.in.orig 2008-02-23 17:19:30.000000000 +0100
++++ xgnokii/Makefile.in 2008-02-23 17:19:58.000000000 +0100
+@@ -351,7 +351,8 @@
+ #FIXME install help
+ HELP_DIR = docs/help
+ pkgconfig_DATA = xgnokii.pc
+-pkgconfigdir = $(libdir)/pkgconfig
++libdatadir = $(libdir)data
++pkgconfigdir = $(libdatadir)/pkgconfig
+ desktop_in_files = xgnokii.desktop.in
+ desktopdir = $(datadir)/applications
+ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index d2298a2c0b9b..20e13ba11b9a 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -20,7 +20,7 @@ include/gnokii/wappush.h
lib/libgnokii.a
lib/libgnokii.la
lib/libgnokii.so
-lib/libgnokii.so.9
+lib/libgnokii.so.12
libdata/pkgconfig/gnokii.pc
libdata/pkgconfig/xgnokii.pc
sbin/gnokiid
@@ -41,24 +41,20 @@ sbin/mgnokiidev
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnokii.mo
%%SMSD%%share/smsd/README
%%SMSD%%share/smsd/action
-%%SMSD%%lib/smsd/libfile.a
-%%SMSD%%lib/smsd/libfile.la
-%%SMSD%%lib/smsd/libfile.so
-%%MSM%%lib/smsd/libmysql.a
-%%MSM%%lib/smsd/libmysql.la
-%%MSM%%lib/smsd/libmysql.so
+%%SMSD%%lib/smsd/libsmsd_file.a
+%%SMSD%%lib/smsd/libsmsd_file.la
+%%SMSD%%lib/smsd/libsmsd_file.so
+%%MSM%%lib/smsd/libsmsd_mysql.a
+%%MSM%%lib/smsd/libsmsd_mysql.la
+%%MSM%%lib/smsd/libsmsd_mysql.so
%%MSM%%share/smsd/sms.tables.mysql.sql
-%%PGM%%lib/smsd/libpq.a
-%%PGM%%lib/smsd/libpq.la
-%%PGM%%lib/smsd/libpq.so
+%%PGM%%lib/smsd/libsmsd_pq.a
+%%PGM%%lib/smsd/libsmsd_pq.la
+%%PGM%%lib/smsd/libsmsd_pq.so
%%PGM%%share/smsd/sms.tables.pq.sql
%%SMSD%%@dirrm lib/smsd
%%SMSD%%@dirrm share/smsd
%%X11%%share/applications/xgnokii.desktop
-%%X11%%share/xgnokii/help/C
-%%X11%%share/xgnokii/help/POSIX
-%%X11%%share/xgnokii/help/en_US/COPYING
-%%X11%%share/xgnokii/help/en_US/CREDITS
%%X11%%share/xgnokii/help/en_US/faq.html
%%X11%%share/xgnokii/help/en_US/firmware/firmware.html
%%X11%%share/xgnokii/help/en_US/index.html
@@ -77,7 +73,6 @@ sbin/mgnokiidev
%%X11%%share/xgnokii/help/en_US/netmon/nm_5110.png
%%X11%%share/xgnokii/help/en_US/netmon/nm_9110.png
%%X11%%share/xgnokii/help/en_US/netmon/tip.png
-%%X11%%share/xgnokii/help/en_US/sample/gnokiirc
%%X11%%share/xgnokii/help/en_US/styl.css
%%X11%%share/xgnokii/help/pl_PL/calendar.html
%%X11%%share/xgnokii/help/pl_PL/contacts.html
@@ -120,48 +115,8 @@ sbin/mgnokiidev
%%X11%%share/xgnokii/help/pl_PL/sms.html
%%X11%%share/xgnokii/help/pl_PL/speeddial.html
%%X11%%share/xgnokii/help/pl_PL/xkeyb.html
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/calendar
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/contacts
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/dtmf
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/main
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/netmon/gsm
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/sms
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/speeddial
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/xkeyb
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/cables
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/irda
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/calendar
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/contacts
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/dtmf
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/main
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/netmon
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/sms
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/speeddial
-%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/windows/xkeyb
-%%X11%%@exec mkdir -p %D/share/doc/gnokii/sample/vCard
-%%X11%%@dirrm share/xgnokii/help/en_US/cables
-%%X11%%@dirrm share/xgnokii/help/en_US/calendar
-%%X11%%@dirrm share/xgnokii/help/en_US/contacts
-%%X11%%@dirrm share/xgnokii/help/en_US/dtmf
%%X11%%@dirrm share/xgnokii/help/en_US/firmware
-%%X11%%@dirrm share/xgnokii/help/en_US/irda
-%%X11%%@dirrm share/xgnokii/help/en_US/main
-%%X11%%@dirrm share/xgnokii/help/en_US/netmon/gsm
%%X11%%@dirrm share/xgnokii/help/en_US/netmon
-%%X11%%@dirrm share/xgnokii/help/en_US/sms
-%%X11%%@dirrm share/xgnokii/help/en_US/speeddial
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/calendar
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/contacts
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/dtmf
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/main
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/netmon
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/sms
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/speeddial
-%%X11%%@dirrm share/xgnokii/help/en_US/windows/xkeyb
-%%X11%%@dirrm share/xgnokii/help/en_US/windows
-%%X11%%@dirrm share/xgnokii/help/en_US/xkeyb
-%%X11%%@dirrm share/xgnokii/help/en_US/sample
%%X11%%@dirrm share/xgnokii/help/en_US
%%X11%%@dirrm share/xgnokii/help/pl_PL/netmon/gsm
%%X11%%@dirrm share/xgnokii/help/pl_PL/netmon