aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2017-01-07 19:06:33 +0000
committerDiane Bruce <db@FreeBSD.org>2017-01-07 19:06:33 +0000
commit6ef184451edd611814b9bf9d6cdf23bee2b89d6e (patch)
treec5250377aee193b8faeb19c15a594fae37cc631a /comms/gnuradio/Makefile
parent041a95b1211b6070506fb0723fd73e6bbdab2a9c (diff)
downloadports-6ef184451edd611814b9bf9d6cdf23bee2b89d6e.tar.gz
ports-6ef184451edd611814b9bf9d6cdf23bee2b89d6e.zip
Notes
Diffstat (limited to 'comms/gnuradio/Makefile')
-rw-r--r--comms/gnuradio/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 6f06d7919717..314f2b94d42c 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gnuradio
-PORTVERSION= 3.7.9.2
-PORTREVISION= 5
+PORTVERSION= 3.7.10.1
CATEGORIES= comms astro hamradio
MASTER_SITES= http://gnuradio.org/releases/gnuradio/ \
LOCAL/db
@@ -24,6 +23,7 @@ BUILD_DEPENDS= sdl-config:devel/sdl12 \
${PYNUMPY} \
${PYTHON_SITELIBDIR}/ephem/__init__.py:astro/pyephem
LIB_DEPENDS= libcppunit.so:devel/cppunit \
+ libcodec2.so:audio/codec2 \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libqwt.so:x11-toolkits/qwt5 \
@@ -42,7 +42,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
USES= cmake:outsource compiler:c11 iconv perl5 pkgconfig python:2.7 shebangfix
-SHEBANG_FILES= grc/freedesktop/grc_setup_freedesktop.in
+SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in
CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"\
-DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
-DICONV_LIB:STRING="X${ICONV_LIB}" \
@@ -51,8 +51,8 @@ CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"\
-DCMAKE_INSTALL_RPATH:STRING="${LOCALBASE}/lib/gcc${_GCC_VER}"
# for detailed debugging uncomment the next line
#CMAKE_ARGS+= --debug-output --trace
-MAJOR_SUB_VER= 3.7.9.2
-DOCSDIR= share/doc/${PORTNAME}-${MAJOR_SUB_VER}
+MAJOR_SUB_VER= ${PORTVERSION}
+DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
USE_GNOME= pygtk2
USE_WX= 3.0+
USE_QT4= corelib gui xml qmake moc rcc uic