aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-14 11:16:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-14 11:16:55 +0000
commit2648d11bfa3f286ed1fdb13ec501e0a68ef9660a (patch)
tree7f45812e8d016b221ce4f01317df38095446baf7 /comms/gnuradio/Makefile
parent3df44021e43cc5be7dfd7ddcb3bc975028ec3e22 (diff)
downloadports-2648d11bfa3f286ed1fdb13ec501e0a68ef9660a.tar.gz
ports-2648d11bfa3f286ed1fdb13ec501e0a68ef9660a.zip
Notes
Diffstat (limited to 'comms/gnuradio/Makefile')
-rw-r--r--comms/gnuradio/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 078c6592b3ef..f26f6bbc024c 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -36,7 +36,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= cmake:outsource iconv perl5 python:2.7 shebangfix
SHEBANG_FILES= grc/freedesktop/grc_setup_freedesktop.in
-CONFIGURE_ENV+= LD_PRELOAD="${GCC_LIBS}/libstdc++.so:${GCC_LIBS}/libgcc_s.so.1"
CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"
CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
-DICONV_LIB:STRING="X${ICONV_LIB}" \
@@ -46,7 +45,6 @@ CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
MAJOR_SUB_VER= 3.7.7
DOCSDIR= share/doc/${PORTNAME}-${MAJOR_SUB_VER}
USE_GNOME= pygtk2
-USE_GCC= yes
USE_WX= 3.0+
USE_QT4= gui xml qmake moc rcc uic
WX_COMPS= wx wx:build wx:run python:build python:run
@@ -64,8 +62,6 @@ USRP_DESC= Include USRP support (UHD) from Ettus
TESTING_DESC= Include testing support
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-VP= ${GCC_DEFAULT:S/.//}
-GCC_LIBS= ${LOCALBASE}/lib/gcc${VP}
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
${LOCALBASE}/bin/sphinx-apidoc:${PORTSDIR}/textproc/py-sphinx \
@@ -88,6 +84,12 @@ TESTING_CMAKE_ON= -DENABLE_TESTING:STRING="ON"
TESTING_CMAKE_OFF= -DENABLE_TESTING:STRING="OFF"
TESTING_BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+USE_GCC= yes
+.endif
+
post-patch:
@${FIND} ${WRKSRC}/.. -name CMakeLists.txt | \
${XARGS} ${REINPLACE_CMD} -e \