aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio/files
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-09-01 00:42:49 +0000
committerDiane Bruce <db@FreeBSD.org>2014-09-01 00:42:49 +0000
commit64a1be3275bd28a3858472477959ca2f376e6dbc (patch)
tree361ca5639e80d25a0ff2c474f440cc44c34deab3 /comms/gnuradio/files
parent183766ca91c7bfa2bb986bdb9fe85db5eaaa8d84 (diff)
Notes
Diffstat (limited to 'comms/gnuradio/files')
-rw-r--r--comms/gnuradio/files/patch-CMakeLists.txt12
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_FindICE-3.5.cmake10
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake39
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_GrMiscUtils.cmake8
-rw-r--r--comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in10
-rw-r--r--comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt8
-rw-r--r--comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc14
-rw-r--r--comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt24
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_CMakeLists.txt30
-rw-r--r--comms/gnuradio/files/patch-gr-utils_python_modtool_CMakeLists.txt6
-rw-r--r--comms/gnuradio/files/patch-grc_CMakeLists.txt20
-rw-r--r--comms/gnuradio/files/patch-volk_CMakeLists.txt6
12 files changed, 105 insertions, 82 deletions
diff --git a/comms/gnuradio/files/patch-CMakeLists.txt b/comms/gnuradio/files/patch-CMakeLists.txt
index 09db443c8cee..e6c0de30196b 100644
--- a/comms/gnuradio/files/patch-CMakeLists.txt
+++ b/comms/gnuradio/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2013-11-29 19:04:23.000000000 -0500
-+++ CMakeLists.txt 2014-03-10 16:31:14.000000000 -0500
-@@ -108,6 +108,14 @@
+--- CMakeLists.txt.orig 2014-07-08 17:32:11.000000000 -0400
++++ CMakeLists.txt 2014-07-29 18:41:58.000000000 -0400
+@@ -139,6 +139,14 @@
########################################################################
include(GrPlatform) #define LIB_SUFFIX
set(GR_RUNTIME_DIR bin)
@@ -15,8 +15,8 @@
set(GR_LIBRARY_DIR lib${LIB_SUFFIX})
set(GR_INCLUDE_DIR include)
set(GR_DATA_DIR share)
-@@ -163,6 +171,42 @@
- )
+@@ -199,6 +207,42 @@
+ include(GrBoost)
########################################################################
+# FreeBSD iconv
@@ -58,7 +58,7 @@
# Enable python component
########################################################################
find_package(PythonLibs 2)
-@@ -247,11 +291,13 @@
+@@ -283,11 +327,13 @@
########################################################################
# Distribute the README file
########################################################################
diff --git a/comms/gnuradio/files/patch-cmake_Modules_FindICE-3.5.cmake b/comms/gnuradio/files/patch-cmake_Modules_FindICE-3.5.cmake
deleted file mode 100644
index fd78f321f893..000000000000
--- a/comms/gnuradio/files/patch-cmake_Modules_FindICE-3.5.cmake
+++ /dev/null
@@ -1,10 +0,0 @@
---- cmake/Modules/FindICE-3.5.cmake.orig 2013-11-26 12:55:32.000000000 -0500
-+++ cmake/Modules/FindICE-3.5.cmake 2014-03-24 19:53:28.189484207 -0400
-@@ -33,7 +33,6 @@
- # Prepare the path hint for the libraries based on the include
- # directory found.
- string(REGEX REPLACE "/include" "" ICE_PATH ${ICE_CONFIG_INCLUDE_DIR})
--
- FIND_PATH(
- ICE_INCLUDE_DIR
- NAMES IceUtil/IceUtil.h Ice/Ice.h
diff --git a/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake b/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake
index 1cd9d5007a13..fe86a14635d9 100644
--- a/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake
+++ b/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake
@@ -1,26 +1,25 @@
---- cmake/Modules/FindPortaudio.cmake.orig 2012-04-25 11:12:33.000000000 -0500
-+++ cmake/Modules/FindPortaudio.cmake 2014-03-02 20:19:36.000000000 -0500
-@@ -6,7 +6,13 @@
- # PORTAUDIO_LIBRARIES - Link these to use Portaudio
-
+--- cmake/Modules/FindPortaudio.cmake.orig 2014-05-16 18:55:22.000000000 -0400
++++ cmake/Modules/FindPortaudio.cmake 2014-08-04 21:57:47.000000000 -0400
+@@ -8,6 +8,15 @@
include(FindPkgConfig)
--pkg_check_modules(PC_PORTAUDIO portaudio)
+ pkg_check_modules(PC_PORTAUDIO portaudio-2.0)
+
+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+ message( "--- Using Portaudio2 for FreeBSD")
-+ set(PORTAUDIO_FOUND TRUE)
-+ set(PORTAUDIO_INCLUDE_DIRS "%%LOCALBASE%%/include/portaudio2")
-+ set(PORTAUDIO_LIBRARIES "%%LOCALBASE%%/lib/portaudio2/libportaudio.so")
++ message("--- Using Portaudio2 for FreeBSD")
++ set(PORTAUDIO_FOUND_TRUE)
++ set(PORTAUDIO_INCLUDE_DIRS "/usr/local/include/portaudio2")
++ set(PORTAUDIO_LIBRARIES "/usr/local/lib/portaudio2/libportaudio.so")
++ mark_as_advanced(PORTAUDIO_INCLUDE_DIRS PORTAUDIO_LIBRARIES)
++ INCLUDE(FindPackageHandleStandardArgs)
++ FIND_PACKAGE_HANDLE_STANDARD_ARGS(PORTAUDIO DEFAULT_MSG PORTAUDIO_INCLUDE_DIRS PORTAUDIO_LIBRARIES)
+else()
-+ pkg_check_modules(PC_PORTAUDIO portaudio)
-
find_path(PORTAUDIO_INCLUDE_DIRS
NAMES
-@@ -28,7 +34,7 @@
- HINTS
- ${PC_PORTAUDIO_LIBDIR}
- )
--
+ portaudio.h
+@@ -50,3 +59,6 @@
+ set(PORTAUDIO_FOUND FALSE)
+ endif(PORTAUDIO2_FOUND)
+ endif()
++
+endif()
- mark_as_advanced(PORTAUDIO_INCLUDE_DIRS PORTAUDIO_LIBRARIES)
-
- INCLUDE(FindPackageHandleStandardArgs)
++
diff --git a/comms/gnuradio/files/patch-cmake_Modules_GrMiscUtils.cmake b/comms/gnuradio/files/patch-cmake_Modules_GrMiscUtils.cmake
index b39467889cea..cd59e35af5bf 100644
--- a/comms/gnuradio/files/patch-cmake_Modules_GrMiscUtils.cmake
+++ b/comms/gnuradio/files/patch-cmake_Modules_GrMiscUtils.cmake
@@ -1,11 +1,11 @@
---- cmake/Modules/GrMiscUtils.cmake.orig 2013-08-28 13:27:03.000000000 -0500
-+++ cmake/Modules/GrMiscUtils.cmake 2014-03-02 20:19:48.000000000 -0500
+--- cmake/Modules/GrMiscUtils.cmake.orig 2014-07-07 17:29:01.000000000 -0400
++++ cmake/Modules/GrMiscUtils.cmake 2014-07-29 18:42:23.000000000 -0400
@@ -142,7 +142,31 @@
ARCHIVE DESTINATION ${GR_LIBRARY_DIR} COMPONENT ${GR_LIBRARY_DEVEL_COMPONENT} # .lib file
RUNTIME DESTINATION ${GR_RUNTIME_DIR} COMPONENT ${GR_LIBRARY_RUNTIME_COMPONENT} # .dll file
)
+
-+
+
+ if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ #create .la file
+ GR_LIBTOOL(TARGET ${target} DESTINATION ${GR_LIBRARY_DIR})
@@ -20,7 +20,7 @@
+ COMMAND ${CMAKE_COMMAND} -E create_symlink ${target_name} "${CMAKE_CURRENT_BINARY_DIR}/lib${target}.so.${MAJOR_VERSION}"
+ COMMAND ${CMAKE_COMMAND} -E touch ${target_name} #so the symlinks point to something valid so cmake 2.6 will install
+ )
-
++
+ #and install the extra symlinks
+ install(
+ FILES
diff --git a/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in b/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
index ae4213ab62ef..0940a52175da 100644
--- a/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
+++ b/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
@@ -1,8 +1,8 @@
---- docs/doxygen/Doxyfile.in.orig 2013-08-28 13:27:03.000000000 -0500
-+++ docs/doxygen/Doxyfile.in 2014-03-02 20:19:55.000000000 -0500
-@@ -1406,7 +1406,7 @@
- # different font using DOT_FONTNAME you can set the path where dot
- # can find it using this tag.
+--- docs/doxygen/Doxyfile.in.orig 2014-03-31 11:52:54.000000000 -0400
++++ docs/doxygen/Doxyfile.in 2014-07-29 18:42:29.000000000 -0400
+@@ -1839,7 +1839,7 @@
+ # If you specify a different font using DOT_FONTNAME you can use DOT_FONTPATH to
+ # set the path where dot can find it.
-DOT_FONTPATH =
+DOT_FONTPATH = %%PREFIX%%/lib/X11/fonts/freefont-ttf
diff --git a/comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt b/comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt
index 0bc870bd7798..bbc1aa1a2c95 100644
--- a/comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt
+++ b/comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt
@@ -1,6 +1,6 @@
---- gnuradio-runtime/CMakeLists.txt.orig 2013-08-29 00:50:51.000000000 -0400
-+++ gnuradio-runtime/CMakeLists.txt 2014-03-24 14:16:02.728878716 -0400
-@@ -133,18 +133,37 @@
+--- gnuradio-runtime/CMakeLists.txt.orig 2014-07-02 21:09:41.000000000 -0400
++++ gnuradio-runtime/CMakeLists.txt 2014-07-29 18:42:32.000000000 -0400
+@@ -141,18 +141,37 @@
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.conf
@ONLY)
@@ -38,7 +38,7 @@
endif(ENABLE_GR_LOG AND HAVE_LOG4CPP)
########################################################################
-@@ -171,7 +190,7 @@
+@@ -179,7 +198,7 @@
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.pc
diff --git a/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc b/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
index 89c5896c5c5e..b372f891a69e 100644
--- a/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
+++ b/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
@@ -1,6 +1,6 @@
---- gnuradio-runtime/lib/thread/thread.cc.orig 2013-08-28 13:27:03.000000000 -0500
-+++ gnuradio-runtime/lib/thread/thread.cc 2014-03-02 20:19:59.000000000 -0500
-@@ -217,6 +217,7 @@
+--- gnuradio-runtime/lib/thread/thread.cc.orig 2014-07-08 16:55:12.000000000 -0400
++++ gnuradio-runtime/lib/thread/thread.cc 2014-07-29 18:42:37.000000000 -0400
+@@ -276,6 +276,7 @@
void
thread_bind_to_processor(gr_thread_t thread, const std::vector<int> &mask)
{
@@ -8,7 +8,7 @@
cpu_set_t set;
size_t len = sizeof(cpu_set_t);
std::vector<int> _mask = mask;
-@@ -232,6 +233,7 @@
+@@ -291,6 +292,7 @@
s << "thread_bind_to_processor failed with error: " << ret << std::endl;
throw std::runtime_error(s.str());
}
@@ -16,7 +16,7 @@
}
void
-@@ -243,6 +245,7 @@
+@@ -302,6 +304,7 @@
void
thread_unbind(gr_thread_t thread)
{
@@ -24,11 +24,11 @@
cpu_set_t set;
size_t len = sizeof(cpu_set_t);
-@@ -258,6 +261,7 @@
+@@ -317,6 +320,7 @@
s << "thread_unbind failed with error: " << ret << std::endl;
throw std::runtime_error(s.str());
}
+#endif
}
- int
+ int
diff --git a/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt b/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt
index 87c07605136f..56e1c0ce577b 100644
--- a/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt
+++ b/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt
@@ -1,6 +1,6 @@
---- gr-audio/lib/CMakeLists.txt.orig 2013-08-28 14:27:03.000000000 -0400
-+++ gr-audio/lib/CMakeLists.txt 2014-03-27 20:18:01.614518348 -0400
-@@ -127,8 +127,8 @@
+--- gr-audio/lib/CMakeLists.txt.orig 2014-07-02 21:09:41.000000000 -0400
++++ gr-audio/lib/CMakeLists.txt 2014-08-02 14:55:41.000000000 -0400
+@@ -136,8 +136,8 @@
if(PORTAUDIO_FOUND)
@@ -11,16 +11,20 @@
list(APPEND gr_audio_libs ${PORTAUDIO_LIBRARIES})
add_definitions(${PORTAUDIO_DEFINITIONS})
list(APPEND gr_audio_sources
-@@ -175,4 +175,12 @@
+@@ -184,7 +184,15 @@
target_link_libraries(gnuradio-audio ${gr_audio_libs})
GR_LIBRARY_FOO(gnuradio-audio RUNTIME_COMPONENT "audio_runtime" DEVEL_COMPONENT "audio_devel")
+-install(FILES ${gr_audio_confs} DESTINATION ${GR_PREFSDIR} COMPONENT "audio_runtime")
+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+foreach (audioconf ${gr_audio_confs})
-+GET_FILENAME_COMPONENT(baseaudioconf ${audioconf} NAME)
-+set(newaudioconf "${baseaudioconf}.sample")
-+install(FILES ${audioconf} DESTINATION ${GR_PREFSDIR} RENAME ${newaudioconf} COMPONENT "audio_runtime")
-+endforeach()
++ foreach (audioconf ${gr_audio_confs})
++ GET_FILENAME_COMPONENT(baseaudioconf ${audioconf} NAME)
++ set(newaudioconf "${baseaudioconf}.sample")
++ install(FILES ${audioconf} DESTINATION ${GR_PREFSDIR} RENAME ${newaudioconf} COMPONENT "audio_runtime")
++ endforeach()
+else()
- install(FILES ${gr_audio_confs} DESTINATION ${GR_PREFSDIR} COMPONENT "audio_runtime")
++ install(FILES ${gr_audio_confs} DESTINATION ${GR_PREFSDIR} COMPONENT "audio_runtime")
+endif()
+
+ if(ENABLE_STATIC_LIBS)
+ add_library(gnuradio-audio_static STATIC ${gr_audio_sources})
diff --git a/comms/gnuradio/files/patch-gr-qtgui_CMakeLists.txt b/comms/gnuradio/files/patch-gr-qtgui_CMakeLists.txt
new file mode 100644
index 000000000000..19ee70dc442b
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_CMakeLists.txt
@@ -0,0 +1,30 @@
+--- gr-qtgui/CMakeLists.txt.orig 2014-08-02 15:09:03.000000000 -0400
++++ gr-qtgui/CMakeLists.txt 2014-08-02 15:11:16.000000000 -0400
+@@ -128,17 +128,26 @@
+
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-qtgui.pc
+- DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
++ DESTINATION ${GR_PKGCONFIG_DIR}/pkgconfig
+ COMPONENT "qtgui_devel"
+ )
+
+ ########################################################################
+ # Install the conf file
+ ########################################################################
++if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
++install(
++ FILES ${CMAKE_CURRENT_SOURCE_DIR}/gr-qtgui.conf
++ DESTINATION ${GR_PREFSDIR}
++ RENAME "gr-qtgui.conf.sample"
++ COMPONENT "qtgui"
++)
++elseif()
+ install(
+ FILES ${CMAKE_CURRENT_SOURCE_DIR}/gr-qtgui.conf
+ DESTINATION ${GR_PREFSDIR}
+ COMPONENT "qtgui"
+ )
++endif()
+
+ endif(ENABLE_GR_QTGUI)
diff --git a/comms/gnuradio/files/patch-gr-utils_python_modtool_CMakeLists.txt b/comms/gnuradio/files/patch-gr-utils_python_modtool_CMakeLists.txt
index 59c6daff9033..2ebd4cacb710 100644
--- a/comms/gnuradio/files/patch-gr-utils_python_modtool_CMakeLists.txt
+++ b/comms/gnuradio/files/patch-gr-utils_python_modtool_CMakeLists.txt
@@ -1,6 +1,6 @@
---- gr-utils/python/modtool/CMakeLists.txt.orig 2014-03-24 23:22:18.237619193 -0400
-+++ gr-utils/python/modtool/CMakeLists.txt 2014-03-24 23:24:08.673612691 -0400
-@@ -56,9 +56,17 @@
+--- gr-utils/python/modtool/CMakeLists.txt.orig 2014-02-22 12:29:47.000000000 -0500
++++ gr-utils/python/modtool/CMakeLists.txt 2014-07-29 18:43:53.000000000 -0400
+@@ -57,9 +57,17 @@
${CMAKE_CURRENT_BINARY_DIR}/modtool.conf
@ONLY)
diff --git a/comms/gnuradio/files/patch-grc_CMakeLists.txt b/comms/gnuradio/files/patch-grc_CMakeLists.txt
index b981b02164cf..ce93e8922eb0 100644
--- a/comms/gnuradio/files/patch-grc_CMakeLists.txt
+++ b/comms/gnuradio/files/patch-grc_CMakeLists.txt
@@ -1,23 +1,23 @@
---- grc/CMakeLists.txt.orig 2013-08-28 13:27:03.000000000 -0500
-+++ grc/CMakeLists.txt 2014-03-02 20:20:40.000000000 -0500
+--- grc/CMakeLists.txt.orig 2014-08-02 15:03:57.000000000 -0400
++++ grc/CMakeLists.txt 2014-08-02 15:03:59.000000000 -0400
@@ -73,11 +73,21 @@
${CMAKE_CURRENT_BINARY_DIR}/grc.conf
@ONLY)
-+# FreeBSD needs an original copy
+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
++ install(
++ FILES ${CMAKE_CURRENT_BINARY_DIR}/grc.conf
++ DESTINATION ${GR_PREFSDIR}
++ RENAME "grc.conf.sample"
++ COMPONENT "grc"
++ )
++
++elseif()
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/grc.conf
DESTINATION ${GR_PREFSDIR}
-+ RENAME "grc.conf.sample"
COMPONENT "grc"
)
-+elseif()
-+install(
-+ FILES ${CMAKE_CURRENT_BINARY_DIR}/grc.conf
-+ DESTINATION ${GR_PREFSDIR}
-+ COMPONENT "grc"
-+)
+endif()
GR_PYTHON_INSTALL(
diff --git a/comms/gnuradio/files/patch-volk_CMakeLists.txt b/comms/gnuradio/files/patch-volk_CMakeLists.txt
index c40f2dbe8bf5..e7ed5d1768bf 100644
--- a/comms/gnuradio/files/patch-volk_CMakeLists.txt
+++ b/comms/gnuradio/files/patch-volk_CMakeLists.txt
@@ -1,6 +1,6 @@
---- volk/CMakeLists.txt.orig 2013-08-28 13:27:03.000000000 -0500
-+++ volk/CMakeLists.txt 2014-03-02 20:20:43.000000000 -0500
-@@ -97,7 +97,7 @@
+--- volk/CMakeLists.txt.orig 2014-07-07 17:29:01.000000000 -0400
++++ volk/CMakeLists.txt 2014-07-29 18:44:30.000000000 -0400
+@@ -102,7 +102,7 @@
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/volk.pc