aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio/files
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-05-30 20:39:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-05-30 20:39:12 +0000
commit3fef6c52f0fc4ef44d16f7c2f73fab20c9c251e5 (patch)
treec6487f309b5d29e868c4ea46df98e320c50df957 /comms/gnuradio/files
parent0b206685de74445cde7f184f18a43c7ac16172a6 (diff)
downloadports-3fef6c52f0fc4ef44d16f7c2f73fab20c9c251e5.tar.gz
ports-3fef6c52f0fc4ef44d16f7c2f73fab20c9c251e5.zip
Notes
Diffstat (limited to 'comms/gnuradio/files')
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake25
-rw-r--r--comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt11
2 files changed, 0 insertions, 36 deletions
diff --git a/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake b/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake
deleted file mode 100644
index fe86a14635d9..000000000000
--- a/comms/gnuradio/files/patch-cmake_Modules_FindPortaudio.cmake
+++ /dev/null
@@ -1,25 +0,0 @@
---- cmake/Modules/FindPortaudio.cmake.orig 2014-05-16 18:55:22.000000000 -0400
-+++ cmake/Modules/FindPortaudio.cmake 2014-08-04 21:57:47.000000000 -0400
-@@ -8,6 +8,15 @@
- include(FindPkgConfig)
- pkg_check_modules(PC_PORTAUDIO portaudio-2.0)
-
-+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+ message("--- Using Portaudio2 for FreeBSD")
-+ set(PORTAUDIO_FOUND_TRUE)
-+ set(PORTAUDIO_INCLUDE_DIRS "/usr/local/include/portaudio2")
-+ set(PORTAUDIO_LIBRARIES "/usr/local/lib/portaudio2/libportaudio.so")
-+ mark_as_advanced(PORTAUDIO_INCLUDE_DIRS PORTAUDIO_LIBRARIES)
-+ INCLUDE(FindPackageHandleStandardArgs)
-+ FIND_PACKAGE_HANDLE_STANDARD_ARGS(PORTAUDIO DEFAULT_MSG PORTAUDIO_INCLUDE_DIRS PORTAUDIO_LIBRARIES)
-+else()
- find_path(PORTAUDIO_INCLUDE_DIRS
- NAMES
- portaudio.h
-@@ -50,3 +59,6 @@
- set(PORTAUDIO_FOUND FALSE)
- endif(PORTAUDIO2_FOUND)
- endif()
-+
-+endif()
-+
diff --git a/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt b/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt
index 56e1c0ce577b..cf59ae092712 100644
--- a/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt
+++ b/comms/gnuradio/files/patch-gr-audio_lib_CMakeLists.txt
@@ -1,16 +1,5 @@
--- gr-audio/lib/CMakeLists.txt.orig 2014-07-02 21:09:41.000000000 -0400
+++ gr-audio/lib/CMakeLists.txt 2014-08-02 14:55:41.000000000 -0400
-@@ -136,8 +136,8 @@
-
- if(PORTAUDIO_FOUND)
-
-- include_directories(BEFORE ${CMAKE_CURRENT_SOURCE_DIR}/portaudio)
-- include_directories(${PORTAUDIO_INCLUDE_DIRS})
-+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/portaudio)
-+ include_directories(BEFORE ${PORTAUDIO_INCLUDE_DIRS})
- list(APPEND gr_audio_libs ${PORTAUDIO_LIBRARIES})
- add_definitions(${PORTAUDIO_DEFINITIONS})
- list(APPEND gr_audio_sources
@@ -184,7 +184,15 @@
target_link_libraries(gnuradio-audio ${gr_audio_libs})
GR_LIBRARY_FOO(gnuradio-audio RUNTIME_COMPONENT "audio_runtime" DEVEL_COMPONENT "audio_devel")