aboutsummaryrefslogtreecommitdiff
path: root/comms/gpsk31
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-21 20:51:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-21 20:51:09 +0000
commit63aae2fafba7e889a31ea5e5905328cab517d8bc (patch)
treec0f7e406a0bf0d65271cddda0423596c49d65393 /comms/gpsk31
parent96f8628b6c410e0754aa2c825004e73545018604 (diff)
downloadports-63aae2fafba7e889a31ea5e5905328cab517d8bc.tar.gz
ports-63aae2fafba7e889a31ea5e5905328cab517d8bc.zip
Notes
Diffstat (limited to 'comms/gpsk31')
-rw-r--r--comms/gpsk31/Makefile11
-rw-r--r--comms/gpsk31/distinfo5
-rw-r--r--comms/gpsk31/files/patch-call_dialog10
-rw-r--r--comms/gpsk31/files/patch-linux-sondcard33
-rw-r--r--comms/gpsk31/files/patch-src_server-main.C14
-rw-r--r--comms/gpsk31/pkg-plist7
6 files changed, 23 insertions, 57 deletions
diff --git a/comms/gpsk31/Makefile b/comms/gpsk31/Makefile
index db1f565da22c..c1b4d2ed83c8 100644
--- a/comms/gpsk31/Makefile
+++ b/comms/gpsk31/Makefile
@@ -5,15 +5,20 @@
# $FreeBSD$
PORTNAME= gpsk31
-PORTVERSION= 0.2.4a
+PORTVERSION= 0.3
CATEGORIES= comms
-MASTER_SITES= http://ftp.iasi.roedu.net/mirrors/ftp.1409.org/gpsk31/
+MASTER_SITES= http://www.qsl.net/pg4i/download/
MAINTAINER= xride@x12.dk
COMMENT= A gtk psk31 client
-USE_GNOME= gtk12
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
+post-patch:
+ @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+MAN1= gpsk31.1
.include <bsd.port.mk>
diff --git a/comms/gpsk31/distinfo b/comms/gpsk31/distinfo
index 1b6c1a73281d..91c8f5640dd6 100644
--- a/comms/gpsk31/distinfo
+++ b/comms/gpsk31/distinfo
@@ -1,2 +1,3 @@
-MD5 (gpsk31-0.2.4a.tar.gz) = da91b3a9e81d2f3c4c5ec40d3057ca35
-SIZE (gpsk31-0.2.4a.tar.gz) = 112009
+MD5 (gpsk31-0.3.tar.gz) = eccba44a5390543de597a379c2bdc006
+SHA256 (gpsk31-0.3.tar.gz) = 83270e38e351b139be58381966b477c590e216666d8b0d998919e7134316e71d
+SIZE (gpsk31-0.3.tar.gz) = 157509
diff --git a/comms/gpsk31/files/patch-call_dialog b/comms/gpsk31/files/patch-call_dialog
deleted file mode 100644
index 1fade7eda5c3..000000000000
--- a/comms/gpsk31/files/patch-call_dialog
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/call_dialog.C.orig Sun May 8 14:07:32 2005
-+++ src/call_dialog.C Sun May 8 14:08:01 2005
-@@ -27,6 +27,7 @@
-
- #include <gtk/gtk.h>
- #include <ctype.h>
-+#include <string.h>
- #include "main_screen.h"
- #include "call_dialog.h"
- #include "menu.h"
diff --git a/comms/gpsk31/files/patch-linux-sondcard b/comms/gpsk31/files/patch-linux-sondcard
deleted file mode 100644
index 3721fe13c647..000000000000
--- a/comms/gpsk31/files/patch-linux-sondcard
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/main.C.orig Sun May 8 14:01:27 2005
-+++ src/main.C Sun May 8 14:01:43 2005
-@@ -29,7 +29,7 @@
- #include <sys/types.h>
- #include <unistd.h>
- #include <stdio.h>
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
- #include <sys/ioctl.h>
- #include <sys/stat.h>
- #include <fcntl.h>
---- src/psk31-transmitter.C.orig Sun May 8 14:02:00 2005
-+++ src/psk31-transmitter.C Sun May 8 14:02:14 2005
-@@ -11,7 +11,7 @@
- #include <errno.h>
- #include <stdio.h>
- #include <stdlib.h>
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
- #include <sys/ioctl.h>
- #include "psk31-coder.h"
- #include "psk31-transmitter.h"
---- src/spectrum.C.orig Sun May 8 14:02:28 2005
-+++ src/spectrum.C Sun May 8 14:03:01 2005
-@@ -30,7 +30,7 @@
- #include <stdlib.h>
- #include <sys/ioctl.h>
- #include <fcntl.h>
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
-
- #include <gtk/gtk.h>
- #include <stdio.h>
diff --git a/comms/gpsk31/files/patch-src_server-main.C b/comms/gpsk31/files/patch-src_server-main.C
index 4305870bed40..aa4682b3fa0c 100644
--- a/comms/gpsk31/files/patch-src_server-main.C
+++ b/comms/gpsk31/files/patch-src_server-main.C
@@ -1,10 +1,10 @@
---- src/server-main.C.orig Sun May 8 13:28:03 2005
-+++ src/server-main.C Sun May 8 13:28:18 2005
-@@ -19,6 +19,7 @@
- * thread and from user interface thread (==interface functions)
+--- src/server-main.C.orig Wed Nov 2 09:54:12 2005
++++ src/server-main.C Sun Dec 18 18:37:29 2005
+@@ -20,7 +20,6 @@
*/
-+#include <sys/types.h>
- #include <sys/mman.h>
- #include "config.h"
+
+-#include <sys/mman.h>
#include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/comms/gpsk31/pkg-plist b/comms/gpsk31/pkg-plist
index 9e841147f1d2..5b2b2ebae2c2 100644
--- a/comms/gpsk31/pkg-plist
+++ b/comms/gpsk31/pkg-plist
@@ -1,4 +1,7 @@
bin/gpsk31
-share/gpsk31/gpsk31.conf
-share/gpsk31/psk31.cod
+%%DATADIR%%/gpsk.conf
+%%DATADIR%%/psk31.cod
+%%DATADIR%%/README
+share/applications/gpsk31.desktop
@dirrm share/gpsk31
+@dirrm share/applications